aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>2004-03-30 19:53:09 +0000
committerBill Fumerola <billf@FreeBSD.org>2004-03-30 19:53:09 +0000
commitc6f7e574ed68c7363c234c63e9d7af5f6599b904 (patch)
tree49c54699e07579b78d10231c1afb86601c388fdb /net/wireshark
parentbee5136a1187f7c94d65efd02e79a3d2f2a40bdd (diff)
downloadports-c6f7e574ed68c7363c234c63e9d7af5f6599b904.tar.gz
ports-c6f7e574ed68c7363c234c63e9d7af5f6599b904.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile87
-rw-r--r--net/wireshark/distinfo3
-rw-r--r--net/wireshark/pkg-plist67
3 files changed, 105 insertions, 52 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 6b9be24c85f2..83609e848c95 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -6,71 +6,98 @@
#
PORTNAME= ethereal
-PORTVERSION= 0.10.0a
-PORTREVISION= 2
+PORTVERSION= 0.10.3
CATEGORIES= net ipv6
-MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/%SUBDIR%/ \
- ftp://gd.tuwien.ac.at/infosys/security/ethereal/%SUBDIR%/ \
- ftp://ftp.sunet.se/pub/network/monitoring/ethereal/%SUBDIR%/ \
- ftp://ftp.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/%SUBDIR%/ \
- http://www.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old-versions
+MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
+ ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
+ ftp://ftp.sunet.se/pub/network/monitoring/ethereal/all-versions/ \
+ ftp://ftp.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/all-versions/ \
+ http://www.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/all-versions/
MAINTAINER= billf@FreeBSD.org
-COMMENT= An X11/GTK network analyzer/capture tool
-FORBIDDEN= http://www.vuxml.org/freebsd/cdf18ed9-7f4a-11d8-9645-0020ed76ef5a.html
+COMMENT?= A powerful network analyzer/capture tool
USE_BZIP2= yes
WANT_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --program-transform-name=""
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_SNMP)
-LIB_DEPENDS= netsnmp.6:${PORTSDIR}/net-mgmt/net-snmp
+.for x in editcap idl2eth mergecap text2pcap
+.if defined(LITE)
+PLIST_SUB+= ${x:U}="@comment $x not installed"
+CONFIGURE_ARGS+= --enable-$x=no
+.else
+PLIST_SUB+= ${x:U}=bin/$x
+MAN1+= $x.1
.endif
+.endfor
-CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.if !defined(WITHOUT_X11)
USE_X_PREFIX= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_X11)
+MAN1+= ethereal.1
+PLIST_SUB+= ETHEREAL=bin/ethereal
.if defined(WITH_GTK2) || (${HAVE_GNOME:Mgtk20}!="")
USE_GNOME= gtk20
CONFIGURE_ARGS+= --enable-gtk2=yes
.else
USE_GNOME= gtk12
.endif
-MAN1+= ethereal.1
-PLIST_SUB+= ETHEREAL=bin/ethereal
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
USE_GNOME= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
- --disable-gtktest
+ --disable-gtktest \
+ --with-gtk-prefix=/nonexistant \
+ --enable-gtk2=no
.endif
USE_LIBTOOL_VER=13
-LIBTOOLFILES= configure epan/configure wiretap/configure
+LIBTOOLFILES= configure epan/configure wiretap/configure doc/configure \
+ plugins/gryphon/configure
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-.if !defined(WITHOUT_SNMP)
-CONFIGURE_ARGS+= --enable-snmp=yes \
- --with-net-snmp=${LOCALBASE}/lib \
- --without-ucdsnmp
+.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6=yes
+.else
+CONFIGURE_ARGS+= --enable-ipv6=no
+.endif
+
.if exists(/usr/include/openssl/crypto.h)
CONFIGURE_ARGS+= --with-ssl=/usr
.endif
+
+# XXX - untested
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+.endif
+
+.if !defined(WITHOUT_PCRE) && !defined(LITE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}/lib
.else
-CONFIGURE_ARGS+= --enable-snmp=no --without-ucdsnmp --without-net-snmp
+CONFIGURE_ARGS+= --with-pcre=no
.endif
-.if defined(WITH_ADNS) || (!defined(WITHOUT_ADNS) && exists(${LOCALBASE}/lib/adns.so))
+.if !defined(WITHOUT_SNMP) && !defined(LITE)
+LIB_DEPENDS+= netsnmp.6:${PORTSDIR}/net-mgmt/net-snmp
+CONFIGURE_ARGS+= --with-net-snmp=${LOCALBASE}/bin/net-snmp-config
+.else
+CONFIGURE_ARGS+= --enable-snmp=no --with-ucd-snmp=no --with-net-snmp=no
+.endif
+
+.if !defined(WITHOUT_ADNS) && !defined(LITE)
LIB_DEPENDS+= adns.1:${PORTSDIR}/dns/adns
-.include <bsd.port.post.mk>
+CONFIGURE_ARGS+= --with-adns=${LOCALBASE}/lib
.else
-CONFIGURE_ARGS+= --without-adns
+CONFIGURE_ARGS+= --with-adns=no
.endif
-MAN1+= editcap.1 idl2eth.1 mergecap.1 tethereal.1 text2pcap.1
-MAN4+= ethereal-filter.4
+MAN1+= tethereal.1
+MAN4+= ethereal-filter.4
.include <bsd.port.post.mk>
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
index fe1fc01e1d62..137745bd7f2f 100644
--- a/net/wireshark/distinfo
+++ b/net/wireshark/distinfo
@@ -1 +1,2 @@
-MD5 (ethereal-0.10.0a.tar.bz2) = 1e31508c5509272595fa237d074461b1
+MD5 (ethereal-0.10.3.tar.bz2) = 6902272eb5304f57db76bf91abe453d1
+SIZE (ethereal-0.10.3.tar.bz2) = 4840005
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index b69366257499..aa0fbe98374c 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -1,45 +1,70 @@
-bin/editcap
+%%EDITCAP%%
%%ETHEREAL%%
-bin/idl2eth
-bin/mergecap
+%%IDL2ETH%%
+%%MERGECAP%%
bin/tethereal
-bin/text2pcap
-lib/ethereal/plugins/%%PORTVERSION%%/acn.so
+%%TEXT2PCAP%%
lib/ethereal/plugins/%%PORTVERSION%%/acn.la
-lib/ethereal/plugins/%%PORTVERSION%%/asn1.so
-lib/ethereal/plugins/%%PORTVERSION%%/asn1.la
-lib/ethereal/plugins/%%PORTVERSION%%/artnet.so
+lib/ethereal/plugins/%%PORTVERSION%%/acn.so
lib/ethereal/plugins/%%PORTVERSION%%/artnet.la
-lib/ethereal/plugins/%%PORTVERSION%%/docsis.so
+lib/ethereal/plugins/%%PORTVERSION%%/artnet.so
+lib/ethereal/plugins/%%PORTVERSION%%/asn1.la
+lib/ethereal/plugins/%%PORTVERSION%%/asn1.so
+lib/ethereal/plugins/%%PORTVERSION%%/ciscosm.la
+lib/ethereal/plugins/%%PORTVERSION%%/ciscosm.so
+lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.la
+lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.so
+lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.la
+lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.so
lib/ethereal/plugins/%%PORTVERSION%%/docsis.la
-lib/ethereal/plugins/%%PORTVERSION%%/enttec.so
+lib/ethereal/plugins/%%PORTVERSION%%/docsis.so
lib/ethereal/plugins/%%PORTVERSION%%/enttec.la
-lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.so
-lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.la
-lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.so
-lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.la
-lib/ethereal/plugins/%%PORTVERSION%%/gryphon.so
+lib/ethereal/plugins/%%PORTVERSION%%/enttec.so
lib/ethereal/plugins/%%PORTVERSION%%/gryphon.la
-lib/ethereal/plugins/%%PORTVERSION%%/lwres.so
+lib/ethereal/plugins/%%PORTVERSION%%/gryphon.so
+lib/ethereal/plugins/%%PORTVERSION%%/irda.la
+lib/ethereal/plugins/%%PORTVERSION%%/irda.so
lib/ethereal/plugins/%%PORTVERSION%%/lwres.la
-lib/ethereal/plugins/%%PORTVERSION%%/megaco.so
+lib/ethereal/plugins/%%PORTVERSION%%/lwres.so
lib/ethereal/plugins/%%PORTVERSION%%/megaco.la
-lib/ethereal/plugins/%%PORTVERSION%%/mgcp.so
+lib/ethereal/plugins/%%PORTVERSION%%/megaco.so
lib/ethereal/plugins/%%PORTVERSION%%/mgcp.la
-lib/ethereal/plugins/%%PORTVERSION%%/pcli.so
+lib/ethereal/plugins/%%PORTVERSION%%/mgcp.so
lib/ethereal/plugins/%%PORTVERSION%%/pcli.la
-lib/ethereal/plugins/%%PORTVERSION%%/rdm.so
+lib/ethereal/plugins/%%PORTVERSION%%/pcli.so
lib/ethereal/plugins/%%PORTVERSION%%/rdm.la
-lib/ethereal/plugins/%%PORTVERSION%%/rtnet.so
+lib/ethereal/plugins/%%PORTVERSION%%/rdm.so
+lib/ethereal/plugins/%%PORTVERSION%%/rlm.la
+lib/ethereal/plugins/%%PORTVERSION%%/rlm.so
lib/ethereal/plugins/%%PORTVERSION%%/rtnet.la
+lib/ethereal/plugins/%%PORTVERSION%%/rtnet.so
+lib/ethereal/plugins/%%PORTVERSION%%/rudp.la
+lib/ethereal/plugins/%%PORTVERSION%%/rudp.so
+lib/ethereal/plugins/%%PORTVERSION%%/v5ua.la
+lib/ethereal/plugins/%%PORTVERSION%%/v5ua.so
+lib/libethereal.la
+lib/libethereal.so
+lib/libethereal.so.0
+lib/libwiretap.la
+lib/libwiretap.so
+lib/libwiretap.so.0
share/ethereal/diameter/dictionary.dtd
share/ethereal/diameter/dictionary.xml
share/ethereal/diameter/mobileipv4.xml
share/ethereal/diameter/nasreq.xml
share/ethereal/diameter/sunping.xml
+share/ethereal/help/capture_filters.txt
+share/ethereal/help/capturing.txt
+share/ethereal/help/display_filters.txt
+share/ethereal/help/faq.txt
+share/ethereal/help/getting_started.txt
+share/ethereal/help/overview.txt
+share/ethereal/help/toc
+share/ethereal/help/well_known.txt
share/ethereal/manuf
@dirrm lib/ethereal/plugins/%%PORTVERSION%%
@dirrm lib/ethereal/plugins
@dirrm lib/ethereal
@dirrm share/ethereal/diameter
+@dirrm share/ethereal/help
@dirrm share/ethereal