aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-07-18 05:03:53 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-07-18 05:03:53 +0000
commita69db4b2a0cc19923f24ac9b55d645cf1db6d8da (patch)
tree98a19e9c31aaa1c2bdbd027c050a89254d4bc9a6 /net/wireshark
parentd50c601e45debeee371b18341da87d51ac8a74b5 (diff)
downloadports-a69db4b2a0cc19923f24ac9b55d645cf1db6d8da.tar.gz
ports-a69db4b2a0cc19923f24ac9b55d645cf1db6d8da.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile28
-rw-r--r--net/wireshark/distinfo6
-rw-r--r--net/wireshark/files/patch-configure29
-rw-r--r--net/wireshark/files/patch-epan_dissectors_packet-radiotap.c198
-rw-r--r--net/wireshark/pkg-plist140
5 files changed, 103 insertions, 298 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index f9f24f214944..a0583cc27005 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -5,13 +5,11 @@
# $FreeBSD$
#
-PORTNAME= ethereal
-PORTVERSION= 0.99.0
-PORTREVISION?= 3
+PORTNAME?= wireshark
+PORTVERSION= 0.99.2
+PORTREVISION?= 0
CATEGORIES= net ipv6
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ftp://ftp.ethereal.com/pub/ethereal/all-versions/
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://www.wireshark.org/download/src/
MAINTAINER= marcus@FreeBSD.org
COMMENT?= A powerful network analyzer/capture tool
@@ -30,7 +28,7 @@ CONFIGURE_ARGS+= --program-transform-name="" \
MAKE_ENV= MIBDIRS="/dev/null"
INSTALLS_SHLIB= yes
-.for x in capinfos editcap idl2eth mergecap text2pcap
+.for x in capinfos editcap idl2wrs mergecap text2pcap
.if defined(LITE)
PLIST_SUB+= ${x:U}="@comment $x not installed"
CONFIGURE_ARGS+= --enable-$x=no
@@ -50,14 +48,14 @@ PLIST_SUB+= ${x:U}=bin/$x
.endfor
.if !defined(WITHOUT_X11)
-USE_X_PREFIX= yes
+USE_XLIB= yes
.endif
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_X11)
-MAN1+= ethereal.1
-PLIST_SUB+= ETHEREAL=bin/ethereal
+MAN1+= wireshark.1
+PLIST_SUB+= WIRESHARK=bin/wireshark
.if defined(WITHOUT_GTK2)
USE_GNOME+= gtk12
CONFIGURE_ARGS+= --disable-gtk2
@@ -65,9 +63,9 @@ CONFIGURE_ARGS+= --disable-gtk2
USE_GNOME+= gtk20
.endif
.else
-PLIST_SUB+= ETHEREAL="@comment ethereal not built"
+PLIST_SUB+= WIRESHARK="@comment wireshark not built"
USE_GNOME+= glib12
-CONFIGURE_ARGS+= --enable-ethereal=no \
+CONFIGURE_ARGS+= --enable-wireshark=no \
--disable-gtktest \
--with-gtk-prefix=/nonexistent \
--disable-gtk2
@@ -115,10 +113,10 @@ CONFIGURE_ARGS+= --with-adns=no
.if exists(${LOCALBASE}/lib/libgnutls.so) || defined(WITH_GNUTLS)
LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-libgnutls-prefix=${LOCALBASE}
+CONFIGURE_ARGS+=--with-libgnutls-prefix=${LOCALBASE}
.endif
-MAN1+= dumpcap.1 tethereal.1
-MAN4+= ethereal-filter.4
+MAN1+= dumpcap.1 tshark.1
+MAN4+= wireshark-filter.4
.include <bsd.port.post.mk>
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
index d40b51ecb138..6d2e607a9e45 100644
--- a/net/wireshark/distinfo
+++ b/net/wireshark/distinfo
@@ -1,3 +1,3 @@
-MD5 (ethereal-0.99.0.tar.gz) = 92490abe23df1b2078579c512c788f9d
-SHA256 (ethereal-0.99.0.tar.gz) = 2aa3030064783c2390d177ba6ad7f784d0c813895197a67f33f5d3e04690635a
-SIZE (ethereal-0.99.0.tar.gz) = 11284145
+MD5 (wireshark-0.99.2.tar.gz) = 46d3b7c9766960fb34782c2078c50d13
+SHA256 (wireshark-0.99.2.tar.gz) = ef2f857fd8d1001890b86834dc3275214f7717fa6948c27829f6575d9b8023bf
+SIZE (wireshark-0.99.2.tar.gz) = 12358081
diff --git a/net/wireshark/files/patch-configure b/net/wireshark/files/patch-configure
index 87b2baa4bdda..ea1bda2c8ac6 100644
--- a/net/wireshark/files/patch-configure
+++ b/net/wireshark/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed May 4 17:32:34 2005
-+++ configure Sat May 7 21:07:38 2005
-@@ -21806,6 +21806,7 @@
+--- configure.orig Tue Jul 18 00:20:03 2006
++++ configure Tue Jul 18 00:19:03 2006
+@@ -22210,6 +22210,7 @@ echo $ECHO_N "checking for GLIB - versio
else
GLIB_CFLAGS=`$GLIB_CONFIG $glib_config_args --cflags`
GLIB_LIBS=`$GLIB_CONFIG $glib_config_args --libs`
@@ -8,7 +8,7 @@
glib_config_major_version=`$GLIB_CONFIG $glib_config_args --version | \
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
glib_config_minor_version=`$GLIB_CONFIG $glib_config_args --version | \
-@@ -21816,7 +21817,7 @@
+@@ -22220,7 +22221,7 @@ echo $ECHO_N "checking for GLIB - versio
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
@@ -17,7 +17,7 @@
rm -f conf.glibtest
if test "$cross_compiling" = yes; then
echo $ac_n "cross compiling; assumed OK... $ac_c"
-@@ -22452,6 +22453,7 @@
+@@ -22854,6 +22855,7 @@ echo $ECHO_N "checking for GLIB - versio
else
GLIB_CFLAGS=`$GLIB_CONFIG $glib_config_args --cflags`
GLIB_LIBS=`$GLIB_CONFIG $glib_config_args --libs`
@@ -25,16 +25,15 @@
glib_config_major_version=`$GLIB_CONFIG $glib_config_args --version | \
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
glib_config_minor_version=`$GLIB_CONFIG $glib_config_args --version | \
-@@ -22462,7 +22464,7 @@
- ac_save_CFLAGS="$CFLAGS"
+@@ -22865,6 +22867,7 @@ echo $ECHO_N "checking for GLIB - versio
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
-- LIBS="$GLIB_LIBS $LIBS"
+ LIBS="$GLIB_LIBS $LIBS"
+ LIBS="$GLIB_LIBS -liconv $LIBS"
rm -f conf.glibtest
if test "$cross_compiling" = yes; then
echo $ac_n "cross compiling; assumed OK... $ac_c"
-@@ -22683,7 +22685,7 @@
+@@ -23084,7 +23087,7 @@ echo $ECHO_N "checking whether GLib supp
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
@@ -43,7 +42,7 @@
if test "$cross_compiling" = yes; then
echo $ac_n "cross compiling; assumed OK... $ac_c"
ac_cv_glib_supports_modules=yes
-@@ -27560,7 +27562,7 @@
+@@ -28684,7 +28687,7 @@ echo "${ECHO_T}yes" >&6
#
CFLAGS="$CFLAGS -I$krb5_dir/include"
CPPFLAGS="$CPPFLAGS -I$krb5_dir/include"
@@ -52,7 +51,7 @@
ac_mit_version=`grep 'Massachusetts Institute of Technology' $krb5_dir/include/krb5.h | head -n 1 | sed 's/^.*Massachusetts Institute of Technology.*$/MIT/'`
ac_krb5_version="$ac_heimdal_version$ac_mit_version"
if test "x$ac_krb5_version" = "xHEIMDAL"
-@@ -27618,7 +27620,7 @@
+@@ -28742,7 +28745,7 @@ fi
if test -x "$KRB5_CONFIG"
then
@@ -61,7 +60,7 @@
KRB5_LIBS=`"$KRB5_CONFIG" --libs`
CFLAGS="$CFLAGS $KRB5_FLAGS"
CPPFLAGS="$CPPFLAGS $KRB5_FLAGS"
-@@ -29121,7 +29123,7 @@
+@@ -30342,7 +30345,7 @@ fi
ac_save_LIBS="$LIBS"
@@ -70,12 +69,12 @@
G_ASCII_STRTOULL_C=""
G_ASCII_STRTOULL_O=""
G_ASCII_STRTOULL_LO=""
-@@ -30094,7 +30096,7 @@
+@@ -31509,7 +31512,7 @@ fi
#
# The plugin dissectors reside in ./plugins/PROTO/
#
--PLUGIN_LIBS="-L../../epan -lethereal $GLIB_LIBS"
-+PLUGIN_LIBS="-L../../epan -lethereal -liconv $GLIB_LIBS"
+-PLUGIN_LIBS="-L../../epan -lwireshark $GLIB_LIBS"
++PLUGIN_LIBS="-L../../epan -lwireshark -liconv $GLIB_LIBS"
#
diff --git a/net/wireshark/files/patch-epan_dissectors_packet-radiotap.c b/net/wireshark/files/patch-epan_dissectors_packet-radiotap.c
deleted file mode 100644
index f66df6cb6f14..000000000000
--- a/net/wireshark/files/patch-epan_dissectors_packet-radiotap.c
+++ /dev/null
@@ -1,198 +0,0 @@
---- epan/dissectors/packet-radiotap.c.orig Mon Apr 17 14:46:52 2006
-+++ epan/dissectors/packet-radiotap.c Fri Apr 28 19:21:24 2006
-@@ -382,7 +382,7 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- proto_item *ti = NULL;
- int offset;
- guint32 version, pad;
-- guint32 length;
-+ guint length, length_remaining;
- guint32 rate, freq, flags;
- gint8 dbm;
- guint8 db, rflags;
-@@ -416,11 +416,13 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- ti = proto_tree_add_uint(radiotap_tree, hf_radiotap_length,
- tvb, offset + 2, 2, length);
- }
-+ length_remaining = length;
-+
- /*
- * FIXME: This only works if there is exactly 1 it_present
- * field in the header
- */
-- if (length < sizeof(struct ieee80211_radiotap_header)) {
-+ if (length_remaining < sizeof(struct ieee80211_radiotap_header)) {
- /*
- * Radiotap header is shorter than the fixed-length portion
- * plus one "present" bitset.
-@@ -435,7 +437,7 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- present_tree = proto_item_add_subtree(pt, ett_radiotap_present);
- }
- offset += sizeof(struct ieee80211_radiotap_header);
-- length -= sizeof(struct ieee80211_radiotap_header);
-+ length_remaining -= sizeof(struct ieee80211_radiotap_header);
-
- rflags = 0;
- for (; present; present = next_present) {
-@@ -447,7 +449,7 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
-
- switch (bit) {
- case IEEE80211_RADIOTAP_FLAGS:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
- rflags = tvb_get_guint8(tvb, offset);
- if (tree) {
-@@ -459,13 +461,12 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- tvb, 0, 0, (rflags&IEEE80211_RADIOTAP_F_DATAPAD) != 0);
- }
- offset++;
-- length--;
-+ length_remaining--;
- /* XXX CFP, WEP, FRAG */
- break;
- case IEEE80211_RADIOTAP_RATE:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- rate = tvb_get_guint8(tvb, offset) & 0x7f;
- if (check_col(pinfo->cinfo, COL_TX_RATE)) {
- col_add_fstr(pinfo->cinfo, COL_TX_RATE, "%d.%d",
-@@ -477,12 +478,11 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- "Data Rate: %d.%d Mb/s", rate / 2, rate & 1 ? 5 : 0);
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_DBM_ANTSIGNAL:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- dbm = (gint8) tvb_get_guint8(tvb, offset);
- if (check_col(pinfo->cinfo, COL_RSSI)) {
- col_add_fstr(pinfo->cinfo, COL_RSSI, "%d dBm", dbm);
-@@ -494,12 +494,11 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- "SSI Signal: %d dBm", dbm);
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_DB_ANTSIGNAL:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- db = tvb_get_guint8(tvb, offset);
- if (check_col(pinfo->cinfo, COL_RSSI)) {
- col_add_fstr(pinfo->cinfo, COL_RSSI, "%u dB", db);
-@@ -511,12 +510,11 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- "SSI Signal: %u dB", db);
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_DBM_ANTNOISE:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- dbm = (gint8) tvb_get_guint8(tvb, offset);
- if (tree) {
- proto_tree_add_int_format(radiotap_tree,
-@@ -525,12 +523,11 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- "SSI Noise: %d dBm", dbm);
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_DB_ANTNOISE:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- db = tvb_get_guint8(tvb, offset);
- if (tree) {
- proto_tree_add_uint_format(radiotap_tree,
-@@ -539,34 +536,31 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- "SSI Noise: %u dB", db);
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_ANTENNA:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- if (tree) {
- proto_tree_add_uint(radiotap_tree, hf_radiotap_antenna,
- tvb, offset, 1, tvb_get_guint8(tvb, offset));
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_DBM_TX_POWER:
-- if (length < 1)
-+ if (length_remaining < 1)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- if (tree) {
- proto_tree_add_int(radiotap_tree, hf_radiotap_txpower,
- tvb, offset, 1, tvb_get_guint8(tvb, offset));
- }
- offset++;
-- length--;
-+ length_remaining--;
- break;
- case IEEE80211_RADIOTAP_CHANNEL:
-- if (length < 4)
-+ if (length_remaining < 4)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- if (tree) {
- freq = tvb_get_letohs(tvb, offset);
- flags = tvb_get_letohs(tvb, offset+2);
-@@ -577,31 +571,29 @@ dissect_radiotap(tvbuff_t *tvb, packet_i
- tvb, offset+2, 2, flags);
- }
- offset+=4;
-- length-=4;
-+ length_remaining-=4;
- break;
- case IEEE80211_RADIOTAP_FHSS:
- case IEEE80211_RADIOTAP_LOCK_QUALITY:
- case IEEE80211_RADIOTAP_TX_ATTENUATION:
- case IEEE80211_RADIOTAP_DB_TX_ATTENUATION:
-- if (length < 2)
-+ if (length_remaining < 2)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- #if 0
- tvb_get_letohs(tvb, offset);
- #endif
- offset+=2;
-- length-=2;
-+ length_remaining-=2;
- break;
- case IEEE80211_RADIOTAP_TSFT:
-- if (length < 8)
-+ if (length_remaining < 8)
- break;
-- rflags = tvb_get_guint8(tvb, offset);
- if (tree) {
- proto_tree_add_uint64(radiotap_tree, hf_radiotap_mactime,
- tvb, offset, 8, tvb_get_letoh64(tvb, offset));
- }
- offset+=8;
-- length-=8;
-+ length_remaining-=8;
- break;
- default:
- /*
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index 1c22f5efccfb..5b5c5009d2cd 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -2,69 +2,71 @@
%%DFTEST%%
bin/dumpcap
%%EDITCAP%%
-%%ETHEREAL%%
-%%IDL2ETH%%
+%%WIRESHARK%%
+%%IDL2WRS%%
%%MERGECAP%%
%%RANDPKT%%
-bin/tethereal
+bin/tshark
%%TEXT2PCAP%%
-lib/ethereal/plugins/%%PORTVERSION%%/acn.la
-lib/ethereal/plugins/%%PORTVERSION%%/acn.so
-lib/ethereal/plugins/%%PORTVERSION%%/agentx.la
-lib/ethereal/plugins/%%PORTVERSION%%/agentx.so
-lib/ethereal/plugins/%%PORTVERSION%%/artnet.la
-lib/ethereal/plugins/%%PORTVERSION%%/artnet.so
-lib/ethereal/plugins/%%PORTVERSION%%/asn1.la
-lib/ethereal/plugins/%%PORTVERSION%%/asn1.so
-lib/ethereal/plugins/%%PORTVERSION%%/ciscosm.la
-lib/ethereal/plugins/%%PORTVERSION%%/ciscosm.so
-lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.la
-lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.so
-lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.la
-lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.so
-lib/ethereal/plugins/%%PORTVERSION%%/docsis.la
-lib/ethereal/plugins/%%PORTVERSION%%/docsis.so
-lib/ethereal/plugins/%%PORTVERSION%%/enttec.la
-lib/ethereal/plugins/%%PORTVERSION%%/enttec.so
-lib/ethereal/plugins/%%PORTVERSION%%/gryphon.la
-lib/ethereal/plugins/%%PORTVERSION%%/gryphon.so
-lib/ethereal/plugins/%%PORTVERSION%%/h223.la
-lib/ethereal/plugins/%%PORTVERSION%%/h223.so
-lib/ethereal/plugins/%%PORTVERSION%%/irda.la
-lib/ethereal/plugins/%%PORTVERSION%%/irda.so
-lib/ethereal/plugins/%%PORTVERSION%%/lwres.la
-lib/ethereal/plugins/%%PORTVERSION%%/lwres.so
-lib/ethereal/plugins/%%PORTVERSION%%/mate.la
-lib/ethereal/plugins/%%PORTVERSION%%/mate.so
-lib/ethereal/plugins/%%PORTVERSION%%/megaco.la
-lib/ethereal/plugins/%%PORTVERSION%%/megaco.so
-lib/ethereal/plugins/%%PORTVERSION%%/mgcp.la
-lib/ethereal/plugins/%%PORTVERSION%%/mgcp.so
-lib/ethereal/plugins/%%PORTVERSION%%/opsi.la
-lib/ethereal/plugins/%%PORTVERSION%%/opsi.so
-lib/ethereal/plugins/%%PORTVERSION%%/parlay.la
-lib/ethereal/plugins/%%PORTVERSION%%/parlay.so
-lib/ethereal/plugins/%%PORTVERSION%%/pcli.la
-lib/ethereal/plugins/%%PORTVERSION%%/pcli.so
-lib/ethereal/plugins/%%PORTVERSION%%/profinet.la
-lib/ethereal/plugins/%%PORTVERSION%%/profinet.so
-lib/ethereal/plugins/%%PORTVERSION%%/rdm.la
-lib/ethereal/plugins/%%PORTVERSION%%/rdm.so
-lib/ethereal/plugins/%%PORTVERSION%%/rlm.la
-lib/ethereal/plugins/%%PORTVERSION%%/rlm.so
-lib/ethereal/plugins/%%PORTVERSION%%/rtnet.la
-lib/ethereal/plugins/%%PORTVERSION%%/rtnet.so
-lib/ethereal/plugins/%%PORTVERSION%%/rudp.la
-lib/ethereal/plugins/%%PORTVERSION%%/rudp.so
-lib/ethereal/plugins/%%PORTVERSION%%/stats_tree.la
-lib/ethereal/plugins/%%PORTVERSION%%/stats_tree.so
-lib/ethereal/plugins/%%PORTVERSION%%/tango.la
-lib/ethereal/plugins/%%PORTVERSION%%/tango.so
-lib/ethereal/plugins/%%PORTVERSION%%/v5ua.la
-lib/ethereal/plugins/%%PORTVERSION%%/v5ua.so
-lib/libethereal.la
-lib/libethereal.so
-lib/libethereal.so.0
+lib/wireshark/plugins/%%PORTVERSION%%/acn.la
+lib/wireshark/plugins/%%PORTVERSION%%/acn.so
+lib/wireshark/plugins/%%PORTVERSION%%/agentx.la
+lib/wireshark/plugins/%%PORTVERSION%%/agentx.so
+lib/wireshark/plugins/%%PORTVERSION%%/artnet.la
+lib/wireshark/plugins/%%PORTVERSION%%/artnet.so
+lib/wireshark/plugins/%%PORTVERSION%%/asn1.la
+lib/wireshark/plugins/%%PORTVERSION%%/asn1.so
+lib/wireshark/plugins/%%PORTVERSION%%/ciscosm.la
+lib/wireshark/plugins/%%PORTVERSION%%/ciscosm.so
+lib/wireshark/plugins/%%PORTVERSION%%/coseventcomm.la
+lib/wireshark/plugins/%%PORTVERSION%%/coseventcomm.so
+lib/wireshark/plugins/%%PORTVERSION%%/cosnaming.la
+lib/wireshark/plugins/%%PORTVERSION%%/cosnaming.so
+lib/wireshark/plugins/%%PORTVERSION%%/docsis.la
+lib/wireshark/plugins/%%PORTVERSION%%/docsis.so
+lib/wireshark/plugins/%%PORTVERSION%%/enttec.la
+lib/wireshark/plugins/%%PORTVERSION%%/enttec.so
+lib/wireshark/plugins/%%PORTVERSION%%/gryphon.la
+lib/wireshark/plugins/%%PORTVERSION%%/gryphon.so
+lib/wireshark/plugins/%%PORTVERSION%%/h223.la
+lib/wireshark/plugins/%%PORTVERSION%%/h223.so
+lib/wireshark/plugins/%%PORTVERSION%%/irda.la
+lib/wireshark/plugins/%%PORTVERSION%%/irda.so
+lib/wireshark/plugins/%%PORTVERSION%%/lwres.la
+lib/wireshark/plugins/%%PORTVERSION%%/lwres.so
+lib/wireshark/plugins/%%PORTVERSION%%/mate.la
+lib/wireshark/plugins/%%PORTVERSION%%/mate.so
+lib/wireshark/plugins/%%PORTVERSION%%/megaco.la
+lib/wireshark/plugins/%%PORTVERSION%%/megaco.so
+lib/wireshark/plugins/%%PORTVERSION%%/mgcp.la
+lib/wireshark/plugins/%%PORTVERSION%%/mgcp.so
+lib/wireshark/plugins/%%PORTVERSION%%/opsi.la
+lib/wireshark/plugins/%%PORTVERSION%%/opsi.so
+lib/wireshark/plugins/%%PORTVERSION%%/parlay.la
+lib/wireshark/plugins/%%PORTVERSION%%/parlay.so
+lib/wireshark/plugins/%%PORTVERSION%%/pcli.la
+lib/wireshark/plugins/%%PORTVERSION%%/pcli.so
+lib/wireshark/plugins/%%PORTVERSION%%/profinet.la
+lib/wireshark/plugins/%%PORTVERSION%%/profinet.so
+lib/wireshark/plugins/%%PORTVERSION%%/rdm.la
+lib/wireshark/plugins/%%PORTVERSION%%/rdm.so
+lib/wireshark/plugins/%%PORTVERSION%%/rlm.la
+lib/wireshark/plugins/%%PORTVERSION%%/rlm.so
+lib/wireshark/plugins/%%PORTVERSION%%/rtnet.la
+lib/wireshark/plugins/%%PORTVERSION%%/rtnet.so
+lib/wireshark/plugins/%%PORTVERSION%%/rudp.la
+lib/wireshark/plugins/%%PORTVERSION%%/rudp.so
+lib/wireshark/plugins/%%PORTVERSION%%/sbus.la
+lib/wireshark/plugins/%%PORTVERSION%%/sbus.so
+lib/wireshark/plugins/%%PORTVERSION%%/stats_tree.la
+lib/wireshark/plugins/%%PORTVERSION%%/stats_tree.so
+lib/wireshark/plugins/%%PORTVERSION%%/tango.la
+lib/wireshark/plugins/%%PORTVERSION%%/tango.so
+lib/wireshark/plugins/%%PORTVERSION%%/v5ua.la
+lib/wireshark/plugins/%%PORTVERSION%%/v5ua.so
+lib/libwireshark.la
+lib/libwireshark.so
+lib/libwireshark.so.0
lib/libwiretap.la
lib/libwiretap.so
lib/libwiretap.so.0
@@ -84,11 +86,15 @@ lib/libwiretap.so.0
%%DATADIR%%/diameter/sunping.xml
%%DATADIR%%/dtds/dc.dtd
%%DATADIR%%/dtds/itunes.dtd
+%%DATADIR%%/dtds/pocsettings.dtd
+%%DATADIR%%/dtds/presence.dtd
+%%DATADIR%%/dtds/reginfo.dtd
%%DATADIR%%/dtds/rss.dtd
%%DATADIR%%/dtds/smil.dtd
+%%DATADIR%%/dtds/watcherinfo.dtd
%%DATADIR%%/editcap.html
-%%DATADIR%%/ethereal-filter.html
-%%DATADIR%%/ethereal.html
+%%DATADIR%%/wireshark-filter.html
+%%DATADIR%%/wireshark.html
%%DATADIR%%/help/capture_filters.txt
%%DATADIR%%/help/capturing.txt
%%DATADIR%%/help/display_filters.txt
@@ -96,7 +102,7 @@ lib/libwiretap.so.0
%%DATADIR%%/help/getting_started.txt
%%DATADIR%%/help/overview.txt
%%DATADIR%%/help/toc
-%%DATADIR%%/idl2eth.html
+%%DATADIR%%/idl2wrs.html
%%DATADIR%%/manuf
%%DATADIR%%/mergecap.html
%%DATADIR%%/radius/dictionary
@@ -161,11 +167,11 @@ lib/libwiretap.so.0
%%DATADIR%%/radius/dictionary.versanet
%%DATADIR%%/radius/dictionary.wispr
%%DATADIR%%/radius/dictionary.xedia
-%%DATADIR%%/tethereal.html
+%%DATADIR%%/tshark.html
%%DATADIR%%/text2pcap.html
-@dirrm lib/ethereal/plugins/%%PORTVERSION%%
-@dirrm lib/ethereal/plugins
-@dirrm lib/ethereal
+@dirrm lib/wireshark/plugins/%%PORTVERSION%%
+@dirrm lib/wireshark/plugins
+@dirrm lib/wireshark
@dirrm %%DATADIR%%/radius
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%/dtds