aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /net/wireshark
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 2373e4eb5e2f..1cf5259bd410 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -24,20 +24,17 @@ USE_PYTHON_BUILD=yes
USES= iconv gettext pkgconfig gmake perl5 tar:bzip2
WANT_GNOME= yes
USE_OPENSSL= yes
-CONFIGURE_ENV= LIBS="${WIRESHARK_LIBS}"
CONFIGURE_ARGS+= --program-transform-name="" \
--with-ssl=${OPENSSLBASE}
USE_LDCONFIG= yes
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
-LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -funit-at-a-time
+LIBS+= -L${LOCALBASE}/lib
DESKTOP_ENTRIES= "Wireshark" "Network Protocol Analyzer" \
"${DATADIR}/hi48-app-wireshark.png" \
"wireshark" "System;Monitor;GTK;" true
-WIRESHARK_LIBS=
-
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
reordercap
.if defined(LITE)
@@ -70,7 +67,6 @@ USE_XORG= x11
.if ${PORT_OPTIONS:MX11}
PLIST_SUB+= WIRESHARK=bin/wireshark WIRESHARK_MAN=""
USE_GNOME+= gtk20
-WIRESHARK_LIBS+=${PTHREAD_LIBS}
.else
PLIST_SUB+= WIRESHARK="@comment wireshark not built" \
WIRESHARK_MAN="@comment wireshark not built "
@@ -114,7 +110,6 @@ PLIST_SUB+= LUA="@comment "
.if ${PORT_OPTIONS:MRTP} && !defined(LITE)
LIB_DEPENDS+= libportaudio.so:${PORTSDIR}/audio/portaudio
CONFIGURE_ARGS+=--with-portaudio=${LOCALBASE}
-WIRESHARK_LIBS+=${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+=--without-portaudio
.endif