aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2013-10-12 17:43:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2013-10-12 17:43:55 +0000
commite74058f67cc27243f02f2cc18aceabec6830b3fb (patch)
tree5b44661839d3238720d1f20a7d0b1c1fecfc150e /net/wireshark
parent669b7fb69db4076e1688cca845ce1865727e6287 (diff)
downloadports-e74058f67cc27243f02f2cc18aceabec6830b3fb.tar.gz
ports-e74058f67cc27243f02f2cc18aceabec6830b3fb.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile20
-rw-r--r--net/wireshark/files/patch-epan_dissectors_packet-gluster.h35
-rw-r--r--net/wireshark/files/patch-epan_dissectors_packet-glusterfs.c27
-rw-r--r--net/wireshark/pkg-plist12
4 files changed, 71 insertions, 23 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 48dfc77d2479..d7fb03471f34 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -42,11 +42,12 @@ WIRESHARK_LIBS=
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
reordercap
.if defined(LITE)
-PLIST_SUB+= ${x:U}="@comment $x not installed"
+PLIST_SUB+= ${x:U}="@comment $x not installed" \
+ ${x:U}_MAN="@comment $x not installed "
CONFIGURE_ARGS+= --enable-$x=no
.else
-PLIST_SUB+= ${x:U}=bin/$x
-MAN1+= $x.1
+PLIST_SUB+= ${x:U}=bin/$x \
+ ${x:U}_MAN=""
.endif
.endfor
@@ -59,7 +60,6 @@ RTP_DESC= Enable support for playing back RTP streams
ADNS_DESC= Enable asynchronous DNS lookup support
.endif
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
@@ -69,12 +69,12 @@ USE_XORG= x11
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MX11}
-MAN1+= wireshark.1
-PLIST_SUB+= WIRESHARK=bin/wireshark
+PLIST_SUB+= WIRESHARK=bin/wireshark WIRESHARK_MAN=""
USE_GNOME+= gtk20
WIRESHARK_LIBS+=${PTHREAD_LIBS}
.else
-PLIST_SUB+= WIRESHARK="@comment wireshark not built"
+PLIST_SUB+= WIRESHARK="@comment wireshark not built" \
+ WIRESHARK_MAN="@comment wireshark not built "
USE_GNOME+= glib20
CONFIGURE_ARGS+= --enable-wireshark=no \
--disable-gtktest
@@ -165,9 +165,6 @@ CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
CONFIGURE_ARGS+=--with-krb5=no
.endif
-MAN1+= dumpcap.1 tshark.1
-MAN4+= wireshark-filter.4
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LUA_INCDIR%%|${LUA_INCDIR}|g ; \
s|-Wl,--as-needed|| ; \
@@ -175,6 +172,7 @@ post-patch:
${WRKSRC}/configure
post-install:
- ${INSTALL_DATA} ${WRKSRC}/image/hi48-app-wireshark.png ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/image/hi48-app-wireshark.png \
+ ${STAGEDIR}${DATADIR}
.include <bsd.port.post.mk>
diff --git a/net/wireshark/files/patch-epan_dissectors_packet-gluster.h b/net/wireshark/files/patch-epan_dissectors_packet-gluster.h
index 53101b021633..6a4359fd1ecb 100644
--- a/net/wireshark/files/patch-epan_dissectors_packet-gluster.h
+++ b/net/wireshark/files/patch-epan_dissectors_packet-gluster.h
@@ -1,19 +1,30 @@
---- epan/dissectors/packet-gluster.h.orig 2013-10-10 23:19:31.007195841 +0000
-+++ epan/dissectors/packet-gluster.h 2013-10-10 23:20:32.550304872 +0000
-@@ -354,6 +354,8 @@
- GFS3_OP_MAXVALUE
- };
+--- epan/dissectors/packet-gluster.h.orig 2013-04-22 14:05:17.000000000 -0400
++++ epan/dissectors/packet-gluster.h 2013-10-12 13:14:25.000000000 -0400
+@@ -356,18 +356,17 @@ enum gf_fop_procnum {
-+# if !defined(__FreeBSD__)
-+
/* dir-entry types from libglusterfs/src/compat.h */
enum gluster_entry_types {
- DT_UNKNOWN = 0,
-@@ -367,6 +369,7 @@
- DT_WHT = 14
+- DT_UNKNOWN = 0,
+- DT_FIFO = 1,
+- DT_CHR = 2,
+- DT_DIR = 4,
+- DT_BLK = 6,
+- DT_REG = 8,
+- DT_LNK = 10,
+- DT_SOCK = 12,
+- DT_WHT = 14
++ GLFS_DT_UNKNOWN = 0,
++ GLFS_DT_FIFO = 1,
++ GLFS_DT_CHR = 2,
++ GLFS_DT_DIR = 4,
++ GLFS_DT_BLK = 6,
++ GLFS_DT_REG = 8,
++ GLFS_DT_LNK = 10,
++ GLFS_DT_SOCK = 12,
++ GLFS_DT_WHT = 14
};
-+# endif
-
+-
/* LOCKING operators come from libglusterfs/src/glusterfs.h */
+ /* based on original enum glusterfs_lk_cmds_t */
diff --git a/net/wireshark/files/patch-epan_dissectors_packet-glusterfs.c b/net/wireshark/files/patch-epan_dissectors_packet-glusterfs.c
new file mode 100644
index 000000000000..f142c771d2b7
--- /dev/null
+++ b/net/wireshark/files/patch-epan_dissectors_packet-glusterfs.c
@@ -0,0 +1,27 @@
+--- epan/dissectors/packet-glusterfs.c.orig 2013-04-22 14:05:16.000000000 -0400
++++ epan/dissectors/packet-glusterfs.c 2013-10-12 13:18:58.000000000 -0400
+@@ -2002,15 +2002,15 @@ static value_string_ext glusterfs3_1_fop
+
+ /* dir-entry types */
+ static const value_string glusterfs_entry_type_names[] = {
+- { DT_UNKNOWN, "DT_UNKNOWN" },
+- { DT_FIFO, "DT_FIFO" },
+- { DT_CHR, "DT_CHR" },
+- { DT_DIR, "DT_DIR" },
+- { DT_BLK, "DT_BLK" },
+- { DT_REG, "DT_REG" },
+- { DT_LNK, "DT_LNK" },
+- { DT_SOCK, "DT_SOCK" },
+- { DT_WHT, "DT_WHT" },
++ { GLFS_DT_UNKNOWN, "DT_UNKNOWN" },
++ { GLFS_DT_FIFO, "DT_FIFO" },
++ { GLFS_DT_CHR, "DT_CHR" },
++ { GLFS_DT_DIR, "DT_DIR" },
++ { GLFS_DT_BLK, "DT_BLK" },
++ { GLFS_DT_REG, "DT_REG" },
++ { GLFS_DT_LNK, "DT_LNK" },
++ { GLFS_DT_SOCK, "DT_SOCK" },
++ { GLFS_DT_WHT, "DT_WHT" },
+ { 0, NULL }
+ };
+ static value_string_ext glusterfs_entry_type_names_ext = VALUE_STRING_EXT_INIT(glusterfs_entry_type_names);
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index aa67093d00bd..4ba49b967916 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -46,6 +46,18 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.la
lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
lib/wireshark/plugins/%%PORTVERSION%%/wimaxmacphy.la
lib/wireshark/plugins/%%PORTVERSION%%/wimaxmacphy.so
+%%CAPINFOS_MAN%%man/man1/capinfos.1.gz
+man/man1/dumpcap.1.gz
+%%EDITCAP_MAN%%man/man1/editcap.1.gz
+%%MERGECAP_MAN%%man/man1/mergecap.1.gz
+%%RAWSHARK_MAN%%man/man1/rawshark.1.gz
+%%TEXT2PCAP_MAN%%man/man1/text2pcap.1.gz
+%%DFTEST_MAN%%man/man1/dftest.1.gz
+%%RANDPKT_MAN%%man/man1/randpkt.1.gz
+%%REORDERCAP_MAN%%man/man1/reordercap.1.gz
+man/man1/tshark.1.gz
+%%WIRESHARK_MAN%%man/man1/wireshark.1.gz
+man/man4/wireshark-filter.4.gz
%%DATADIR%%/AUTHORS-SHORT
%%DATADIR%%/COPYING
%%DATADIR%%/capinfos.html