aboutsummaryrefslogtreecommitdiff
path: root/net/wmnet2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-09-08 13:01:34 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-09-08 13:01:34 +0000
commit5d4bd00b946f570b0c16e052f83b892560284490 (patch)
tree065263b60a1e3eec7584c55cd18effe030a49e24 /net/wmnet2
parentbb8cf40c25593d2e5b3909bcb65916941c96fcaa (diff)
downloadports-5d4bd00b946f570b0c16e052f83b892560284490.tar.gz
ports-5d4bd00b946f570b0c16e052f83b892560284490.zip
Notes
Diffstat (limited to 'net/wmnet2')
-rw-r--r--net/wmnet2/Makefile20
-rw-r--r--net/wmnet2/distinfo1
-rw-r--r--net/wmnet2/files/patch-aa41
-rw-r--r--net/wmnet2/files/patch-ab11
-rw-r--r--net/wmnet2/pkg-comment1
-rw-r--r--net/wmnet2/pkg-descr14
-rw-r--r--net/wmnet2/pkg-plist1
7 files changed, 89 insertions, 0 deletions
diff --git a/net/wmnet2/Makefile b/net/wmnet2/Makefile
new file mode 100644
index 000000000000..854717c273d0
--- /dev/null
+++ b/net/wmnet2/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: wmnet2
+# Date created: 7 September 2001
+# Whom: Paolo Pisati <flag@libero.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmnet2
+PORTVERSION= 1.06
+CATEGORIES= net
+MASTER_SITES= http://www.digitalkaos.net/linux/wmnet/download/
+DISTNAME= wmnet-${PORTVERSION}
+
+MAINTAINER= flag@libero.it
+
+USE_IMAKE= yes
+
+MAN1= wmnet2.1
+
+.include <bsd.port.mk>
diff --git a/net/wmnet2/distinfo b/net/wmnet2/distinfo
new file mode 100644
index 000000000000..ae81e68c7be2
--- /dev/null
+++ b/net/wmnet2/distinfo
@@ -0,0 +1 @@
+MD5 (wmnet-1.06.tar.gz) = 64e74c37c0cb5fd4fb81cfb0f5c4a264
diff --git a/net/wmnet2/files/patch-aa b/net/wmnet2/files/patch-aa
new file mode 100644
index 000000000000..c09100b8bfa9
--- /dev/null
+++ b/net/wmnet2/files/patch-aa
@@ -0,0 +1,41 @@
+*** drivers.c.orig Fri Sep 7 16:39:23 2001
+--- drivers.c Fri Jun 29 23:21:52 2001
+***************
+*** 15,20 ****
+--- 15,21 ----
+ #include<X11/Xlib.h>
+ #include<fcntl.h>
+ #include<sys/types.h>
++ #include <sys/time.h>
+ #include<sys/stat.h>
+ #include<sys/socket.h>
+ #include<unistd.h>
+***************
+*** 24,29 ****
+--- 25,32 ----
+ /* For FreeBSD */
+ #ifdef USE_KVM
+ #include<net/if.h>
++ #include <net/if_var.h>
++ #include <net/if_types.h>
+ #include<kvm.h>
+ #include<nlist.h>
+
+***************
+*** 490,496 ****
+ #ifdef __OpenBSD__
+ ifnet_addr = (unsigned long)ifnet->if_list.tqe_next;
+ #else
+! ifnet_addr = (unsigned long)ifnet->if_next;
+ #endif
+ }
+ }
+--- 493,500 ----
+ #ifdef __OpenBSD__
+ ifnet_addr = (unsigned long)ifnet->if_list.tqe_next;
+ #else
+! //ifnet_addr = (unsigned long)ifnet->if_next;
+! ifnet_addr = (unsigned long) TAILQ_NEXT(ifnet,if_link);
+ #endif
+ }
+ }
diff --git a/net/wmnet2/files/patch-ab b/net/wmnet2/files/patch-ab
new file mode 100644
index 000000000000..b313b4aa4320
--- /dev/null
+++ b/net/wmnet2/files/patch-ab
@@ -0,0 +1,11 @@
+--- Imakefile 2001/09/08 12:01:26 1.1
++++ Imakefile 2001/09/08 12:02:34
+@@ -26,4 +26,7 @@
+ #endif
+
+
+-ComplexProgramTarget(wmnet)
++ComplexProgramTarget(wmnet2)
++
++wmnet2.man: wmnet.man
++ ln -sf wmnet.man wmnet2.man
diff --git a/net/wmnet2/pkg-comment b/net/wmnet2/pkg-comment
new file mode 100644
index 000000000000..983bbd9fb785
--- /dev/null
+++ b/net/wmnet2/pkg-comment
@@ -0,0 +1 @@
+A cool network monitor for WindowMaker
diff --git a/net/wmnet2/pkg-descr b/net/wmnet2/pkg-descr
new file mode 100644
index 000000000000..cad0ef574189
--- /dev/null
+++ b/net/wmnet2/pkg-descr
@@ -0,0 +1,14 @@
+This little program polls network statistics and does a few things with the
+data it gets. It has small blinking lights for the rx and tx of IP packets,
+a digital speedometer of your polled stat's currentspeed and a bar graph like
+xload et. al which has a tx speed graph from bottom-up and rx speed graph
+from the top-down. The speedometer keeps track of the current speed per
+second and shows it in a color corresponding to which of rx or tx that has
+the highest speed at the moment. Also, the graph is drawn in a way that the
+highest speed is drawn on top of the other while the other is in the
+background.
+
+WWW: http://http://www.digitalkaos.net/linux/wmnet/
+
+- Paolo
+flag@libero.it
diff --git a/net/wmnet2/pkg-plist b/net/wmnet2/pkg-plist
new file mode 100644
index 000000000000..b811b0fc4764
--- /dev/null
+++ b/net/wmnet2/pkg-plist
@@ -0,0 +1 @@
+bin/wmnet2