aboutsummaryrefslogtreecommitdiff
path: root/net/wmnetmon/files
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-11-13 00:04:37 +0000
committerJohn Marino <marino@FreeBSD.org>2015-11-13 00:04:37 +0000
commit8f3687f167eaeed875f36999b19af5a804f9f26c (patch)
tree747cc7efa952300d7cc5816301e8d72e5486db84 /net/wmnetmon/files
parent070f7a6e7d1893d1dfafd7aa018c63540e1a124a (diff)
downloadports-8f3687f167eaeed875f36999b19af5a804f9f26c.tar.gz
ports-8f3687f167eaeed875f36999b19af5a804f9f26c.zip
Notes
Diffstat (limited to 'net/wmnetmon/files')
-rw-r--r--net/wmnetmon/files/patch-Makefile.in26
-rw-r--r--net/wmnetmon/files/patch-configure30
-rw-r--r--net/wmnetmon/files/patch-configure.in30
-rw-r--r--net/wmnetmon/files/patch-leds.c22
-rw-r--r--net/wmnetmon/files/patch-list.c24
-rw-r--r--net/wmnetmon/files/patch-pinger.c26
-rw-r--r--net/wmnetmon/files/patch-pinger.h47
-rw-r--r--net/wmnetmon/files/patch-tcpmonitor.c52
8 files changed, 110 insertions, 147 deletions
diff --git a/net/wmnetmon/files/patch-Makefile.in b/net/wmnetmon/files/patch-Makefile.in
index cea2c390d796..95446f26ded9 100644
--- a/net/wmnetmon/files/patch-Makefile.in
+++ b/net/wmnetmon/files/patch-Makefile.in
@@ -1,14 +1,12 @@
-*** Makefile.in.orig Sat Jul 10 22:04:53 1999
---- Makefile.in Sun Apr 1 16:16:21 2001
-***************
-*** 11,19 ****
- wmnetmon: $(OBJS)
- $(CC) $(OBJS) -o wmnetmon $(LDFLAGS)
-
-- .o:.c
-- $(CC) $(CFLAGS) -c $.c -o $.o
--
- install: wmnetmon
- $(INSTALL) wmnetmon $(BINDIR) -o root --mode=4755
-
---- 11,16 ----
+--- Makefile.in.orig 1999-07-10 19:04:53 UTC
++++ Makefile.in
+@@ -11,9 +11,6 @@ all: wmnetmon
+ wmnetmon: $(OBJS)
+ $(CC) $(OBJS) -o wmnetmon $(LDFLAGS)
+
+-.o:.c
+- $(CC) $(CFLAGS) -c $.c -o $.o
+-
+ install: wmnetmon
+ $(INSTALL) wmnetmon $(BINDIR) -o root --mode=4755
+
diff --git a/net/wmnetmon/files/patch-configure b/net/wmnetmon/files/patch-configure
index b1b401a12fea..37da2415d55d 100644
--- a/net/wmnetmon/files/patch-configure
+++ b/net/wmnetmon/files/patch-configure
@@ -1,19 +1,11 @@
-*** configure.orig Sun Apr 1 15:17:16 2001
---- configure Sun Apr 1 15:17:24 2001
-***************
-*** 1605,1611 ****
-
- fi
-
-! for ac_hdr in fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
---- 1605,1611 ----
-
- fi
-
-! for ac_hdr in fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
+--- configure.orig 1999-07-23 14:07:40 UTC
++++ configure
+@@ -1605,7 +1605,7 @@ EOF
+
+ fi
+
+-for ac_hdr in fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
++for ac_hdr in fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
+ do
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
diff --git a/net/wmnetmon/files/patch-configure.in b/net/wmnetmon/files/patch-configure.in
index 901058ada5b0..9632da24ffe8 100644
--- a/net/wmnetmon/files/patch-configure.in
+++ b/net/wmnetmon/files/patch-configure.in
@@ -1,19 +1,11 @@
-*** configure.in.orig Sun Apr 1 15:17:40 2001
---- configure.in Sun Apr 1 15:17:47 2001
-***************
-*** 43,49 ****
- dnl Checks for header files.
-
- AC_HEADER_STDC
-! AC_CHECK_HEADERS(fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
- AC_MSG_ERROR([Couldn't find some include files... aborting]))
- AC_CHECK_HEADERS(netinet/in_systm.h netinet/in.h netinet/ip.h netinet/ip_icmp.h arpa/inet.h netdb.h sys/socket.h,,
- AC_MSG_ERROR([Couldn't find network include files]))
---- 43,49 ----
- dnl Checks for header files.
-
- AC_HEADER_STDC
-! AC_CHECK_HEADERS(fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
- AC_MSG_ERROR([Couldn't find some include files... aborting]))
- AC_CHECK_HEADERS(netinet/in_systm.h netinet/in.h netinet/ip.h netinet/ip_icmp.h arpa/inet.h netdb.h sys/socket.h,,
- AC_MSG_ERROR([Couldn't find network include files]))
+--- configure.in.orig 1999-07-23 14:03:17 UTC
++++ configure.in
+@@ -43,7 +43,7 @@ fi
+ dnl Checks for header files.
+
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
++AC_CHECK_HEADERS(fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
+ AC_MSG_ERROR([Couldn't find some include files... aborting]))
+ AC_CHECK_HEADERS(netinet/in_systm.h netinet/in.h netinet/ip.h netinet/ip_icmp.h arpa/inet.h netdb.h sys/socket.h,,
+ AC_MSG_ERROR([Couldn't find network include files]))
diff --git a/net/wmnetmon/files/patch-leds.c b/net/wmnetmon/files/patch-leds.c
index b90e3a9f1718..e9c3405cc117 100644
--- a/net/wmnetmon/files/patch-leds.c
+++ b/net/wmnetmon/files/patch-leds.c
@@ -1,12 +1,10 @@
-*** leds.c.orig Sun Apr 1 15:18:44 2001
---- leds.c Sun Apr 1 15:19:01 2001
-***************
-*** 1,5 ****
---- 1,7 ----
- #include <stdlib.h>
-+ #ifndef __FreeBSD__
- #include <malloc.h>
-+ #endif
- #include <X11/xpm.h>
- #include <stdio.h>
- #include "list.h"
+--- leds.c.orig 1999-07-26 16:23:23 UTC
++++ leds.c
+@@ -1,5 +1,7 @@
+ #include <stdlib.h>
++#if ! (defined __FreeBSD__ || defined __DragonFly__)
+ #include <malloc.h>
++#endif
+ #include <X11/xpm.h>
+ #include <stdio.h>
+ #include "list.h"
diff --git a/net/wmnetmon/files/patch-list.c b/net/wmnetmon/files/patch-list.c
index 7a7d2545e835..d717372996e2 100644
--- a/net/wmnetmon/files/patch-list.c
+++ b/net/wmnetmon/files/patch-list.c
@@ -1,13 +1,11 @@
-*** list.c.orig Sun Apr 1 15:19:28 2001
---- list.c Sun Apr 1 15:19:39 2001
-***************
-*** 1,6 ****
---- 1,8 ----
- #include "list.h"
- #include <stdlib.h>
-+ #ifndef __FreeBSD__
- #include <malloc.h>
-+ #endif
- #include <string.h>
-
-
+--- list.c.orig 1999-07-22 12:43:11 UTC
++++ list.c
+@@ -1,6 +1,8 @@
+ #include "list.h"
+ #include <stdlib.h>
++#if ! (defined __FreeBSD__ || defined __DragonFly__)
+ #include <malloc.h>
++#endif
+ #include <string.h>
+
+
diff --git a/net/wmnetmon/files/patch-pinger.c b/net/wmnetmon/files/patch-pinger.c
index 033b91a6639d..58bb2cd48859 100644
--- a/net/wmnetmon/files/patch-pinger.c
+++ b/net/wmnetmon/files/patch-pinger.c
@@ -1,14 +1,12 @@
-*** pinger.c.orig Sun Apr 1 15:21:08 2001
---- pinger.c Sun Apr 1 15:21:22 2001
-***************
-*** 14,20 ****
---- 14,22 ----
- #include <netdb.h>
- #include <errno.h>
- #include <stdlib.h>
-+ #ifndef __FreeBSD__
- #include <malloc.h>
-+ #endif
- #include <unistd.h>
- #include "list.h"
- #include "config.h"
+--- pinger.c.orig 2000-06-17 11:01:23 UTC
++++ pinger.c
+@@ -14,7 +14,9 @@
+ #include <netdb.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#if ! (defined __FreeBSD__ || defined __DragonFly__)
+ #include <malloc.h>
++#endif
+ #include <unistd.h>
+ #include "list.h"
+ #include "config.h"
diff --git a/net/wmnetmon/files/patch-pinger.h b/net/wmnetmon/files/patch-pinger.h
index ee4abbc5de5c..6a22b1ab5761 100644
--- a/net/wmnetmon/files/patch-pinger.h
+++ b/net/wmnetmon/files/patch-pinger.h
@@ -1,25 +1,22 @@
-*** pinger.h.orig Fri Jul 23 17:08:26 1999
---- pinger.h Sun Apr 1 15:30:20 2001
-***************
-*** 2,7 ****
---- 2,8 ----
- #define __PINGER_H__
-
-
-+ #include <sys/types.h>
- #include <netinet/in.h>
- #include "list.h"
- #include "config.h"
-***************
-*** 47,54 ****
---- 48,57 ----
- #define UDP_DPORT dest
- #endif
-
-+ #ifndef __FreeBSD__
- #if ! (defined(__GLIBC__) && (__GLIBC__ >= 2))
- #define inet_ntoa(x) inet_ntoa(*((struct in_addr *)&(x)))
-+ #endif
- #endif
-
- #define TIMEOUT_SIZE 55
+--- pinger.h.orig 1999-07-23 14:08:26 UTC
++++ pinger.h
+@@ -2,6 +2,7 @@
+ #define __PINGER_H__
+
+
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include "list.h"
+ #include "config.h"
+@@ -47,9 +48,11 @@
+ #define UDP_DPORT dest
+ #endif
+
++#if ! (defined __FreeBSD__ || defined __DragonFly__)
+ #if ! (defined(__GLIBC__) && (__GLIBC__ >= 2))
+ #define inet_ntoa(x) inet_ntoa(*((struct in_addr *)&(x)))
+ #endif
++#endif
+
+ #define TIMEOUT_SIZE 55
+
diff --git a/net/wmnetmon/files/patch-tcpmonitor.c b/net/wmnetmon/files/patch-tcpmonitor.c
index 379db455096a..faff35a5a293 100644
--- a/net/wmnetmon/files/patch-tcpmonitor.c
+++ b/net/wmnetmon/files/patch-tcpmonitor.c
@@ -1,31 +1,21 @@
-*** tcpmonitor.c.orig Fri Jul 23 16:58:24 1999
---- tcpmonitor.c Sun Apr 1 15:32:49 2001
-***************
-*** 12,18 ****
---- 12,20 ----
- #include <sys/time.h>
- #include <arpa/inet.h>
- #include <stdlib.h>
-+ #ifndef __FreeBSD__
- #include <malloc.h>
-+ #endif
- #include <fcntl.h>
- #include <errno.h>
- #include "config.h"
-***************
-*** 51,57 ****
- if (debug)
- fprintf(stderr,"trying to connect (tcp) to port %d at %s...\n", h->tcpport,
- inet_ntoa(h->tcpsock->sin_addr));
-! if (connect(h->tcp_socket, (struct sockaddr_in*)h->tcpsock,
- sizeof(struct sockaddr_in))<0)
- switch(errno) {
- case EISCONN: /* Common.. reported by lots of users
---- 53,59 ----
- if (debug)
- fprintf(stderr,"trying to connect (tcp) to port %d at %s...\n", h->tcpport,
- inet_ntoa(h->tcpsock->sin_addr));
-! if (connect(h->tcp_socket, (struct sockaddr*)h->tcpsock,
- sizeof(struct sockaddr_in))<0)
- switch(errno) {
- case EISCONN: /* Common.. reported by lots of users
+--- tcpmonitor.c.orig 1999-07-23 13:58:24 UTC
++++ tcpmonitor.c
+@@ -12,7 +12,9 @@
+ #include <sys/time.h>
+ #include <arpa/inet.h>
+ #include <stdlib.h>
++#if ! (defined __FreeBSD__ || defined __DragonFly__)
+ #include <malloc.h>
++#endif
+ #include <fcntl.h>
+ #include <errno.h>
+ #include "config.h"
+@@ -51,7 +53,7 @@ int tcp_isalive(pinger_host *h)
+ if (debug)
+ fprintf(stderr,"trying to connect (tcp) to port %d at %s...\n", h->tcpport,
+ inet_ntoa(h->tcpsock->sin_addr));
+- if (connect(h->tcp_socket, (struct sockaddr_in*)h->tcpsock,
++ if (connect(h->tcp_socket, (struct sockaddr*)h->tcpsock,
+ sizeof(struct sockaddr_in))<0)
+ switch(errno) {
+ case EISCONN: /* Common.. reported by lots of users