aboutsummaryrefslogtreecommitdiff
path: root/net/wol/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-07 18:00:59 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-07 18:00:59 +0000
commitba285848624bc37a09be5139f14313ffbee97f55 (patch)
treea0b383f48033baa49f4cd39e953b61f9b5caa58b /net/wol/Makefile
parent1fe2fee346339b4d5460565e9896b4d5ba2bc8ad (diff)
Notes
Diffstat (limited to 'net/wol/Makefile')
-rw-r--r--net/wol/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/net/wol/Makefile b/net/wol/Makefile
index bfb358a012ba..e834d8ceb31f 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -8,19 +8,30 @@
PORTNAME= wol
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ahh
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Wake On LAN client
+MAINTAINER= sergei@kolobov.com
+COMMENT= Tool to wake up Wake-On-LAN compliant computers
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ iconv.3:${PORTSDIR}/converters/libiconv
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -liconv -lgnugetopt"
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+DOCS= AUTHORS NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>