aboutsummaryrefslogtreecommitdiff
path: root/net/x11vnc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-11-29 07:08:42 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-11-29 07:08:42 +0000
commit6963e9f773e2e88096b1c60398375331e369cd43 (patch)
tree08bd74f6980f805e02704bb9ba0e8f60483fa69c /net/x11vnc
parenteeb12f0b4aaa4e18ac3879a197d6eaaeced27a0d (diff)
downloadports-6963e9f773e2e88096b1c60398375331e369cd43.tar.gz
ports-6963e9f773e2e88096b1c60398375331e369cd43.zip
Notes
Diffstat (limited to 'net/x11vnc')
-rw-r--r--net/x11vnc/Makefile32
-rw-r--r--net/x11vnc/pkg-plist1
2 files changed, 12 insertions, 21 deletions
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 9d1c6a462a3b..585edf36515a 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -12,11 +12,9 @@ COMMENT= VNC server for use with real X displays
LICENSE= GPLv2
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- dbus:${PORTSDIR}/devel/dbus \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
-
-NO_STAGE= yes
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
xdmcp recordproto
@@ -27,36 +25,28 @@ USES= iconv pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-MAN1= x11vnc.1
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README README.LibVNCServer TODO
OPTIONS_DEFINE=NLS AVAHI
OPTIONS_DEFAULT=NLS AVAHI
NO_OPTIONS_SORT=yes
+NLS_USES= gettext
+AVAHI_LIB_DEPENDS= libavahi-common.so:${PORTSDIR}/net/avahi-app
+AVAHI_CONFIGURE_OFF= --without-avahi
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-.endif
-
-.if ${PORT_OPTIONS:MAVAHI}
-LIB_DEPENDS+= avahi-common:${PORTSDIR}/net/avahi-app
-.else
-CONFIGURE_ARGS+= --without-avahi
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|include_HEADERS = |noinst_HEADERS = |' \
+ ${REINPLACE_CMD} -e 's|include_HEADERS = |noinst_HEADERS = |' \
-e 's|am__include_HEADERS_DIST|am__noinst_HEADERS_DIST|' \
-e 's|/include/rfb|/include|' ${WRKSRC}/Makefile.in
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/net/x11vnc/pkg-plist b/net/x11vnc/pkg-plist
index d47ee3e69c91..6f99aa4a97e0 100644
--- a/net/x11vnc/pkg-plist
+++ b/net/x11vnc/pkg-plist
@@ -1,4 +1,5 @@
bin/x11vnc
+man/man1/x11vnc.1.gz
%%DATADIR%%/classes/ssl/README
%%DATADIR%%/classes/ssl/SignedUltraViewerSSL.jar
%%DATADIR%%/classes/ssl/SignedVncViewer.jar