aboutsummaryrefslogtreecommitdiff
path: root/net/x2goclient
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:54:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:54:31 +0000
commitb1efb2d416d04b6b4b2ca34843aa5dd2bde87e1e (patch)
tree1561461009c4b397b30463ca510e5e3e36a741fc /net/x2goclient
parentcae23db22b22580a65628175d4a0a7c8d5e90832 (diff)
downloadports-b1efb2d416d04b6b4b2ca34843aa5dd2bde87e1e.tar.gz
ports-b1efb2d416d04b6b4b2ca34843aa5dd2bde87e1e.zip
Notes
Diffstat (limited to 'net/x2goclient')
-rw-r--r--net/x2goclient/Makefile15
-rw-r--r--net/x2goclient/files/patch-cupsprint.h10
2 files changed, 18 insertions, 7 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index fb768c214da5..ec7c6eae2611 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -14,20 +14,21 @@ DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The x2go perl client
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
RUN_DEPENDS= nxproxy:${PORTSDIR}/net/nxproxy \
x2goclient-cli:${PORTSDIR}/net/x2goclient-cli
-BROKEN= does not compile
-EXPIRATION_DATE= 2011-11-30
-
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-PLIST_FILES= bin/x2goclient
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S,-5,,}
+
USE_QT_VER= 4
QT_COMPONENTS= gui network svg qmake_build moc_build uic_build rcc_build
USE_OPENLDAP= yes
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/x2goclient
post-patch:
cd ${WRKSRC}; ${REINPLACE_CMD} -e "s,Q_OS_LINUX,Q_OS_FREEBSD," \
@@ -38,7 +39,7 @@ post-patch:
${REINPLACE_CMD} -e "s,linux,freebsd," ${WRKSRC}/x2goclient.pro
do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${QMAKE}
+ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/x2goclient ${PREFIX}/bin
diff --git a/net/x2goclient/files/patch-cupsprint.h b/net/x2goclient/files/patch-cupsprint.h
new file mode 100644
index 000000000000..7a283600d214
--- /dev/null
+++ b/net/x2goclient/files/patch-cupsprint.h
@@ -0,0 +1,10 @@
+--- cupsprint.h.orig 2009-11-12 06:47:37.000000000 +0900
++++ cupsprint.h 2011-11-23 03:23:33.000000000 +0900
+@@ -15,6 +15,7 @@
+ #ifndef Q_OS_WIN
+ #include <QStringList>
+ #include <cups/cups.h>
++#include <cups/ppd.h>
+ /**
+ @author Oleksandr Shneyder <oleksandr.shneyder@obviously-nice.de>
+ */