aboutsummaryrefslogtreecommitdiff
path: root/net/x2goclient
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-01 15:12:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-01 15:12:24 +0000
commitad36c89df1e0b0b3d059158eeb926032560033ea (patch)
tree34d261626b4079569dfe9ea8737cd895d97e8740 /net/x2goclient
parent6b34971cd5f3fe512e75ef5c28a509d0b69778a2 (diff)
downloadports-ad36c89df1e0b0b3d059158eeb926032560033ea.tar.gz
ports-ad36c89df1e0b0b3d059158eeb926032560033ea.zip
Notes
Diffstat (limited to 'net/x2goclient')
-rw-r--r--net/x2goclient/Makefile13
-rw-r--r--net/x2goclient/distinfo4
-rw-r--r--net/x2goclient/files/patch-sshmasterconnection.cpp20
-rw-r--r--net/x2goclient/files/patch-sshprocess.cpp8
-rw-r--r--net/x2goclient/files/patch-sshprocess.h8
5 files changed, 31 insertions, 22 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index e6bb1d7414b1..d54da7f767e0 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= x2goclient
-PORTVERSION= 4.0.3.2
+PORTVERSION= 4.0.4.0
CATEGORIES= net
MASTER_SITES= http://code.x2go.org/releases/source/x2goclient/
@@ -11,9 +11,6 @@ COMMENT= Qt client for the X2Go system
LICENSE= GPLv2
-# http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=870
-BROKEN= does not build with new libssh: undefined reference to `ssh_forward_listen'
-
# Avoid clash with libssh from base
BUILD_DEPENDS= ${LOCALBASE}/lib/libssh.so:${PORTSDIR}/security/libssh
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
@@ -37,7 +34,7 @@ LDAP_QMAKE_ON= LIBS+="-lX11 -lXpm -lcups -lldap"
LDAP_QMAKE_OFF= LIBS+="-lX11 -lXpm -lcups"
post-patch:
- @${FIND} ${WRKSRC} -name "*.cpp" -or -name "*.h" | ${XARGS} \
+ @${FIND} ${WRKSRC}/src -name "*.cpp" -or -name "*.h" | ${XARGS} \
${REINPLACE_CMD} -e \
's|Q_OS_LINUX|Q_OS_UNIX| ; \
/<linux\/fs.h>/s|^|//| ; \
@@ -57,14 +54,14 @@ do-install:
${STAGEDIR}${DESKTOPDIR})
.for i in 16x16 32x32 48x48 64x64 128x128
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}/apps
- (cd ${WRKSRC}/icons/${i} && ${INSTALL_DATA} x2goclient.png \
+ (cd ${WRKSRC}/res/img/icons/${i} && ${INSTALL_DATA} x2goclient.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}/apps)
.endfor
@${MKDIR} ${STAGEDIR}${DATADIR}/icons
- (cd ${WRKSRC}/icons && ${INSTALL_DATA} x2goclient.xpm \
+ (cd ${WRKSRC}/res/img/icons && ${INSTALL_DATA} x2goclient.xpm \
${STAGEDIR}${DATADIR}/icons)
.for i in x2goclient.png x2gosession.png
- (cd ${WRKSRC}/icons/128x128 && ${INSTALL_DATA} ${i} \
+ (cd ${WRKSRC}/res/img/icons/128x128 && ${INSTALL_DATA} ${i} \
${STAGEDIR}${DATADIR}/icons)
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net/x2goclient/distinfo b/net/x2goclient/distinfo
index a5198ec5bdc7..12363213c918 100644
--- a/net/x2goclient/distinfo
+++ b/net/x2goclient/distinfo
@@ -1,2 +1,2 @@
-SHA256 (x2goclient-4.0.3.2.tar.gz) = f65a70463eae3d6d9fe6e4379f4ffacda50080a11f196d2792742f5b67fa0c6f
-SIZE (x2goclient-4.0.3.2.tar.gz) = 1560536
+SHA256 (x2goclient-4.0.4.0.tar.gz) = 86d05ce10039fe0a965cdc55086e00f4f3abc573a96f128b92f87081b7251657
+SIZE (x2goclient-4.0.4.0.tar.gz) = 1571218
diff --git a/net/x2goclient/files/patch-sshmasterconnection.cpp b/net/x2goclient/files/patch-sshmasterconnection.cpp
index c8c349e6129b..3002808f8efc 100644
--- a/net/x2goclient/files/patch-sshmasterconnection.cpp
+++ b/net/x2goclient/files/patch-sshmasterconnection.cpp
@@ -1,6 +1,6 @@
---- sshmasterconnection.cpp.orig 2011-11-25 21:08:10.000000000 +0900
-+++ sshmasterconnection.cpp 2011-12-20 01:50:14.000000000 +0900
-@@ -25,6 +25,9 @@
+--- src/sshmasterconnection.cpp.orig 2015-05-26 19:13:12 UTC
++++ src/sshmasterconnection.cpp
+@@ -28,6 +28,9 @@
#include <QDir>
#include <QTemporaryFile>
#ifndef Q_OS_WIN
@@ -9,4 +9,16 @@
+#include <netinet/in.h>
#include <arpa/inet.h>
#endif
-
+ #include <math.h>
+@@ -272,7 +275,11 @@ void SshMasterConnection::addReverseTunn
+ if(!reverseTunnelRequest[i].listen)
+ {
+ reverseTunnelRequest[i].listen=true;
++#if LIBSSH_VERSION_MAJOR == 0 && LIBSSH_VERSION_MINOR <= 6
+ int rc=ssh_forward_listen(my_ssh_session, NULL, reverseTunnelRequest[i].forwardPort, NULL);
++#else
++ int rc=ssh_channel_listen_forward(my_ssh_session, NULL, reverseTunnelRequest[i].forwardPort, NULL);
++#endif
+ if(rc==SSH_OK)
+ {
+ emit reverseTunnelOk(reverseTunnelRequest[i].creator);
diff --git a/net/x2goclient/files/patch-sshprocess.cpp b/net/x2goclient/files/patch-sshprocess.cpp
index 41247a0aef96..63a1889da75d 100644
--- a/net/x2goclient/files/patch-sshprocess.cpp
+++ b/net/x2goclient/files/patch-sshprocess.cpp
@@ -1,8 +1,8 @@
---- sshprocess.cpp.orig 2011-11-25 21:08:10.000000000 +0900
-+++ sshprocess.cpp 2011-12-20 01:53:47.000000000 +0900
-@@ -21,6 +21,9 @@
- #include <QTimer>
+--- src/sshprocess.cpp.orig 2015-05-26 19:13:12 UTC
++++ src/sshprocess.cpp
+@@ -24,6 +24,9 @@
+ #include <QProcess>
#ifndef Q_OS_WIN
+#include <sys/types.h>
+#include <sys/socket.h>
diff --git a/net/x2goclient/files/patch-sshprocess.h b/net/x2goclient/files/patch-sshprocess.h
index a6030305a0d3..4b28165b9b59 100644
--- a/net/x2goclient/files/patch-sshprocess.h
+++ b/net/x2goclient/files/patch-sshprocess.h
@@ -1,6 +1,6 @@
---- sshprocess.h.orig 2011-11-25 21:08:10.000000000 +0900
-+++ sshprocess.h 2011-12-20 01:56:29.000000000 +0900
-@@ -17,6 +17,12 @@
+--- src/sshprocess.h.orig 2015-05-26 19:13:12 UTC
++++ src/sshprocess.h
+@@ -18,6 +18,12 @@
#ifndef SSHPROCESS_H
#define SSHPROCESS_H
@@ -12,4 +12,4 @@
+#endif
#include <libssh/libssh.h>
#include <QObject>
-
+ #include <QProcess>