aboutsummaryrefslogtreecommitdiff
path: root/net/xboxproxy
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-07-23 15:18:23 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-07-23 15:18:23 +0000
commitb7a95dea7aaf1c2d498f449b9c02585de009adc7 (patch)
tree4711e6de8a0f3edafeb2d763b7440d9b5f089ecb /net/xboxproxy
parent258e0fcbc9c20770f1642570c460e905c8e98646 (diff)
downloadports-b7a95dea7aaf1c2d498f449b9c02585de009adc7.tar.gz
ports-b7a95dea7aaf1c2d498f449b9c02585de009adc7.zip
Notes
Diffstat (limited to 'net/xboxproxy')
-rw-r--r--net/xboxproxy/Makefile5
-rw-r--r--net/xboxproxy/files/xboxproxy.in37
-rw-r--r--net/xboxproxy/pkg-descr2
3 files changed, 41 insertions, 3 deletions
diff --git a/net/xboxproxy/Makefile b/net/xboxproxy/Makefile
index c742882005e2..80299b8afd93 100644
--- a/net/xboxproxy/Makefile
+++ b/net/xboxproxy/Makefile
@@ -6,9 +6,9 @@
PORTNAME= xboxproxy
PORTVERSION= 2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
-MASTER_SITES= http://www.csh.rit.edu/~psionic/projects/xboxproxy/
+MASTER_SITES= http://www.semicomplete.com/files/xboxproxy/
DISTNAME= proxy-${PORTVERSION}
MAINTAINER= ports@mawer.org
@@ -16,6 +16,7 @@ COMMENT= A proxy for the XBox system link protocol
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+USE_RC_SUBR= xboxproxy
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=xbox
diff --git a/net/xboxproxy/files/xboxproxy.in b/net/xboxproxy/files/xboxproxy.in
new file mode 100644
index 000000000000..ec5b8d9a4a2d
--- /dev/null
+++ b/net/xboxproxy/files/xboxproxy.in
@@ -0,0 +1,37 @@
+#!/bin/sh
+#
+# PROVIDE: xboxproxy
+# REQUIRE: LOGIN
+#
+# Add the following lines to /etc/rc.conf to enable xboxproxy
+#
+# xboxproxy_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable xboxproxy.
+# xboxproxy_flags (str): Additional flags to pass to xboxproxy.
+# Defaults to -x -b -m.
+#
+
+. %%RC_SUBR%%
+
+name="xboxproxy"
+rcvar="${name}_enable"
+
+load_rc_config $name
+
+: ${xboxproxy_enable="NO"}
+: ${xboxproxy_flags="-x -b -m"}
+
+
+start_cmd="${name}_start"
+pidfile="/var/run/xboxproxy.pid"
+command="%%PREFIX%%/bin/${name}"
+
+
+xboxproxy_start() {
+ echo "Starting ${name}."
+ /usr/sbin/daemon -p $pidfile ${command} ${xboxproxy_flags}
+}
+
+
+run_rc_command "$1"
+
diff --git a/net/xboxproxy/pkg-descr b/net/xboxproxy/pkg-descr
index 848573631868..333372147793 100644
--- a/net/xboxproxy/pkg-descr
+++ b/net/xboxproxy/pkg-descr
@@ -4,4 +4,4 @@ system link across multiple networks (eg. two people in different states).
It also supports bridging of the Apple Rendezvous protocol for sharing of
iTunes music shares across different Layer 3 networks..
-WWW: http://www.csh.rit.edu/~psionic/projects/xboxproxy/
+WWW: http://www.semicomplete.com/projects/xboxproxy