aboutsummaryrefslogtreecommitdiff
path: root/net/xboxproxy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/xboxproxy
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net/xboxproxy')
-rw-r--r--net/xboxproxy/Makefile12
-rw-r--r--net/xboxproxy/files/patch-configure32
2 files changed, 42 insertions, 2 deletions
diff --git a/net/xboxproxy/Makefile b/net/xboxproxy/Makefile
index a93ef509d8cb..f85797679ec7 100644
--- a/net/xboxproxy/Makefile
+++ b/net/xboxproxy/Makefile
@@ -6,7 +6,7 @@
PORTNAME= xboxproxy
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.csh.rit.edu/~psionic/projects/xboxproxy/
DISTNAME= proxy-${PORTVERSION}
@@ -14,13 +14,15 @@ DISTNAME= proxy-${PORTVERSION}
MAINTAINER= ports@mawer.org
COMMENT= A proxy for the XBox system link protocol
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=xbox
PLIST_FILES= bin/xboxproxy
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -28,4 +30,10 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
CONFIGURE_ARGS+= --with-pcap=${LOCALBASE}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libnet-config|${LIBNET_CONFIG}|g; \
+ s|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.post.mk>
diff --git a/net/xboxproxy/files/patch-configure b/net/xboxproxy/files/patch-configure
new file mode 100644
index 000000000000..709d3a1753e6
--- /dev/null
+++ b/net/xboxproxy/files/patch-configure
@@ -0,0 +1,32 @@
+--- ./configure.orig Thu Oct 6 23:51:26 2005
++++ ./configure Wed Sep 27 17:29:04 2006
+@@ -2867,7 +2867,7 @@
+
+ # Checks for libraries.
+ LIBNET_LDFLAGS="`libnet-config --libs`"
+-LIBNET_CFLAGS="`libnet-config --defines` -D__GLIBC__"
++LIBNET_CFLAGS="`libnet-config --defines` `libnet-config --cflags` -D__GLIBC__"
+
+ # Checks for header files.
+
+@@ -5111,19 +5111,7 @@
+ as_ac_File=`echo "ac_cv_file_${dirname}/lib/libnet.a" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for ${dirname}/lib/libnet.a" >&5
+ echo $ECHO_N "checking for ${dirname}/lib/libnet.a... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_File+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- test "$cross_compiling" = yes &&
+- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+- { (exit 1); exit 1; }; }
+-if test -r "${dirname}/lib/libnet.a"; then
+- eval "$as_ac_File=yes"
+-else
+- eval "$as_ac_File=no"
+-fi
+-fi
++eval "$as_ac_File=yes"
+ echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
+ echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
+ if test `eval echo '${'$as_ac_File'}'` = yes; then