aboutsummaryrefslogtreecommitdiff
path: root/net/xipdump
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 19:45:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 19:45:01 +0000
commit7d7a63cbcd3d71898f3fa64ae8dbc872413a8670 (patch)
tree576d501fc0f63c5ec5ab3a68e56a4fb6d60329ad /net/xipdump
parent8607a509cc54e9cb4ca32edd2b380da77bbbb033 (diff)
downloadports-7d7a63cbcd3d71898f3fa64ae8dbc872413a8670.tar.gz
ports-7d7a63cbcd3d71898f3fa64ae8dbc872413a8670.zip
Notes
Diffstat (limited to 'net/xipdump')
-rw-r--r--net/xipdump/Makefile38
-rw-r--r--net/xipdump/distinfo1
-rw-r--r--net/xipdump/files/patch-XmgMacro.c11
-rw-r--r--net/xipdump/files/patch-configure52
-rw-r--r--net/xipdump/files/patch-xipshcut.c12
-rw-r--r--net/xipdump/pkg-comment1
-rw-r--r--net/xipdump/pkg-descr5
-rw-r--r--net/xipdump/pkg-plist3
8 files changed, 123 insertions, 0 deletions
diff --git a/net/xipdump/Makefile b/net/xipdump/Makefile
new file mode 100644
index 000000000000..45658d0dcfc4
--- /dev/null
+++ b/net/xipdump/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xipdump
+# Date created: 17 Jun 2001
+# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xipdump
+PORTVERSION= 1.5.4
+CATEGORIES= net
+MASTER_SITES= http://www.epita.fr/~lse/xipdump/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+USE_X_PREFIX= yes
+LIBNET_CONFIG= ${LOCALBASE}/bin/libnet-config
+CFLAGS+= `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
+CFLAGS+= -I${LOCALBASE}/include
+LIBS= `${LIBNET_CONFIG} --libs`
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}"
+
+PLIST= ${WRKDIR}/PLIST
+
+MAN8= xipdump.8
+
+post-build:
+ @${CP} ${PKGDIR}/pkg-plist ${PLIST}
+ @(cd ${WRKSRC}/data; find pkc pkt ! -type d | \
+ ${SED} -e 's|^|share/xipdump/|' >> ${PLIST})
+ @${ECHO} "@dirrm share/xipdump/pkt" >> ${PLIST}
+ @${ECHO} "@dirrm share/xipdump/pkc" >> ${PLIST}
+ @${ECHO} "@dirrm share/xipdump" >> ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/net/xipdump/distinfo b/net/xipdump/distinfo
new file mode 100644
index 000000000000..0fb6b94d3547
--- /dev/null
+++ b/net/xipdump/distinfo
@@ -0,0 +1 @@
+MD5 (xipdump-1.5.4.tgz) = 0b987cdb3b1ef49209a1a85d0bc6851d
diff --git a/net/xipdump/files/patch-XmgMacro.c b/net/xipdump/files/patch-XmgMacro.c
new file mode 100644
index 000000000000..1e045a057587
--- /dev/null
+++ b/net/xipdump/files/patch-XmgMacro.c
@@ -0,0 +1,11 @@
+--- XmgMacro.c.orig Mon Nov 15 10:47:25 1999
++++ XmgMacro.c Tue Oct 10 16:10:50 2000
+@@ -274,7 +274,7 @@
+ #if defined(__osf__) && defined(__alpha)
+ (ArgList)(var._a0),
+ #else
+- (ArgList)var,
++ va_arg(var, ArgList),
+ #endif
+ total_count);
+ #if XtSpecificationRelease>4
diff --git a/net/xipdump/files/patch-configure b/net/xipdump/files/patch-configure
new file mode 100644
index 000000000000..735ad1231d2b
--- /dev/null
+++ b/net/xipdump/files/patch-configure
@@ -0,0 +1,52 @@
+--- configure.orig Wed Dec 22 09:51:48 1999
++++ configure
+@@ -1360,8 +1360,10 @@
+ LDFLAGS="$LDFLAGS -L$PCAP_LIBPATH"
+ fi
+
++if false
++then
+ echo $ac_n "checking for local libnet library""... $ac_c" 1>&6
+ echo "configure:1365: checking for local libnet library" >&5
+ libnet=FAIL
+ lastdir=FAIL
+ places=`ls .. | sed -e 's,/$,,' -e 's,^,../,' | \
+@@ -1389,18 +1391,7 @@
+ then
+ LDFLAGS="$LDFLAGS -L$LIBNET_LIBPATH"
+ fi
+-
+-if test "x$ac_cv_c_bigendian" = "xyes"; then
+- cat >> confdefs.h <<\EOF
+-#define LIBNET_BIG_ENDIAN 1
+-EOF
+-
+-else
+- cat >> confdefs.h <<\EOF
+-#define LIBNET_LIL_ENDIAN 1
+-EOF
+-
+ fi
+-
++
+ for ac_func in gethostbyname getservbyname
+ do
+@@ -1877,6 +1868,18 @@
+ fi
+
+
++if test "x$ac_cv_c_bigendian" = "xyes"; then
++ cat >> confdefs.h <<\EOF
++#define LIBNET_BIG_ENDIAN 1
++EOF
++
++else
++ cat >> confdefs.h <<\EOF
++#define LIBNET_LIL_ENDIAN 1
++EOF
++
++fi
++
+
+ for ac_func in bzero bcopy bcmp strdup qsort snprintf usleep strerror strtol strtoul dlopen scandir
+ do
diff --git a/net/xipdump/files/patch-xipshcut.c b/net/xipdump/files/patch-xipshcut.c
new file mode 100644
index 000000000000..205ae5753823
--- /dev/null
+++ b/net/xipdump/files/patch-xipshcut.c
@@ -0,0 +1,12 @@
+--- xipshcut.c.orig Fri Oct 29 05:23:57 1999
++++ xipshcut.c Mon Nov 15 10:41:54 1999
+@@ -27,7 +27,7 @@
+ {"",
+ "<b>%Timestamp%</b>: %Pat% %ether.shost% %ether.dhost% %ether.Type% %Len%"},
+- {"arp[6:2] = 1",
++ {"arp[7] = 1 && arp[6] = 0",
+ "<b>%Timestamp%</b>: arp who-has %arpethip.Tpa% tell %arpethip.Spa%"},
+- {"arp[6:2] = 2",
++ {"arp[7] = 2 && arp[6] = 0",
+ "<b>%Timestamp%</b>: %arpethip.Spa% tells %arpethip.Tpa% he has %arpethip.sha%"},
+ {"ip",
diff --git a/net/xipdump/pkg-comment b/net/xipdump/pkg-comment
new file mode 100644
index 000000000000..b9293254c78e
--- /dev/null
+++ b/net/xipdump/pkg-comment
@@ -0,0 +1 @@
+Displays ip packets using X window
diff --git a/net/xipdump/pkg-descr b/net/xipdump/pkg-descr
new file mode 100644
index 000000000000..8e5eda7e9127
--- /dev/null
+++ b/net/xipdump/pkg-descr
@@ -0,0 +1,5 @@
+xipdump - displays ip packets using X window.
+
+xipdump is a protocol analyzer and tester. It's a kind of graphical
+tcpdump(8) with possibility of changing packet values and resending them.
+It could be also designed by term "human ip stack".
diff --git a/net/xipdump/pkg-plist b/net/xipdump/pkg-plist
new file mode 100644
index 000000000000..7a810149cd75
--- /dev/null
+++ b/net/xipdump/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+bin/xipdump
+lib/X11/app-defaults/Xipdump