aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c-devel/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-09-07 18:11:22 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-09-07 18:11:22 +0000
commit99c8b0dddb5b3ba3e5a4f1a78b712fa8143b64be (patch)
treee9e797273762b1e460970086206840635dd7fd11 /net/xmlrpc-c-devel/Makefile
parent6cf8a3c5bfa17d769374f9b9fe5d9fdb35eec4b7 (diff)
Notes
Diffstat (limited to 'net/xmlrpc-c-devel/Makefile')
-rw-r--r--net/xmlrpc-c-devel/Makefile32
1 files changed, 11 insertions, 21 deletions
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index 098e48007501..4088e192714c 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xmlrpc-c
-PORTVERSION= 1.29.2
+PORTVERSION= 1.31.04
CATEGORIES= net
MASTER_SITES= LOCAL/garga/xmlrpc-c
PKGNAMESUFFIX= -devel
@@ -17,22 +17,18 @@ COMMENT= XML-RPC library for C and C++
LICENSE= BSD
-OPTIONS_DEFINE= DEBUG CURL LIBWWW TOOLS
-OPTIONS_DEFAULT=CURL LIBWWW TOOLS
+OPTIONS_DEFINE= DEBUG CURL LIBWWW CPLUSPLUS
+OPTIONS_DEFAULT=CURL LIBWWW CPLUSPLUS
LIBWWW_DESC= Compile with libwww support
-TOOLS_DESC= Build xmlrpc-c tools
+CPLUSPLUS_DESC= Build xmlrpc-c c++ libs and tools
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-[0-9]*
-USE_PERL5= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:env
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
-MAKE_ARGS= LIBTOOL="${LIBTOOL}" \
- CFLAGS_COMMON="${CFLAGS}"
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
@@ -51,24 +47,20 @@ CONFIGURE_ARGS+= --disable-curl-client
.if ${PORT_OPTIONS:MLIBWWW}
LIB_DEPENDS+= wwwcore:${PORTSDIR}/www/libwww
-CONFIGURE_ARGS+= --enable-libwww-client
+CONFIGURE_ARGS+= --enable-libwww-client --with-libwww-ssl
.else
CONFIGURE_ARGS+= --disable-libwww-client
.endif
-.if ${PORT_OPTIONS:MTOOLS}
-CONFIGURE_ARGS+= --enable-tools
-PLIST_SUB+= TOOLS=""
-MAN1+= xml-rpc-api2cpp.1 xml-rpc-api2txt.1
+.if ${PORT_OPTIONS:MCPLUSPLUS}
+CONFIGURE_ARGS+= --enable-cplusplus
+PLIST_SUB+= CPLUSPLUS=""
.else
-CONFIGURE_ARGS+= --disable-tools
-PLIST_SUB+= TOOLS="@comment "
+CONFIGURE_ARGS+= --disable-cplusplus
+PLIST_SUB+= CPLUSPLUS="@comment "
.endif
.if empty(PORT_OPTIONS:MLIBWWW) && empty(PORT_OPTIONS:MCURL)
-. if ${PORT_OPTIONS:MTOOLS}
-IGNORE= xmlrpc-c tools requires CURL or LIBWWW support enabled
-. endif
PLIST_SUB+= CLIENT="@comment "
.else
PLIST_SUB+= CLIENT=""
@@ -81,9 +73,7 @@ post-extract:
post-patch:
@${GREP} -lR '\-lpthread' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
- @${REINPLACE_CMD} -e '/#include.*features.h/d' \
+ @${REINPLACE_CMD} -e '/#include.*features.h/ s/features.h/sys\/cdefs.h/' \
${WRKSRC}/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
- @${REINPLACE_CMD} -e 's/s6_addr16/s6_addr/g' \
- ${WRKSRC}/lib/abyss/src/socket_unix.c
.include <bsd.port.post.mk>