aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c-devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-05-16 15:29:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-05-16 15:29:38 +0000
commitc094eff5d50f2e6effcafcebd934747250525924 (patch)
tree8508677870abb72ce0b5508dec8c073cf7910ba0 /net/xmlrpc-c-devel
parent7c2d4fb932016ac7635573302a19c5f0d0225d59 (diff)
downloadports-c094eff5d50f2e6effcafcebd934747250525924.tar.gz
ports-c094eff5d50f2e6effcafcebd934747250525924.zip
Notes
Diffstat (limited to 'net/xmlrpc-c-devel')
-rw-r--r--net/xmlrpc-c-devel/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index 0bbb3be757fa..f2a5d8b33ee4 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= -devel
MAINTAINER= garga@FreeBSD.org
COMMENT= XML-RPC library for C and C++
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
OPTIONS_DEFINE= DEBUG CURL LIBWWW CPLUSPLUS
OPTIONS_DEFAULT=CURL LIBWWW CPLUSPLUS
@@ -20,12 +20,13 @@ CPLUSPLUS_DESC= Build xmlrpc-c c++ libs and tools
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-[0-9]*
-USES= gmake
+USES= gmake tar:xz
OPTIONS_SUB= yes
-USE_XZ= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
MAKE_JOBS_UNSAFE= yes
+MAKE_ENV+= INSTALL_SHLIB="${INSTALL_LIB}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}"
USE_LDCONFIG= yes
CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
@@ -60,5 +61,7 @@ post-patch:
${WRKSRC}/src/xmlrpc_server_abyss.c
@${REINPLACE_CMD} -e 's,sys/unistd.h,unistd.h,' \
${WRKSRC}/test/cpp/server_abyss.cpp
+ @${REINPLACE_CMD} -e '/^INSTALL_/s/=/\?=/' \
+ ${WRKSRC}/config.mk.in
.include <bsd.port.post.mk>