aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c-devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-05-25 20:44:45 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-05-25 20:44:45 +0000
commitc04ecf949bc343ad9531540bfad128e50d8d8d3d (patch)
treefcf69163c0190e0cb7507903e44dd0661a9783e5 /net/xmlrpc-c-devel
parentff1e2af9410e7c70608fe2a2c8c7113317d259cf (diff)
downloadports-c04ecf949bc343ad9531540bfad128e50d8d8d3d.tar.gz
ports-c04ecf949bc343ad9531540bfad128e50d8d8d3d.zip
Notes
Diffstat (limited to 'net/xmlrpc-c-devel')
-rw-r--r--net/xmlrpc-c-devel/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index 6371e5de5764..12253418976d 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -10,16 +10,17 @@ PORTNAME= xmlrpc-c
PORTVERSION= 1.18.00
CATEGORIES= net
MASTER_SITES= LOCAL/chinsan/xmlrpc-c
+PKGNAMESUFFIX= -devel
EXTRACT_SUFX= .tgz
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-PKGNAMESUFFIX= -devel
MAINTAINER= chinsan@FreeBSD.org
COMMENT= XML-RPC library for C and C++
OPTIONS= DEBUG "Compile with debugging information" off \
CURL "Compile with curl support" on \
- LIBWWW "Compile with libwww support" on
+ LIBWWW "Compile with libwww support" on \
+ CPLUSPLUS "Enable cpp headers and libs" off
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-[0-9]*
@@ -40,6 +41,12 @@ USE_LDCONFIG= yes
CFLAGS+= -DNDEBUG
.endif
+.if defined(WITH_CPLUSPLUS)
+CONFIGURE_ARGS+= --enable-cplusplus
+.else
+CONFIGURE_ARGS+= --disable-cplusplus
+.endif
+
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --disable-curl-client
.else