aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-08 07:58:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-08 07:58:54 +0000
commit31be84f148ca97e1578e1d580899723d961c1aa1 (patch)
tree7dcff7915d1ef31fc40eaba177fe7bea900f3d5b /net/xmlrpc-c
parent7527c43abd19c488d15184c0086977be1787e606 (diff)
downloadports-31be84f148ca97e1578e1d580899723d961c1aa1.tar.gz
ports-31be84f148ca97e1578e1d580899723d961c1aa1.zip
Notes
Diffstat (limited to 'net/xmlrpc-c')
-rw-r--r--net/xmlrpc-c/Makefile29
-rw-r--r--net/xmlrpc-c/distinfo1
-rw-r--r--net/xmlrpc-c/pkg-comment1
-rw-r--r--net/xmlrpc-c/pkg-descr17
-rw-r--r--net/xmlrpc-c/pkg-plist31
5 files changed, 79 insertions, 0 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
new file mode 100644
index 000000000000..6099a503835e
--- /dev/null
+++ b/net/xmlrpc-c/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: xmlrpc-c
+# Date created: Mar 8, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlrpc-c
+PORTVERSION= 0.9.8
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+post-install:
+ @${RM} -f ${PREFIX}/lib/*.la
+
+.include <bsd.port.mk>
diff --git a/net/xmlrpc-c/distinfo b/net/xmlrpc-c/distinfo
new file mode 100644
index 000000000000..fbe77ec3dea7
--- /dev/null
+++ b/net/xmlrpc-c/distinfo
@@ -0,0 +1 @@
+MD5 (xmlrpc-c-0.9.8.tar.gz) = 1470f8da19b43adebe2e0600191ff84c
diff --git a/net/xmlrpc-c/pkg-comment b/net/xmlrpc-c/pkg-comment
new file mode 100644
index 000000000000..66fb3d0e0202
--- /dev/null
+++ b/net/xmlrpc-c/pkg-comment
@@ -0,0 +1 @@
+XML-RPC library for C and C++
diff --git a/net/xmlrpc-c/pkg-descr b/net/xmlrpc-c/pkg-descr
new file mode 100644
index 000000000000..41931be8cb1d
--- /dev/null
+++ b/net/xmlrpc-c/pkg-descr
@@ -0,0 +1,17 @@
+XML-RPC is a quick-and-easy way to make procedure calls over the Internet.
+It converts the procedure call into XML document, sends it to a remote
+server using HTTP, and gets back the response as XML.
+
+This library provides a modular implementation of XML-RPC for C and C++.
+
+ - C API and experimental C++ API.
+ - Modular XML-RPC core: If you want, you can supply all your own HTTP
+ code.
+ - Synchronous and asynchronous XML-RPC clients based on w3c-libwww.
+ - Multithreaded XML-RPC server based on the Abyss web server.
+ - Full support for basic types, including <struct>, <array> and <base64>.
+ - Extensive test suites to help verify correct behavior and correct
+ error handling.
+ - Passes the official XML-RPC validator1 test suite.
+
+WWW: http://xmlrpc-c.sourceforge.net/
diff --git a/net/xmlrpc-c/pkg-plist b/net/xmlrpc-c/pkg-plist
new file mode 100644
index 000000000000..81b501a13d78
--- /dev/null
+++ b/net/xmlrpc-c/pkg-plist
@@ -0,0 +1,31 @@
+bin/meerkat-app-list
+bin/query-meerkat
+bin/xml-rpc-api2txt
+bin/xmlrpc-c-config
+include/XmlRpcCpp.h
+include/xmlrpc.h
+include/xmlrpc_abyss.h
+include/xmlrpc_cgi.h
+include/xmlrpc_client.h
+lib/libxmlrpc.a
+lib/libxmlrpc.so
+lib/libxmlrpc.so.5
+lib/libxmlrpc_abyss.a
+lib/libxmlrpc_abyss.so
+lib/libxmlrpc_abyss.so.5
+lib/libxmlrpc_abyss_server.a
+lib/libxmlrpc_abyss_server.so
+lib/libxmlrpc_abyss_server.so.5
+lib/libxmlrpc_cgi.a
+lib/libxmlrpc_cgi.so
+lib/libxmlrpc_cgi.so.5
+lib/libxmlrpc_client.a
+lib/libxmlrpc_client.so
+lib/libxmlrpc_client.so.5
+lib/libxmlrpc_cpp.a
+lib/libxmlrpc_xmlparse.a
+lib/libxmlrpc_xmlparse.so
+lib/libxmlrpc_xmlparse.so.5
+lib/libxmlrpc_xmltok.a
+lib/libxmlrpc_xmltok.so
+lib/libxmlrpc_xmltok.so.5