aboutsummaryrefslogtreecommitdiff
path: root/net/xrdesktop2
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-02-01 11:07:29 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-02-01 11:07:29 +0000
commit6ef0a1b4f53d9f6cc241e0ddb4d08b52ef2944df (patch)
tree44f60af2e6f092698aaff56deaf80a189af36d74 /net/xrdesktop2
parentc38739eb1495916d8720a4b1434ab8b8bab7993b (diff)
downloadports-6ef0a1b4f53d9f6cc241e0ddb4d08b52ef2944df.tar.gz
ports-6ef0a1b4f53d9f6cc241e0ddb4d08b52ef2944df.zip
Notes
Diffstat (limited to 'net/xrdesktop2')
-rw-r--r--net/xrdesktop2/Makefile40
-rw-r--r--net/xrdesktop2/distinfo2
-rw-r--r--net/xrdesktop2/pkg-descr9
-rw-r--r--net/xrdesktop2/pkg-message19
4 files changed, 70 insertions, 0 deletions
diff --git a/net/xrdesktop2/Makefile b/net/xrdesktop2/Makefile
new file mode 100644
index 000000000000..6edafd2d7d13
--- /dev/null
+++ b/net/xrdesktop2/Makefile
@@ -0,0 +1,40 @@
+# Created by: Chris Hutchinson <portmaster@BSDforge.com>
+# $FreeBSD$
+
+PORTNAME= xrdesktop2
+PORTVERSION= 2.00
+CATEGORIES= net
+MASTER_SITES= http://BSDforge.com/projects/source/net/xrdesktop2/
+
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= GTK2 frontend for Rdesktop
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop \
+ p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
+
+CONFLICTS= xrdesktop-1*
+
+NO_BUILD= yes
+NO_ARCH= yes
+USES= perl5 shebangfix tar:xz
+SHEBANG_FILES= xrdesktop
+DOCS= Changelog INSTALL LICENSE README
+PIXMAPS= *.png
+
+PLIST_FILES= bin/xrdesktop share/doc/xrdesktop2/Changelog \
+ share/doc/xrdesktop2/INSTALL share/doc/xrdesktop2/LICENSE \
+ share/doc/xrdesktop2/README share/pixmaps/x-remote-desktop-256.png \
+ share/pixmaps/x-remote-desktop-128.png \
+ share/pixmaps/x-remote-desktop-48.png \
+ share/applications/xrdesktop2.desktop
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xrdesktop ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${PIXMAPS} ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/xrdesktop2.desktop ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} ${WRKSRC}/${DOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/xrdesktop2/distinfo b/net/xrdesktop2/distinfo
new file mode 100644
index 000000000000..b64169cbcc95
--- /dev/null
+++ b/net/xrdesktop2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xrdesktop2-2.00.tar.xz) = c4f38793d138a37b13d02f77f8d94db09d47305f9d22052025995bace7d7d0e7
+SIZE (xrdesktop2-2.00.tar.xz) = 39088
diff --git a/net/xrdesktop2/pkg-descr b/net/xrdesktop2/pkg-descr
new file mode 100644
index 000000000000..f9e785de0184
--- /dev/null
+++ b/net/xrdesktop2/pkg-descr
@@ -0,0 +1,9 @@
+Xrdesktop2 is a GTK2-Perl frontend for Rdesktop, which allows for the
+saving, and editing of session configurations.
+
+Xrdesktop2's intent is to handle Rdesktop's available commandline options,
+by presenting them in a [Perl/GTK2] GUI. Xrdesktop2 currently handles most
+any of the options you're likely to be interested in. Future versions will
+undoubtedly add more.
+
+WWW: http://BSDforge.com/projects/net/xrdesktop2/
diff --git a/net/xrdesktop2/pkg-message b/net/xrdesktop2/pkg-message
new file mode 100644
index 000000000000..46719d116b11
--- /dev/null
+++ b/net/xrdesktop2/pkg-message
@@ -0,0 +1,19 @@
+=========================================================================
+* WARNING * WARNING * WARNING * WARNING * WARNING * WARNING * WARNING *
+
+ If are upgrading from a previous version;
+
+ xrdesktop_config is now xrdesktop2_config
+
+ If you intend to use previous config settings from 1.x versions, you
+ will need to start xrdesktop2, and allow it to create the config file
+ for the first time. Then exit xrdesktop2. You must do this BEFORE you
+ attempt to migrate settings from your previous config.
+
+ This is only required the first time you use xrdesktop2. This only
+ concerns those wanting to migrate their xrdesktop 1.x settings, and
+ does not affect first time users of xrdesktop2. This will NOT be
+ required in future versions.
+
+* WARNING * WARNING * WARNING * WARNING * WARNING * WARNING * WARNING *
+=========================================================================