aboutsummaryrefslogtreecommitdiff
path: root/net/yate
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-24 12:03:17 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-24 12:03:17 +0000
commitafcf4ba1c41b3f2164ed972c37a84a50caaa3e3e (patch)
tree4658801509bb7ef1dd338dc7e5a184f8bc2db8a4 /net/yate
parent8417519cc660ce9d027e0646a7691cdc71f61ddf (diff)
downloadports-afcf4ba1c41b3f2164ed972c37a84a50caaa3e3e.tar.gz
ports-afcf4ba1c41b3f2164ed972c37a84a50caaa3e3e.zip
Notes
Diffstat (limited to 'net/yate')
-rw-r--r--net/yate/Makefile40
-rw-r--r--net/yate/files/patch-configure.in11
-rw-r--r--net/yate/files/patch-modules__Makefile.in11
-rw-r--r--net/yate/pkg-plist3
4 files changed, 57 insertions, 8 deletions
diff --git a/net/yate/Makefile b/net/yate/Makefile
index 9bc4fb4e3c38..7d32857ff2f7 100644
--- a/net/yate/Makefile
+++ b/net/yate/Makefile
@@ -6,6 +6,7 @@
PORTNAME= yate
PORTVERSION= 3.3.2.p1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://yate.null.ro/tarballs/yate3/
DISTNAME= yate-3.3.2-1
@@ -18,7 +19,7 @@ LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
ONLY_FOR_ARCHS= i386 amd64 sparc64
-USE_AUTOTOOLS= autoconf:env
+USE_AUTOTOOLS= autoconf
USE_GMAKE= yes
USE_BISON= build
USE_LDCONFIG= yes
@@ -28,6 +29,7 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/yate
CONFIGURE_ARGS= --without-fdsize \
+ --without-libqt4 \
--with-zlib=/usr
LDFLAGS+= -L${LOCALBASE}/lib
@@ -43,6 +45,9 @@ MAN8= yate-config.8 yate.8
OPTIONS= MYSQL "MySQL Database support" off \
PGSQL "PostgreSQL Database support" off \
+ SCTP "Stream Control Transmission Protocol" on \
+ AMR_NB "AMR Narrow Band encoder (opencore)" off \
+ ILBC "Enable iLBC codec" off \
SPANDSP "Enable Spandsp faxing support" off \
DAHDI "Dahdi driver" off \
H323 "H323 software channel/protocol support" off \
@@ -77,6 +82,32 @@ CONFIGURE_ARGS+= --without-libpq
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
+.if !defined(WITHOUT_SCTP)
+CONFIGURE_ARGS+= --enable-sctp
+MAKE_ENV+= WITH_SCTP=1
+PLIST_SUB+= WITH_SCTP=""
+.else
+PLIST_SUB+= WITH_SCTP="@comment "
+.endif
+
+.if !defined(WITHOUT_AMR_NB)
+LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
+CONFIGURE_ARGS+= --with-amrnb=${LOCALBASE}
+PLIST_SUB+= WITH_AMR_NB=""
+.else
+CONFIGURE_ARGS+= --without-amrnb
+PLIST_SUB+= WITH_AMR_NB="@comment "
+.endif
+
+.if !defined(WITHOUT_ILBC)
+LIB_DEPENDS+= ilbc.0:${PORTSDIR}/net/ilbc
+CONFIGURE_ARGS+= --enable-ilbc
+PLIST_SUB+= WITH_ILBC=""
+.else
+CONFIGURE_ARGS+= --disable-ilbc
+PLIST_SUB+= WITH_ILBC="@comment "
+.endif
+
.if !defined(WITHOUT_SPANDSP)
CONFIGURE_ARGS+= --with-spandsp=${LOCALBASE}/include
LIB_DEPENDS+= spandsp.2:${PORTSDIR}/comms/spandsp-devel
@@ -93,7 +124,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/dahdi/user.h:${PORTSDIR}/misc/dahdi
MAKE_ENV+= WITH_DAHDI=1
PLIST_SUB+= WITH_DAHDI=""
.else
-CONFIGURE_ARGS+= --without-dahdi
+CONFIGURE_ARGS+= --disable-dahdi
PLIST_SUB+= WITH_DAHDI="@comment "
.endif
@@ -110,9 +141,8 @@ PLIST_SUB+= WITH_H323="@comment "
.endif
.if !defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= --with-openssl
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS+= ssl.7:${PORTSDIR}/security/openssl
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
MAKE_ENV+= WITH_SSL=1
PLIST_SUB+= WITH_SSL=""
.else
diff --git a/net/yate/files/patch-configure.in b/net/yate/files/patch-configure.in
index bfb8bb575a03..8ac624824440 100644
--- a/net/yate/files/patch-configure.in
+++ b/net/yate/files/patch-configure.in
@@ -1,5 +1,5 @@
--- ./configure.in.orig 2011-04-12 18:04:04.000000000 +0400
-+++ ./configure.in 2011-04-13 15:25:28.000000000 +0400
++++ ./configure.in 2012-01-17 00:54:49.000000000 +0400
@@ -476,7 +476,7 @@
AC_SUBST(MYSQL_VER)
@@ -45,3 +45,12 @@
if [[ "$vpw" '<' "01.06.00" ]]; then
# Very old pwlib needs more includes.
PWLIB_INC="$PWLIB_INC/unix/ptlib $PWLIB_INC/unix $PWLIB_INC"
+@@ -1036,7 +1036,7 @@
+ AC_MSG_CHECKING([for OpenSSL in $ac_cv_use_openssl])
+ verssl=no
+ if [[ -f "$ac_cv_use_openssl/include/openssl/opensslconf.h" ]]; then
+- verssl=`sed -n 's/^#define SHLIB_VERSION_NUMBER "\([0-9.]\+\)".*/\1/p' <$ac_cv_use_openssl/include/openssl/opensslv.h 2>/dev/null`
++ verssl=`sed -n 's/^#define SHLIB_VERSION_NUMBER "\([0-9.]*\)"/\1/p' <$ac_cv_use_openssl/include/openssl/opensslv.h 2>/dev/null`
+ if [[ "x$verssl" != "x" ]]; then
+ HAVE_OPENSSL=yes
+ OPENSSL_VER="$verssl"
diff --git a/net/yate/files/patch-modules__Makefile.in b/net/yate/files/patch-modules__Makefile.in
index 5272d97495ea..c0426ce58813 100644
--- a/net/yate/files/patch-modules__Makefile.in
+++ b/net/yate/files/patch-modules__Makefile.in
@@ -1,5 +1,5 @@
--- ./modules/Makefile.in.orig 2011-03-03 17:48:39.000000000 +0300
-+++ ./modules/Makefile.in 2011-04-13 15:26:16.000000000 +0400
++++ ./modules/Makefile.in 2012-01-17 00:53:04.000000000 +0400
@@ -32,7 +32,7 @@
ZLIB_LIB := @ZLIB_LIB@
SED := sed
@@ -9,3 +9,12 @@
CFLAGS := @CFLAGS@ @MODULE_CFLAGS@ @INLINE_FLAGS@
CPPFLAGS := @CFLAGS@ @MODULE_CPPFLAGS@ @INLINE_FLAGS@
LDFLAGS:= @LDFLAGS@
+@@ -316,7 +316,7 @@
+ server/mgcpgw.yate: LOCALLIBS = -lyatemgcp
+
+ server/lksctp.yate: LOCALFLAGS = @SCTP_FLAGS@
+-server/lksctp.yate: LOCALLIBS = -lsctp
++server/lksctp.yate: LOCALLIBS =
+
+ ilbccodec.yate: ../libs/ilbc/libilbc.a
+ ilbccodec.yate: LOCALFLAGS = @ILBC_INC@
diff --git a/net/yate/pkg-plist b/net/yate/pkg-plist
index 38c30efb3e10..b4b02c34f35e 100644
--- a/net/yate/pkg-plist
+++ b/net/yate/pkg-plist
@@ -211,7 +211,7 @@ lib/yate/extmodule.yate
lib/yate/filetransfer.yate
lib/yate/gsmcodec.yate
%%WITH_H323%%lib/yate/h323chan.yate
-lib/yate/ilbccodec.yate
+%%WITH_ILBC%%lib/yate/ilbccodec.yate
lib/yate/jabber/jabberserver.yate
lib/yate/jabber/jbfeatures.yate
lib/yate/moh.yate
@@ -234,6 +234,7 @@ lib/yate/server/dbwave.yate
lib/yate/server/heartbeat.yate
lib/yate/server/isupmangler.yate
lib/yate/server/lateroute.yate
+%%WITH_SCTP%%lib/yate/server/lksctp.yate
lib/yate/server/mgcpca.yate
lib/yate/server/mgcpgw.yate
lib/yate/server/monitoring.yate