aboutsummaryrefslogtreecommitdiff
path: root/net/zebra-server
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2002-08-17 11:41:43 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2002-08-17 11:41:43 +0000
commitedcde514a44a38cfb9cbfecefffa8020e4457ce5 (patch)
tree7261f698c6193b7f2078577cea2c2342dabd42b3 /net/zebra-server
parent767f15aedce9138a67be67343fdff7b446adb0ee (diff)
downloadports-edcde514a44a38cfb9cbfecefffa8020e4457ce5.tar.gz
ports-edcde514a44a38cfb9cbfecefffa8020e4457ce5.zip
Notes
Diffstat (limited to 'net/zebra-server')
-rw-r--r--net/zebra-server/Makefile9
-rw-r--r--net/zebra-server/distinfo2
-rw-r--r--net/zebra-server/files/patch-aa11
-rw-r--r--net/zebra-server/files/patch-configure12
-rw-r--r--net/zebra-server/files/patch-dict-Makefile.in11
-rw-r--r--net/zebra-server/files/patch-doc-Makefile.in11
-rw-r--r--net/zebra-server/pkg-plist36
7 files changed, 47 insertions, 45 deletions
diff --git a/net/zebra-server/Makefile b/net/zebra-server/Makefile
index 76b623b3bfc3..f4a3dae3562b 100644
--- a/net/zebra-server/Makefile
+++ b/net/zebra-server/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= zebra-server
-PORTVERSION= 1.1
+PORTVERSION= 1.3.0
CATEGORIES= net
MASTER_SITES= http://ftp.indexdata.dk/pub/zebra/
-DISTNAME= zebra-${PORTVERSION:S/0./0pl/}
+DISTNAME= zebra-${PORTVERSION}
MAINTAINER= demon@FreeBSD.org
+BUILD_DEPENDS= ${LOCALBASE}/bin/tclsh8.3:${PORTSDIR}/lang/tcl83
LIB_DEPENDS= yaz.1:${PORTSDIR}/net/yaz
+RUN_DEPENDS= ${LOCALBASE}/bin/tclsh8.3:${PORTSDIR}/lang/tcl83
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-yazconfig=${LOCALBASE}/bin
+CONFIGURE_ARGS= --with-yazconfig=${LOCALBASE}/bin \
+ --with-tclconfig=${LOCALBASE}/lib/tcl8.3
CONFIGURE_ENV+= PTHREAD_LIBS=${PTHREAD_LIBS}
post-install:
diff --git a/net/zebra-server/distinfo b/net/zebra-server/distinfo
index d728a555f5ce..3657776a162d 100644
--- a/net/zebra-server/distinfo
+++ b/net/zebra-server/distinfo
@@ -1 +1 @@
-MD5 (zebra-1.1.tar.gz) = 15bb6efecc81fb92fb387a682b35ed82
+MD5 (zebra-1.3.0.tar.gz) = d6fdb07a83256b3caf5b8e2cf37d4c5f
diff --git a/net/zebra-server/files/patch-aa b/net/zebra-server/files/patch-aa
deleted file mode 100644
index cd1073d6515a..000000000000
--- a/net/zebra-server/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- index/lockutil.c.orig Sat Sep 16 14:24:25 2000
-+++ index/lockutil.c Sat Sep 16 14:24:40 2000
-@@ -79,7 +79,7 @@
- (O_BINARY|O_CREAT|O_RDWR), 0666);
- #else
- h->fd= open (name, ((h->excl_flag > 1) ? O_EXCL : 0)|
-- (O_BINARY|O_CREAT|O_RDWR|O_SYNC), 0666);
-+ (O_BINARY|O_CREAT|O_RDWR), 0666);
- #endif
- if (h->fd == -1)
- {
diff --git a/net/zebra-server/files/patch-configure b/net/zebra-server/files/patch-configure
index 3d453e941fec..a4fa60833a21 100644
--- a/net/zebra-server/files/patch-configure
+++ b/net/zebra-server/files/patch-configure
@@ -1,13 +1,13 @@
---- configure.orig Thu Oct 25 17:24:18 2001
-+++ configure Wed Dec 26 11:41:58 2001
-@@ -794,7 +794,7 @@
- EOF
+--- configure.orig Sat Aug 17 14:52:11 2002
++++ configure Sat Aug 17 14:53:16 2002
+@@ -697,7 +697,7 @@
+ fi
+
-
-PACKAGE=zebra
+PACKAGE=zebra-server
- VERSION=1.1
+ VERSION=1.3.0
@@ -2005,6 +2005,7 @@
s%@DEFS@%$DEFS%g
diff --git a/net/zebra-server/files/patch-dict-Makefile.in b/net/zebra-server/files/patch-dict-Makefile.in
new file mode 100644
index 000000000000..d5d4d38e2ab0
--- /dev/null
+++ b/net/zebra-server/files/patch-dict-Makefile.in
@@ -0,0 +1,11 @@
+--- dict/Makefile.in.orig Sat Aug 17 14:58:12 2002
++++ dict/Makefile.in Sat Aug 17 14:58:39 2002
+@@ -113,7 +113,7 @@
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+-LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
++LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) @PTHREAD_LIBS@ -o $@
+ DIST_COMMON = Makefile.am Makefile.in
+
+
diff --git a/net/zebra-server/files/patch-doc-Makefile.in b/net/zebra-server/files/patch-doc-Makefile.in
deleted file mode 100644
index 5b44d9c801f6..000000000000
--- a/net/zebra-server/files/patch-doc-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.in.orig Sun Dec 23 14:33:05 2001
-+++ doc/Makefile.in Sun Dec 23 14:34:23 2001
-@@ -73,7 +73,7 @@
- YAZVERSION = @YAZVERSION@
- yazconfig = @yazconfig@
-
--docdir = $(pkgdatadir)/doc
-+docdir = $(datadir)/doc/@PACKAGE@
-
- doc_DATA = zebra.sgml gils.sgml zebra.txt zebra.ps zebra.html zebra-1.html zebra-2.html zebra-3.html zebra-4.html zebra-5.html zebra-6.html zebra-7.html zebra-8.html zebra-9.html
-
diff --git a/net/zebra-server/pkg-plist b/net/zebra-server/pkg-plist
index b11c0d08aadc..fdac89e6e1cb 100644
--- a/net/zebra-server/pkg-plist
+++ b/net/zebra-server/pkg-plist
@@ -1,19 +1,29 @@
bin/zebraidx
bin/zebrasrv
-share/doc/zebra-server/gils.sgml
-share/doc/zebra-server/zebra-1.html
-share/doc/zebra-server/zebra-2.html
-share/doc/zebra-server/zebra-3.html
-share/doc/zebra-server/zebra-4.html
-share/doc/zebra-server/zebra-5.html
-share/doc/zebra-server/zebra-6.html
-share/doc/zebra-server/zebra-7.html
-share/doc/zebra-server/zebra-8.html
-share/doc/zebra-server/zebra-9.html
share/doc/zebra-server/zebra.html
-share/doc/zebra-server/zebra.ps
-share/doc/zebra-server/zebra.sgml
-share/doc/zebra-server/zebra.txt
+share/doc/zebra-server/zebra.pdf
+share/doc/zebra-server/administration.html
+share/doc/zebra-server/configuration-file.html
+share/doc/zebra-server/data-model.html
+share/doc/zebra-server/features.html
+share/doc/zebra-server/file-ids.html
+share/doc/zebra-server/formats.html
+share/doc/zebra-server/future.html
+share/doc/zebra-server/generic-ids.html
+share/doc/zebra-server/indexdata.html
+share/doc/zebra-server/installation.html
+share/doc/zebra-server/internal-representation.html
+share/doc/zebra-server/introduction.html
+share/doc/zebra-server/license.html
+share/doc/zebra-server/locating-records.html
+share/doc/zebra-server/protocol-support.html
+share/doc/zebra-server/quick-start.html
+share/doc/zebra-server/record-model.html
+share/doc/zebra-server/register-location.html
+share/doc/zebra-server/server.html
+share/doc/zebra-server/shadow-registers.html
+share/doc/zebra-server/simple-indexing.html
+share/doc/zebra-server/zebraidx.html
share/zebra-server/tab/default.idx
share/zebra-server/tab/hci.flt
share/zebra-server/tab/mail.flt