aboutsummaryrefslogtreecommitdiff
path: root/net/zebra/scripts
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2001-01-11 21:45:05 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2001-01-11 21:45:05 +0000
commit6e2dbdc869e741fe3c44a514e3344dafc15b014f (patch)
tree5f96c4ff4fb9d9c9bfb205af358521035242012e /net/zebra/scripts
parent070b9cadbcb588fc95898606d4349e846eb2d3a4 (diff)
downloadports-6e2dbdc869e741fe3c44a514e3344dafc15b014f.tar.gz
ports-6e2dbdc869e741fe3c44a514e3344dafc15b014f.zip
Notes
Diffstat (limited to 'net/zebra/scripts')
-rw-r--r--net/zebra/scripts/configure57
1 files changed, 57 insertions, 0 deletions
diff --git a/net/zebra/scripts/configure b/net/zebra/scripts/configure
new file mode 100644
index 000000000000..68629d4f44f0
--- /dev/null
+++ b/net/zebra/scripts/configure
@@ -0,0 +1,57 @@
+#! /bin/sh
+
+# $FreeBSD$
+
+# configure - zebra compile time option configurator
+# by Andreas Klemm <andreas@FreeBSD.org>
+
+if [ "$BATCH" != "yes" -o "$BATCH" != "YES" ]; then
+
+#
+# configure - zebra compile time options
+#
+
+/usr/bin/dialog --title "Zebra Compile Time Options" --clear \
+ --checklist "\n\
+Select compile time options for zebra port:" -1 -1 8 \
+LIBPAM "enable PAM authentication for vtysh" OFF \
+OSPF_NSSA "turn on undergoing NSSA feature" OFF \
+SNMP "enable SNMP support" OFF \
+2> /tmp/zebra-checklist.$$
+
+retval=$?
+
+if [ -s /tmp/zebra-checklist.$$ ]; then
+ set `cat /tmp/zebra-checklist.$$`
+fi
+rm -f /tmp/zebra-checklist.$$
+
+case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+esac
+
+/bin/mkdir -p ${WRKDIRPREFIX}${CURDIR}
+exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+
+while [ "$1" ]; do
+ case $1 in
+ \"LIBPAM\")
+ echo CONFIGURE_ARGS+=--with-libpam
+ ;;
+ \"OSPF_NSSA\")
+ echo CONFIGURE_ARGS+=--enable-nssa
+ ;;
+ \"SNMP\")
+ echo CONFIGURE_ARGS+=--enable-snmp
+ ;;
+ esac
+ shift
+done
+
+fi # if $BATCH