aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-05 10:32:23 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-05 10:32:23 +0000
commit3779b5222a514b8dab0105840de4ce2c02760e4f (patch)
treef187844035a77de7a87722694043987a9592c380 /net
parentffb2503c984f5260a595c3426b3381b6fe13041e (diff)
downloadports-3779b5222a514b8dab0105840de4ce2c02760e4f.tar.gz
ports-3779b5222a514b8dab0105840de4ce2c02760e4f.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/freenx/Makefile3
-rw-r--r--net/ldap-stats/Makefile2
-rw-r--r--net/p5-Amazon-SQS-Simple/Makefile3
-rw-r--r--net/p5-BBS-UserInfo-Maple3/Makefile3
-rw-r--r--net/p5-Filesys-SmbClient/Makefile3
-rw-r--r--net/p5-IO-Socket-Multicast/Makefile3
-rw-r--r--net/p5-IPC-Session/Makefile3
-rw-r--r--net/p5-Net-Divert/Makefile3
-rw-r--r--net/p5-Net-LDAP-posixAccount/Makefile3
-rw-r--r--net/p5-Net-Server-SS-PreFork/Makefile3
-rw-r--r--net/p5-Net-Todoist/Makefile3
-rw-r--r--net/p5-Net-sFlow/Makefile3
-rw-r--r--net/p5-POE-Component-Client-Telnet/Makefile3
-rw-r--r--net/p5-POE-Component-Client-Traceroute/Makefile3
-rw-r--r--net/p5-POE-Component-Client-Twitter/Makefile3
-rw-r--r--net/p5-SOAP-MySOAP/Makefile3
-rw-r--r--net/p5-URI-Match/Makefile3
-rw-r--r--net/p5-XML-Fast/Makefile3
-rw-r--r--net/sendsnpp/Makefile3
19 files changed, 37 insertions, 19 deletions
diff --git a/net/freenx/Makefile b/net/freenx/Makefile
index fcd0d0eac78b..7662d51fe595 100644
--- a/net/freenx/Makefile
+++ b/net/freenx/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= ${NXPREFIX}/bin/nxagent:${PORTSDIR}/net/nxserver \
expect:${PORTSDIR}/lang/expect \
gls:${PORTSDIR}/sysutils/coreutils \
xauth:${PORTSDIR}/x11/xauth
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
BUILD_WRKSRC= ${WRKSRC}/nxserver-helper
diff --git a/net/ldap-stats/Makefile b/net/ldap-stats/Makefile
index ae286b49b776..46efc7bb709e 100644
--- a/net/ldap-stats/Makefile
+++ b/net/ldap-stats/Makefile
@@ -16,7 +16,7 @@ COMMENT= Program to generate OpenLDAP statistics reports
RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/ldap-stats
diff --git a/net/p5-Amazon-SQS-Simple/Makefile b/net/p5-Amazon-SQS-Simple/Makefile
index abc434884f6f..ccf4cd64c751 100644
--- a/net/p5-Amazon-SQS-Simple/Makefile
+++ b/net/p5-Amazon-SQS-Simple/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Amazon::SQS::Simple::Message.3 \
Amazon::SQS::Simple::Queue.3 \
diff --git a/net/p5-BBS-UserInfo-Maple3/Makefile b/net/p5-BBS-UserInfo-Maple3/Makefile
index f66629817422..9d361779d255 100644
--- a/net/p5-BBS-UserInfo-Maple3/Makefile
+++ b/net/p5-BBS-UserInfo-Maple3/Makefile
@@ -17,7 +17,8 @@ COMMENT= Get user information of Maple3-style BBS
RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::UserInfo::Maple3.3
diff --git a/net/p5-Filesys-SmbClient/Makefile b/net/p5-Filesys-SmbClient/Makefile
index 2d0c7c39bf3a..e6dac63ea3fe 100644
--- a/net/p5-Filesys-SmbClient/Makefile
+++ b/net/p5-Filesys-SmbClient/Makefile
@@ -13,7 +13,8 @@ COMMENT= Interface for access Samba filesystem with libsmclient.so
LIB_DEPENDS= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Filesys::SmbClient.3
diff --git a/net/p5-IO-Socket-Multicast/Makefile b/net/p5-IO-Socket-Multicast/Makefile
index 9115523abb56..e6aeb40da358 100644
--- a/net/p5-IO-Socket-Multicast/Makefile
+++ b/net/p5-IO-Socket-Multicast/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
MAN3= IO::Socket::Multicast.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
post-install:
.ifndef(NOPORTEXAMPLES)
diff --git a/net/p5-IPC-Session/Makefile b/net/p5-IPC-Session/Makefile
index 316b934b7c6a..adbbf1304c4b 100644
--- a/net/p5-IPC-Session/Makefile
+++ b/net/p5-IPC-Session/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= avk@vl.ru
COMMENT= Drive ssh or other interactive shell, local or remote (like 'expect')
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IPC::Session.3
diff --git a/net/p5-Net-Divert/Makefile b/net/p5-Net-Divert/Makefile
index f1ef8504d69c..43f5bce0b154 100644
--- a/net/p5-Net-Divert/Makefile
+++ b/net/p5-Net-Divert/Makefile
@@ -11,7 +11,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ecu@200ok.org
COMMENT= A module to deal with divert(4) sockets
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Divert.3
diff --git a/net/p5-Net-LDAP-posixAccount/Makefile b/net/p5-Net-LDAP-posixAccount/Makefile
index 3ef6e447d4ad..127c796f112e 100644
--- a/net/p5-Net-LDAP-posixAccount/Makefile
+++ b/net/p5-Net-LDAP-posixAccount/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
p5-Sys-User-UIDhelper>=0:${PORTSDIR}/sysutils/p5-Sys-User-UIDhelper \
p5-Sys-Group-GIDhelper>=0:${PORTSDIR}/sysutils/p5-Sys-Group-GIDhelper
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::posixAccount.3
diff --git a/net/p5-Net-Server-SS-PreFork/Makefile b/net/p5-Net-Server-SS-PreFork/Makefile
index 6b09a4d2bd5c..8d1cf5b73b0f 100644
--- a/net/p5-Net-Server-SS-PreFork/Makefile
+++ b/net/p5-Net-Server-SS-PreFork/Makefile
@@ -26,7 +26,8 @@ TEST_DEPENDS= p5-HTTP-Server-Simple>0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
p5-Test-TCP>=0.06:${PORTSDIR}/devel/p5-Test-TCP \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Server::SS::PreFork.3
diff --git a/net/p5-Net-Todoist/Makefile b/net/p5-Net-Todoist/Makefile
index a9c7234f6952..debdac7ff69c 100644
--- a/net/p5-Net-Todoist/Makefile
+++ b/net/p5-Net-Todoist/Makefile
@@ -17,7 +17,8 @@ COMMENT= Todoist API
RUN_DEPENDS= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Todoist.3
diff --git a/net/p5-Net-sFlow/Makefile b/net/p5-Net-sFlow/Makefile
index 60fc86b93d04..5dac24da9ea9 100644
--- a/net/p5-Net-sFlow/Makefile
+++ b/net/p5-Net-sFlow/Makefile
@@ -16,7 +16,8 @@ COMMENT= Decode sFlow datagrams
LICENSE= ART10
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::sFlow.3
diff --git a/net/p5-POE-Component-Client-Telnet/Makefile b/net/p5-POE-Component-Client-Telnet/Makefile
index 9e09d010bec2..d8f2fef33af2 100644
--- a/net/p5-POE-Component-Client-Telnet/Makefile
+++ b/net/p5-POE-Component-Client-Telnet/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Client::Telnet.3
diff --git a/net/p5-POE-Component-Client-Traceroute/Makefile b/net/p5-POE-Component-Client-Traceroute/Makefile
index c2bbd610972a..0fc49a59cba2 100644
--- a/net/p5-POE-Component-Client-Traceroute/Makefile
+++ b/net/p5-POE-Component-Client-Traceroute/Makefile
@@ -17,7 +17,8 @@ COMMENT= A non-blocking traceroute client
RUN_DEPENDS= p5-POE>=0.11:${PORTSDIR}/devel/p5-POE
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Client::Traceroute.3
diff --git a/net/p5-POE-Component-Client-Twitter/Makefile b/net/p5-POE-Component-Client-Twitter/Makefile
index 17a67d3892b5..808237137ea9 100644
--- a/net/p5-POE-Component-Client-Twitter/Makefile
+++ b/net/p5-POE-Component-Client-Twitter/Makefile
@@ -25,7 +25,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Client::Twitter.3
diff --git a/net/p5-SOAP-MySOAP/Makefile b/net/p5-SOAP-MySOAP/Makefile
index 15b7e82c2b27..80ffbe2c3ce7 100644
--- a/net/p5-SOAP-MySOAP/Makefile
+++ b/net/p5-SOAP-MySOAP/Makefile
@@ -19,7 +19,8 @@ COMMENT= An extremely basic SOAP client module
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SOAP::MySOAP.3
diff --git a/net/p5-URI-Match/Makefile b/net/p5-URI-Match/Makefile
index 6e8356b0d31e..5429d69fa5e3 100644
--- a/net/p5-URI-Match/Makefile
+++ b/net/p5-URI-Match/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= \
p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::Match.3
diff --git a/net/p5-XML-Fast/Makefile b/net/p5-XML-Fast/Makefile
index 0a073bfd5bc9..ac63b1abd134 100644
--- a/net/p5-XML-Fast/Makefile
+++ b/net/p5-XML-Fast/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dhn@FreeBSD.org
COMMENT= Simple and very fast XML to hash conversion
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Fast.3
diff --git a/net/sendsnpp/Makefile b/net/sendsnpp/Makefile
index b3972e8e03e4..7f9b1821a6c8 100644
--- a/net/sendsnpp/Makefile
+++ b/net/sendsnpp/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= itetcu@FreeBSD.org
COMMENT= Tool for sending messages through a RFC1861 compliant SNPP server
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
PLIST_FILES= bin/sendSNPP.pl