aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-10 16:38:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-10 16:38:00 +0000
commit44105bbef82d297a098e178b03eb4290daa5d98b (patch)
tree4a763a23b7382a8c937ccd9826b459ad9ccec255 /net
parent9d0989571c6206b6ed8d38f60bd2033d59a689a1 (diff)
downloadports-44105bbef82d297a098e178b03eb4290daa5d98b.tar.gz
ports-44105bbef82d297a098e178b03eb4290daa5d98b.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/binkd/Makefile2
-rw-r--r--net/hawknl-devel/Makefile4
-rw-r--r--net/hupnp/Makefile3
-rw-r--r--net/jsch/Makefile2
-rw-r--r--net/libtcp4u/Makefile2
-rw-r--r--net/nusoap/Makefile2
-rw-r--r--net/openmq/Makefile2
-rw-r--r--net/p5-Net-Ping-External/Makefile3
-rw-r--r--net/p5-S3/Makefile3
-rw-r--r--net/py-pysphere/Makefile3
-rw-r--r--net/py-xmlrpclib/Makefile2
-rw-r--r--net/py-zope.proxy/Makefile2
-rw-r--r--net/repeater/Makefile2
-rw-r--r--net/rsmb/Makefile2
-rw-r--r--net/sip_scenario/Makefile3
-rw-r--r--net/tn5250j/Makefile2
-rw-r--r--net/wizd/Makefile4
17 files changed, 18 insertions, 25 deletions
diff --git a/net/binkd/Makefile b/net/binkd/Makefile
index 3caacb7342f2..d66137a4f1c5 100644
--- a/net/binkd/Makefile
+++ b/net/binkd/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= Fidonet TCP/IP mailer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_ZIP= yes
+USES= zip
USE_RC_SUBR= binkd
GNU_CONFIGURE= yes
diff --git a/net/hawknl-devel/Makefile b/net/hawknl-devel/Makefile
index fea6b5c3ec42..fa0b2231a0a2 100644
--- a/net/hawknl-devel/Makefile
+++ b/net/hawknl-devel/Makefile
@@ -14,9 +14,7 @@ COMMENT= Portable networking library (devel)
CONFLICTS= hawknl-[0-9]*
-USE_ZIP= yes
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
+USES= dos2unix gmake zip
MAKEFILE= makefile.linux
USE_LDCONFIG= yes
diff --git a/net/hupnp/Makefile b/net/hupnp/Makefile
index 6919675c65b2..5111c21003b9 100644
--- a/net/hupnp/Makefile
+++ b/net/hupnp/Makefile
@@ -11,8 +11,7 @@ DISTNAME= herqq-${PORTVERSION}
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Library for building UPnP devices and control points
-USES= gmake qmake
-USE_ZIP= yes
+USES= gmake qmake zip
USE_QT4= corelib network xml dbus gui \
moc_build rcc_build uic_build
diff --git a/net/jsch/Makefile b/net/jsch/Makefile
index 11bba2c86719..b0bbbd4f13df 100644
--- a/net/jsch/Makefile
+++ b/net/jsch/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF
MAINTAINER= miwi@FreeBSD.org
COMMENT= A pure Java implementation of SSH2
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/net/libtcp4u/Makefile b/net/libtcp4u/Makefile
index 018fba96fcd4..6b0ada382896 100644
--- a/net/libtcp4u/Makefile
+++ b/net/libtcp4u/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/tcp4u.331/src
PATCH_WRKSRC= ${WRKDIR}/tcp4u.331
-USE_ZIP= yes
+USES= zip
PLIST_FILES= include/udp4u.h include/tcp4u.h \
include/smtp4u.h include/http4u.h \
diff --git a/net/nusoap/Makefile b/net/nusoap/Makefile
index f117a3e938a3..55126edde728 100644
--- a/net/nusoap/Makefile
+++ b/net/nusoap/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= SF
MAINTAINER= clsung@FreeBSD.org
COMMENT= SOAP Toolkit for PHP
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PHP= curl zlib xml
-USE_ZIP= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/net/openmq/Makefile b/net/openmq/Makefile
index f668b9d55bf2..a1b82ecf1b51 100644
--- a/net/openmq/Makefile
+++ b/net/openmq/Makefile
@@ -23,7 +23,7 @@ BOOTJARS= javaee-api-6.0.jar:2 \
grizzly-nio-framework-1.9.18a.jar:3 \
jhall-2.0.jar:4
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6
JAVA_VENDOR= openjdk
diff --git a/net/p5-Net-Ping-External/Makefile b/net/p5-Net-Ping-External/Makefile
index 33b5218dd55f..0ba6967e9cb9 100644
--- a/net/p5-Net-Ping-External/Makefile
+++ b/net/p5-Net-Ping-External/Makefile
@@ -13,8 +13,7 @@ COMMENT= Perl cross-platform interface to ICMP "ping" utilities
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-USE_ZIP= yes
-USES= perl5
+USES= perl5 zip
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index a0e205a15903..7da5b5fa4985 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS= p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
-USES= perl5
+USES= perl5 zip
USE_PERL5= run
-USE_ZIP= yes
WRKSRC= ${WRKDIR}/s3-example-libraries/perl
do-install:
diff --git a/net/py-pysphere/Makefile b/net/py-pysphere/Makefile
index a41ec978bf21..5dca8bad3263 100644
--- a/net/py-pysphere/Makefile
+++ b/net/py-pysphere/Makefile
@@ -13,8 +13,7 @@ COMMENT= Python API for interaction with the vSphere Web Services SDK
LICENSE= BSD
-USE_ZIP= yes
-USE_DOS2UNIX= yes
+USES= dos2unix zip
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/net/py-xmlrpclib/Makefile b/net/py-xmlrpclib/Makefile
index ed7d65012701..28431b1ba231 100644
--- a/net/py-xmlrpclib/Makefile
+++ b/net/py-xmlrpclib/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Python implementation of the XML-RPC protocol
USE_PYTHON= yes
-USE_ZIP= yes
+USES= zip
DOCSDIR= ${PREFIX}/share/doc/py-xmlrpclib
EXAMPLESDIR= ${PREFIX}/share/examples/py-xmlrpclib
diff --git a/net/py-zope.proxy/Makefile b/net/py-zope.proxy/Makefile
index 5c695cf15297..f19aa0852502 100644
--- a/net/py-zope.proxy/Makefile
+++ b/net/py-zope.proxy/Makefile
@@ -16,9 +16,9 @@ LICENSE= ZPL21
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0:${PORTSDIR}/devel/py-zope.interface
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/net/repeater/Makefile b/net/repeater/Makefile
index c6d1edcca587..5cd635f92962 100644
--- a/net/repeater/Makefile
+++ b/net/repeater/Makefile
@@ -10,7 +10,7 @@ DISTNAME= repeater${PORTVERSION:C/\.//}
MAINTAINER= rick@sloservers.com
COMMENT= UltraVNC repeater
-USE_ZIP= yes
+USES= zip
USE_RC_SUBR= repeater
WRKSRC= ${WRKDIR}/Ver${PORTVERSION:C/\.//}
ALL_TARGET= repeater
diff --git a/net/rsmb/Makefile b/net/rsmb/Makefile
index 6dc2520da427..00b19607c77c 100644
--- a/net/rsmb/Makefile
+++ b/net/rsmb/Makefile
@@ -12,7 +12,7 @@ COMMENT= Really Small Message Broker, an MQTT supporting server
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
+USES= zip
USE_LINUX= yes
LINUX_OSRELEASE=2.6.16
IA32_BINARY_PORT= yes
diff --git a/net/sip_scenario/Makefile b/net/sip_scenario/Makefile
index 4442f3323aa6..b960c143711e 100644
--- a/net/sip_scenario/Makefile
+++ b/net/sip_scenario/Makefile
@@ -12,8 +12,7 @@ COMMENT= SIP call flow creator (HTML format)
LICENSE= APACHE20
-USE_ZIP= yes
-USES= perl5
+USES= perl5 zip
USE_PERL5= run
WRKSRC= ${WRKDIR}
diff --git a/net/tn5250j/Makefile b/net/tn5250j/Makefile
index 358bdef85291..5487748ec08a 100644
--- a/net/tn5250j/Makefile
+++ b/net/tn5250j/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${JAVAJARDIR}/mail.jar:${PORTSDIR}/java/javamail \
${JAVAJARDIR}/itext.jar:${PORTSDIR}/devel/itext \
${JAVAJARDIR}/log4j.jar:${PORTSDIR}/devel/log4j
-USE_ZIP= yes
+USES= zip
USE_ANT= yes
USE_JAVA= 1.3+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/net/wizd/Makefile b/net/wizd/Makefile
index b4ec5a786dfc..9b7398b6ab0b 100644
--- a/net/wizd/Makefile
+++ b/net/wizd/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= libdvdread.so:${PORTSDIR}/multimedia/libdvdread \
libjpeg.so:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
-USE_DOS2UNIX= Makefile nkfwrap/Makefile nkfwrap/nkfwrap_test.c \
+DOS2UNIX_FILES= Makefile nkfwrap/Makefile nkfwrap/nkfwrap_test.c \
wizd_http.c wizd_menu.c
USE_RC_SUBR= wizd
-USE_ZIP= yes
+USES= dos2unix zip:infozip
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
post-patch: