aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2018-10-22 15:34:55 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2018-10-22 15:34:55 +0000
commita483159515eb30a66230a2415be6603436db18a2 (patch)
treec3a4298f23b3ae3fee012004e1d8948b0ba70802 /net
parent89bcd41ec26418e25fc01a2d42784b766767c550 (diff)
downloadports-a483159515eb30a66230a2415be6603436db18a2.tar.gz
ports-a483159515eb30a66230a2415be6603436db18a2.zip
New port: net/flent:
Flent is a Python wrapper to run multiple simultaneous netperf/iperf/ping instances and aggregate the results. It was previously known as 'netperf-wrapper'. WWW: https://flent.org
Notes
Notes: svn path=/head/; revision=482747
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/flent/Makefile33
-rw-r--r--net/flent/distinfo3
-rw-r--r--net/flent/pkg-descr5
4 files changed, 42 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7b3a77c67867..94e14b24cc38 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -147,6 +147,7 @@
SUBDIR += fiche
SUBDIR += file2pcap
SUBDIR += findmtu
+ SUBDIR += flent
SUBDIR += flower
SUBDIR += flowgrep
SUBDIR += fonulator
diff --git a/net/flent/Makefile b/net/flent/Makefile
new file mode 100644
index 000000000000..e4031c6fd355
--- /dev/null
+++ b/net/flent/Makefile
@@ -0,0 +1,33 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flent
+PORTVERSION= 1.2.2
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+MASTER_SITES= GH \
+ ZI
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= FLExible Network Tester
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= fping>0:net/fping \
+ iperf>0:benchmarks/iperf \
+ netperf>0:benchmarks/netperf
+
+USES= desktop-file-utils python:2.7 shared-mime-info
+USE_PYTHON= distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= tohojo
+NO_ARCH= yes
+
+OPTIONS_DEFINE= MATPLOT
+MATPLOT_DESC= Plot results using matplotlib (requires X)
+MATPLOT_RUN_DEPENDS= py-matplotlib>0:math/py-matplotlib
+
+.include <bsd.port.options.mk>
+
+.include <bsd.port.mk>
diff --git a/net/flent/distinfo b/net/flent/distinfo
new file mode 100644
index 000000000000..c0a8a0f66bf3
--- /dev/null
+++ b/net/flent/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540220792
+SHA256 (tohojo-flent-v1.2.2_GH0.tar.gz) = 554bb1b5329cd39113cbb34445765ca6868dbf033aa64832d957d4a09d56adc7
+SIZE (tohojo-flent-v1.2.2_GH0.tar.gz) = 2877455
diff --git a/net/flent/pkg-descr b/net/flent/pkg-descr
new file mode 100644
index 000000000000..b0b86943b572
--- /dev/null
+++ b/net/flent/pkg-descr
@@ -0,0 +1,5 @@
+Flent is a Python wrapper to run multiple simultaneous netperf/iperf/ping
+instances and aggregate the results. It was previously known as
+'netperf-wrapper'.
+
+WWW: https://flent.org