aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-12-17 06:23:44 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-12-17 06:23:44 +0000
commitdbca1ba1e5692edcbb1510f685f585bd236dd62b (patch)
tree06a3349c395943146baca16fe529671fe7489b5e /net
parent22030da0b89da993892c4e4389be1157f760fef5 (diff)
downloadports-dbca1ba1e5692edcbb1510f685f585bd236dd62b.tar.gz
ports-dbca1ba1e5692edcbb1510f685f585bd236dd62b.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/wireshark/Makefile14
-rw-r--r--net/wireshark/distinfo4
-rw-r--r--net/wireshark/files/patch-configure35
3 files changed, 40 insertions, 13 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 3144e9b4dae7..bcc31507622f 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= wireshark
-PORTVERSION= 1.8.3
-PORTREVISION= 1
+PORTVERSION= 1.8.4
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
@@ -69,7 +68,8 @@ OPTIONS= RTP "Enable support for playing back RTP streams" off \
IPV6 "Enable IPv6 support" on \
GEOIP "Enable GeoIP lookups" on \
LUA "Enable LUA scripting integration" off \
- CARES "Asynchronous DNS resolution via c-ares" off
+ CARES "Asynchronous DNS resolution via c-ares" off \
+ GSSAPI "Enable Kerberos support" on
.endif
.include <bsd.port.pre.mk>
@@ -167,12 +167,16 @@ LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
.endif
+.if defined(WITHOUT_GSSAPI)
+CONFIGURE_ARGS+=--with-krb5=no
+.endif
+
MAN1+= dumpcap.1 tshark.1
MAN4+= wireshark-filter.4
post-patch:
- @${REINPLACE_CMD} -e 's|lua5\.1|lua${LUA_VER_STR}|g ; \
- s|-llua${LUA_VER_STR}|${LUA_LIBDIR}/liblua.a|g' \
+ @${REINPLACE_CMD} -e 's|%%LUA_INCDIR%%|${LUA_INCDIR}|g ; \
+ s|%%LUA_LIBDIR%%|${LUA_LIBDIR}|g' \
${WRKSRC}/configure
post-install:
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
index ab8a1e8311bf..05c12da65468 100644
--- a/net/wireshark/distinfo
+++ b/net/wireshark/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wireshark-1.8.3.tar.bz2) = 83a85ff506b5e2a70f03c49de7af291802404983a23c7779e0f4ac3e672a2fb3
-SIZE (wireshark-1.8.3.tar.bz2) = 24123989
+SHA256 (wireshark-1.8.4.tar.bz2) = cae9ec0cb9fa0b732a76c0f72f8c15d763f8cdc2e389cda2da6c48c24559faac
+SIZE (wireshark-1.8.4.tar.bz2) = 24164286
diff --git a/net/wireshark/files/patch-configure b/net/wireshark/files/patch-configure
index 38269b3e5cb9..685576b101db 100644
--- a/net/wireshark/files/patch-configure
+++ b/net/wireshark/files/patch-configure
@@ -1,20 +1,43 @@
---- configure.orig 2010-08-29 18:20:30.000000000 -0400
-+++ configure 2010-09-04 17:19:07.000000000 -0400
-@@ -22487,7 +22487,7 @@ $as_echo "yes" >&6; }
+--- configure.orig 2012-11-28 13:51:02.000000000 -0500
++++ configure 2012-12-17 01:11:49.000000000 -0500
+@@ -25305,9 +25305,9 @@ $as_echo "yes" >&6; }
+ # searches the specified directory.
+ #
+ wireshark_save_CPPFLAGS="$CPPFLAGS"
+- CPPFLAGS="$CPPFLAGS -I$lua_dir/include"
++ CPPFLAGS="$CPPFLAGS -I%%LUA_INCDIR%%"
+ wireshark_save_LIBS="$LIBS"
+- LIBS="$LIBS -L$lua_dir/lib -llua -lm"
++ LIBS="$LIBS -L%%LUA_LIBDIR%% -llua -lm"
+ wireshark_save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS -L$lua_dir/lib"
+ else
+@@ -25512,8 +25512,8 @@ if test "x$ac_cv_lib_lua_luaL_register"
+ # Put the "-I" and "-L" flags for lua into
+ # LUA_INCLUDES and LUA_LIBS, respectively.
+ #
+- LUA_LIBS="-L$lua_dir/lib -llua -lm"
+- LUA_INCLUDES="-I$lua_dir/include"
++ LUA_LIBS="-L%%LUA_LIBDIR%% -llua -lm"
++ LUA_INCLUDES="-I%%LUA_INCDIR%%"
+ else
+ LUA_LIBS="-llua -lm"
+ LUA_INCLUDES=""
+@@ -26487,7 +26487,7 @@ $as_echo "yes" >&6; }
+ # searches the specified directory.
#
- CFLAGS="$CFLAGS -I$krb5_dir/include"
CPPFLAGS="$CPPFLAGS -I$krb5_dir/include"
- ac_heimdal_version=`grep heimdal $krb5_dir/include/krb5.h | head -n 1 | sed 's/^.*heimdal.*$/HEIMDAL/'`
+ ac_heimdal_version=`grep heimdal $krb5_dir/include/krb5.h | head -n 1 | tr "[:lower:]" "[:upper:]" sed 's/^.*heimdal.*$/HEIMDAL/'`
# MIT Kerberos moved krb5.h to krb5/krb5.h starting with release 1.5
ac_mit_version_olddir=`grep 'Massachusetts Institute of Technology' $krb5_dir/include/krb5.h | head -n 1 | sed 's/^.*Massachusetts Institute of Technology.*$/MIT/'`
ac_mit_version_newdir=`grep 'Massachusetts Institute of Technology' $krb5_dir/include/krb5/krb5.h | head -n 1 | sed 's/^.*Massachusetts Institute of Technology.*$/MIT/'`
-@@ -22546,7 +22546,7 @@ fi
+@@ -26547,7 +26547,7 @@ fi
if test -x "$KRB5_CONFIG"
then
- KRB5_FLAGS=`"$KRB5_CONFIG" --cflags`
+ KRB5_FLAGS=`"$KRB5_CONFIG" --cflags | sed -e 's/@INCLUDE_des@//g'`
KRB5_LIBS=`"$KRB5_CONFIG" --libs`
- CFLAGS="$CFLAGS $KRB5_FLAGS"
CPPFLAGS="$CPPFLAGS $KRB5_FLAGS"
+ #