aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-30 21:49:21 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-30 21:49:21 +0000
commit8cb7d5a29a51f1def07f81e20b869a930fd13c08 (patch)
treef17f0dcbdc8e7fe6d9a23f1bd50551ce8ecf1010 /net
parentd06bee97730c87003b4aa02c775f777e0ae8009c (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/poptop/Makefile1
-rw-r--r--net/poptop/files/patch-pptpctrl.c10
2 files changed, 10 insertions, 1 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index e361a7d1097d..bff2e7e2c228 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -3,6 +3,7 @@
PORTNAME= poptop
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/pptpd/pptpd-${PORTVERSION} \
SAMBA/ppp:pppd
diff --git a/net/poptop/files/patch-pptpctrl.c b/net/poptop/files/patch-pptpctrl.c
index 3b05a55870ba..fed8e436f1c2 100644
--- a/net/poptop/files/patch-pptpctrl.c
+++ b/net/poptop/files/patch-pptpctrl.c
@@ -38,7 +38,7 @@
#elif SLIRP
-@@ -786,7 +796,7 @@
+@@ -786,14 +796,14 @@
if (pptp_logwtmp) {
pppd_argv[an++] = "plugin";
@@ -47,3 +47,11 @@
pppd_argv[an++] = "pptpd-original-ip";
pppd_argv[an++] = inet_ntoa(inetaddrs[1]);
}
+-#endif
+
+ pppd_argv[an++] = "remotenumber";
+ pppd_argv[an++] = inet_ntoa(inetaddrs[1]);
++#endif
+
+ /* argv arrays must always be NULL terminated */
+ pppd_argv[an++] = NULL;