aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2009-09-18 15:24:01 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2009-09-18 15:24:01 +0000
commit8f5f3b53509564392ef66b45109d6331774f57e5 (patch)
treed558f4ae4d1aa8497dd585d08d918922a49576f3 /net
parente772ec271ddeadbbf27edd5f960c254961ba64c5 (diff)
downloadports-8f5f3b53509564392ef66b45109d6331774f57e5.tar.gz
ports-8f5f3b53509564392ef66b45109d6331774f57e5.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/openntpd/Makefile5
-rw-r--r--net/openntpd/pkg-install35
2 files changed, 4 insertions, 36 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 87550f78fe39..5c6f2978eb90 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openntpd
PORTVERSION= 4.4
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_OPENBSD}
@@ -16,6 +17,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= naddy@FreeBSD.org
COMMENT= OpenBSD's Network Time Protocol daemon
+USERS= _ntp
+GROUPS= _ntp
+
USE_RC_SUBR= openntpd
WRKSRC= ${WRKDIR}/ntpd
@@ -41,7 +45,6 @@ pre-build:
${WRKSRC}/ntpd.h ${WRKSRC}/ntpd.conf.5 ${WRKSRC}/ntpd.8
do-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${INSTALL_PROGRAM} ${WRKSRC}/ntpd ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/ntpd.conf.5 ${PREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/ntpd.8 ${PREFIX}/man/man8
diff --git a/net/openntpd/pkg-install b/net/openntpd/pkg-install
deleted file mode 100644
index 62ded74d3b34..000000000000
--- a/net/openntpd/pkg-install
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-
-USER=_ntp
-GROUP=${USER}
-UID=123
-GID=${UID}
-
-if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -s "/sbin/nologin" -d "/var/empty" \
- -c "NTP daemon"; \
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
-fi
-
-exit 0