aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2011-02-24 21:50:08 +0000
committerXin LI <delphij@FreeBSD.org>2011-02-24 21:50:08 +0000
commitca858ffb67dbe767e6839a4eb980e9a2796e23eb (patch)
tree6eac7017b74a3b5405878e613bdf7f50a1da586f /net
parent908e96cabe84a43aa91ab7cf1e0fdcc7a50ef32e (diff)
downloadports-ca858ffb67dbe767e6839a4eb980e9a2796e23eb.tar.gz
ports-ca858ffb67dbe767e6839a4eb980e9a2796e23eb.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile20
-rw-r--r--net/openldap24-server/distinfo5
-rw-r--r--net/openldap24-server/files/manpages4
-rw-r--r--net/openldap24-server/files/patch-configure28
-rw-r--r--net/openldap24-server/pkg-plist29
-rw-r--r--net/openldap24-server/pkg-plist.client6
6 files changed, 49 insertions, 43 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index ef4b00ddcc09..4a26a1b950e0 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-DISTVERSION= 2.4.23
+DISTVERSION= 2.4.24
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -41,6 +41,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
PORTREVISION_CLIENT= 0
PORTREVISION_SERVER= 0
+OPENLDAP_SHLIB_MAJOR= 8
OPTIONS= SASL "With (Cyrus) SASL2 support" off \
FETCH "Enable fetch(3) support" on
@@ -48,6 +49,7 @@ OPTIONS= SASL "With (Cyrus) SASL2 support" off \
.if !defined(CLIENT_ONLY)
OPTIONS+= DYNACL "Run-time loadable ACL (experimental)" off \
ACI "Per-object ACI (experimental)" off \
+ BDB "With BerkeleyDB backend" on \
DNSSRV "With Dnssrv backend" off \
PASSWD "With Passwd backend" off \
PERL "With Perl backend" off \
@@ -59,7 +61,6 @@ OPTIONS+= DYNACL "Run-time loadable ACL (experimental)" off \
SLP "With SLPv2 (RFC 2608) support" off \
SLAPI "With Netscape SLAPI plugin API" off \
TCP_WRAPPERS "With tcp wrapper support" on \
- BDB "With BerkeleyDB support" on \
ACCESSLOG "With In-Directory Access Logging overlay" off \
AUDITLOG "With Audit Logging overlay" off \
COLLECT "With Collect overy Services overlay" off \
@@ -68,7 +69,6 @@ OPTIONS+= DYNACL "Run-time loadable ACL (experimental)" off \
DEREF "With Dereference overlay" off \
DYNGROUP "With Dynamic Group overlay" off \
DYNLIST "With Dynamic List overlay" off \
- LASTMOD "With Last Modification overlay" off \
MEMBEROF "With Reverse Group Membership overlay" off \
PPOLICY "With Password Policy overlay" off \
PROXYCACHE "With Proxy Cache overlay" off \
@@ -76,6 +76,7 @@ OPTIONS+= DYNACL "Run-time loadable ACL (experimental)" off \
RETCODE "With Return Code testing overlay" off \
RWM "With Rewrite/Remap overlay" off \
SEQMOD "Sequential Modify overlay" on \
+ SSSVLV "With ServerSideSort/VLV overlay" off \
SYNCPROV "With Syncrepl Provider overlay" on \
TRANSLUCENT "With Translucent Proxy overlay" off \
UNIQUE "With attribute Uniqueness overlay" off \
@@ -147,6 +148,7 @@ SUB_LIST+= LDAP_RUN_DIR=${LDAP_RUN_DIR} \
CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
+ --disable-dependency-tracking \
--enable-dynamic
.if defined(WITHOUT_FETCH)
@@ -167,7 +169,6 @@ CONFIGURE_ARGS+= --disable-slapd \
--disable-monitor \
--disable-bdb \
--disable-relay \
- --disable-glue \
--disable-syncprov
SUB_FILES+= pkg-message.client
PKGMESSAGE= ${WRKSRC}/pkg-message.client
@@ -246,10 +247,6 @@ CONFIGURE_ARGS+= --enable-dyngroup
CONFIGURE_ARGS+= --enable-dynlist
.endif
-.if defined(WITH_LASTMOD)
-CONFIGURE_ARGS+= --enable-lastmod
-.endif
-
.if defined(WITH_MEMBEROF)
CONFIGURE_ARGS+= --enable-memberof
.endif
@@ -280,6 +277,10 @@ CONFIGURE_ARGS+= --disable-seqmod
CONFIGURE_ARGS+= --enable-seqmod
.endif
+.if defined(WITH_SSSVLV)
+CONFIGURE_ARGS+= --enable-sssvlv
+.endif
+
.if defined(WITHOUT_SYNCPROV)
CONFIGURE_ARGS+= --disable-syncprov
.else
@@ -314,7 +315,7 @@ PLIST_SUB+= BACK_BDB="@comment " \
.else
WITH_BDB_VER?= 46
-INVALID_BDB_VER= 42 50
+INVALID_BDB_VER= 42
USE_BDB= yes
.if ${WITH_BDB_VER} >= 43
@@ -459,6 +460,7 @@ SUB_LIST+= RC_DIR=${PREFIX} \
.endif
PLIST_SUB+= ${SUB_LIST}
+PLIST_SUB+= SHLIB_MAJOR=${OPENLDAP_SHLIB_MAJOR}
post-patch:
@${REINPLACE_CMD} -e 's,%LOCALSTATEDIR%/run/,${LDAP_RUN_DIR}/,g' \
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 1c7a06ed56bc..db2fad110bcd 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,3 +1,2 @@
-MD5 (openldap-2.4.23.tgz) = 90150b8c0d0192e10b30157e68844ddf
-SHA256 (openldap-2.4.23.tgz) = 5a5ede91d5e8ab3c7f637620aa29a3b96eb34318a8b26c8eef2d2c789fc055e3
-SIZE (openldap-2.4.23.tgz) = 5182440
+SHA256 (openldap-2.4.24.tgz) = fdcecb64082a0d8e124f13b31fccf4765901e29decaf4224b28d4cff90a14614
+SIZE (openldap-2.4.24.tgz) = 5240643
diff --git a/net/openldap24-server/files/manpages b/net/openldap24-server/files/manpages
index c712b4efaa79..369f397c6ec5 100644
--- a/net/openldap24-server/files/manpages
+++ b/net/openldap24-server/files/manpages
@@ -26,6 +26,7 @@ MAN3+= lber-decode.3 \
ldap_compare.3 \
ldap_controls.3 \
ldap_delete.3 \
+ ldap_dup.3 \
ldap_get_option.3 \
ldap_error.3 \
ldap_extended_operation.3 \
@@ -113,6 +114,7 @@ MLINKS+= \
ldap_delete.3 ldap_delete_s.3 \
ldap_delete.3 ldap_delete_ext.3 \
ldap_delete.3 ldap_delete_ext_s.3 \
+ ldap_dup.3 ldap_destroy.3 \
ldap_error.3 ldap_perror.3 \
ldap_error.3 ld_errno.3 \
ldap_error.3 ldap_result2error.3 \
@@ -155,6 +157,8 @@ MLINKS+= \
ldap_modrdn.3 ldap_modrdn2_s.3 \
ldap_open.3 ldap_init.3 \
ldap_open.3 ldap_initialize.3 \
+ ldap_open.3 ldap_init_fd.3 \
+ ldap_open.3 ldap_set_urllist_proc.3 \
ldap_parse_result.3 ldap_parse_sasl_bind_result.3 \
ldap_parse_result.3 ldap_parse_extended_result.3 \
ldap_rename.3 ldap_rename_s.3 \
diff --git a/net/openldap24-server/files/patch-configure b/net/openldap24-server/files/patch-configure
index a2df6201ed60..af237d0b7694 100644
--- a/net/openldap24-server/files/patch-configure
+++ b/net/openldap24-server/files/patch-configure
@@ -1,25 +1,25 @@
---- configure.orig 2008-02-11 15:36:45.000000000 -0800
-+++ configure 2008-02-19 14:03:01.410279419 -0800
-@@ -31928,7 +31928,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
+--- configure.orig 2011-01-31 12:53:50.000000000 -0800
++++ configure 2011-02-19 04:12:30.885900446 -0800
+@@ -21598,7 +21598,7 @@
+ $as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-liodbc $LIBS"
+LIBS="-liodbc $LIBS $LTHREAD_LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -32004,7 +32004,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -21646,7 +21646,7 @@
+ $as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lodbc $LIBS"
+LIBS="-lodbc $LIBS $LTHREAD_LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -32263,7 +32263,7 @@
- cat >>conftest.$ac_ext <<_ACEOF
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -21903,7 +21903,7 @@
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-#include <unicode/utypes.h>
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index e67669660462..34bcce3b0659 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -3,6 +3,7 @@
etc/openldap/schema/README
etc/openldap/schema/core.ldif
etc/openldap/schema/cosine.ldif
+etc/openldap/schema/dyngroup.ldif
etc/openldap/schema/inetorgperson.ldif
etc/openldap/schema/nis.ldif
etc/openldap/schema/openldap.ldif
@@ -16,58 +17,58 @@ etc/openldap/DB_CONFIG.example
%%SLAPI%%lib/libslapi.la
%%SLAPI%%lib/libslapi.so
%%SLAPI%%lib/libslapi-2.4.so
-%%SLAPI%%lib/libslapi-2.4.so.7
+%%SLAPI%%lib/libslapi-2.4.so.%%SHLIB_MAJOR%%
%%MODULES%%@exec mkdir -p %D/libexec/openldap
%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so
-%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so.7
+%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so.%%SHLIB_MAJOR%%
%%BACK_BDB%%libexec/openldap/back_bdb.la
%%BACK_BDB%%libexec/openldap/back_bdb.so
%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so
-%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so.7
+%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so.%%SHLIB_MAJOR%%
%%BACK_HDB%%libexec/openldap/back_hdb.la
%%BACK_HDB%%libexec/openldap/back_hdb.so
%%BACKEND%%libexec/openldap/back_ldap-2.4.so
-%%BACKEND%%libexec/openldap/back_ldap-2.4.so.7
+%%BACKEND%%libexec/openldap/back_ldap-2.4.so.%%SHLIB_MAJOR%%
%%BACKEND%%libexec/openldap/back_ldap.la
%%BACKEND%%libexec/openldap/back_ldap.so
%%BACKEND%%libexec/openldap/back_meta-2.4.so
-%%BACKEND%%libexec/openldap/back_meta-2.4.so.7
+%%BACKEND%%libexec/openldap/back_meta-2.4.so.%%SHLIB_MAJOR%%
%%BACKEND%%libexec/openldap/back_meta.la
%%BACKEND%%libexec/openldap/back_meta.so
%%BACKEND%%libexec/openldap/back_monitor-2.4.so
-%%BACKEND%%libexec/openldap/back_monitor-2.4.so.7
+%%BACKEND%%libexec/openldap/back_monitor-2.4.so.%%SHLIB_MAJOR%%
%%BACKEND%%libexec/openldap/back_monitor.la
%%BACKEND%%libexec/openldap/back_monitor.so
%%BACKEND%%libexec/openldap/back_null-2.4.so
-%%BACKEND%%libexec/openldap/back_null-2.4.so.7
+%%BACKEND%%libexec/openldap/back_null-2.4.so.%%SHLIB_MAJOR%%
%%BACKEND%%libexec/openldap/back_null.la
%%BACKEND%%libexec/openldap/back_null.so
%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so
-%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so.7
+%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so.%%SHLIB_MAJOR%%
%%BACK_DNSSRV%%libexec/openldap/back_dnssrv.la
%%BACK_DNSSRV%%libexec/openldap/back_dnssrv.so
%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so
-%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so.7
+%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so.%%SHLIB_MAJOR%%
%%BACK_PASSWD%%libexec/openldap/back_passwd.la
%%BACK_PASSWD%%libexec/openldap/back_passwd.so
%%BACK_PERL%%libexec/openldap/back_perl-2.4.so
-%%BACK_PERL%%libexec/openldap/back_perl-2.4.so.7
+%%BACK_PERL%%libexec/openldap/back_perl-2.4.so.%%SHLIB_MAJOR%%
%%BACK_PERL%%libexec/openldap/back_perl.la
%%BACK_PERL%%libexec/openldap/back_perl.so
%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so
-%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so.7
+%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so.%%SHLIB_MAJOR%%
%%BACK_RELAY%%libexec/openldap/back_relay.la
%%BACK_RELAY%%libexec/openldap/back_relay.so
%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so
-%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so.7
+%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so.%%SHLIB_MAJOR%%
%%BACK_SHELL%%libexec/openldap/back_shell.la
%%BACK_SHELL%%libexec/openldap/back_shell.so
%%BACK_SOCK%%libexec/openldap/back_sock-2.4.so
-%%BACK_SOCK%%libexec/openldap/back_sock-2.4.so.7
+%%BACK_SOCK%%libexec/openldap/back_sock-2.4.so.%%SHLIB_MAJOR%%
%%BACK_SOCK%%libexec/openldap/back_sock.la
%%BACK_SOCK%%libexec/openldap/back_sock.so
%%BACK_SQL%%libexec/openldap/back_sql-2.4.so
-%%BACK_SQL%%libexec/openldap/back_sql-2.4.so.7
+%%BACK_SQL%%libexec/openldap/back_sql-2.4.so.%%SHLIB_MAJOR%%
%%BACK_SQL%%libexec/openldap/back_sql.la
%%BACK_SQL%%libexec/openldap/back_sql.so
%%SMBPWD%%libexec/openldap/smbk5pwd.la
diff --git a/net/openldap24-server/pkg-plist.client b/net/openldap24-server/pkg-plist.client
index b20d5e212747..e517733663a3 100644
--- a/net/openldap24-server/pkg-plist.client
+++ b/net/openldap24-server/pkg-plist.client
@@ -22,17 +22,17 @@ include/ldap_schema.h
include/ldap_utf8.h
include/slapi-plugin.h
lib/liblber-2.4.so
-lib/liblber-2.4.so.7
+lib/liblber-2.4.so.%%SHLIB_MAJOR%%
lib/liblber.a
lib/liblber.la
lib/liblber.so
lib/libldap-2.4.so
-lib/libldap-2.4.so.7
+lib/libldap-2.4.so.%%SHLIB_MAJOR%%
lib/libldap.a
lib/libldap.la
lib/libldap.so
lib/libldap_r-2.4.so
-lib/libldap_r-2.4.so.7
+lib/libldap_r-2.4.so.%%SHLIB_MAJOR%%
lib/libldap_r.a
lib/libldap_r.la
lib/libldap_r.so