aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-03-28 21:58:17 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-03-28 21:58:17 +0000
commit50d0809adf9cac5b344bd1292ff5cd9d786676ea (patch)
treebb106ad3b483b74b8a560f60e011b96a14693a26 /net
parent0f2a6d26053654a7d8c29a0b63de908b09169729 (diff)
downloadports-50d0809adf9cac5b344bd1292ff5cd9d786676ea.tar.gz
ports-50d0809adf9cac5b344bd1292ff5cd9d786676ea.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/py-impacket/Makefile17
-rw-r--r--net/py-impacket/distinfo4
-rw-r--r--net/py-impacket/files/patch-setup.py15
-rw-r--r--net/py-impacket/pkg-descr23
4 files changed, 26 insertions, 33 deletions
diff --git a/net/py-impacket/Makefile b/net/py-impacket/Makefile
index e4dcadae27fd..c8d927cd106b 100644
--- a/net/py-impacket/Makefile
+++ b/net/py-impacket/Makefile
@@ -2,18 +2,16 @@
# $FreeBSD$
PORTNAME= impacket
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.11
CATEGORIES= net python
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Collection of Python classes providing access to network packets
-LICENSE= AL11
-LICENSE_NAME= Apache License version 1.1
+LICENSE= APACHE11
LICENSE_FILE= ${WRKSRC}/LICENSE
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pcapy>=0:${PORTSDIR}/net/py-pcapy \
${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto
@@ -23,16 +21,13 @@ USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_AUTOPLIST=yes
-PORTDOCS= README
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/impacket && ${COPYTREE_SHARE} testcases ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/py-impacket/distinfo b/net/py-impacket/distinfo
index eb0d52ba1d95..e4112c746a34 100644
--- a/net/py-impacket/distinfo
+++ b/net/py-impacket/distinfo
@@ -1,2 +1,2 @@
-SHA256 (impacket-0.9.10.tar.gz) = 6d9e2b91f825c3bdfb9b5f42419900fcc7739257cbb5eac48ee8d8f68166092b
-SIZE (impacket-0.9.10.tar.gz) = 435448
+SHA256 (impacket-0.9.11.tar.gz) = e0b4e5174b869efa35c3068ee55ac3c2364706b59ffc43cd9e3c2f75f5accf2d
+SIZE (impacket-0.9.11.tar.gz) = 779016
diff --git a/net/py-impacket/files/patch-setup.py b/net/py-impacket/files/patch-setup.py
index fb726c560d25..818a15aaf39c 100644
--- a/net/py-impacket/files/patch-setup.py
+++ b/net/py-impacket/files/patch-setup.py
@@ -1,10 +1,11 @@
---- ./setup.py.orig 2013-05-08 13:57:03.000000000 +0000
-+++ ./setup.py 2013-05-08 13:57:03.000000000 +0000
-@@ -21,7 +21,5 @@
+--- ./setup.py.orig 2014-01-30 16:07:52.000000000 +0000
++++ ./setup.py 2014-03-26 22:12:00.000000000 +0000
+@@ -21,8 +21,4 @@
platforms = ["Unix","Windows"],
- packages = ['impacket', 'impacket.dcerpc', 'impacket.examples'],
+ packages = ['impacket', 'impacket.dcerpc', 'impacket.examples', 'impacket.dcerpc.v5'],
scripts = glob.glob(os.path.join('examples', '*.py')),
-- data_files = [(os.path.join('share', 'doc', PACKAGE_NAME),
-- ['README', 'LICENSE']+glob.glob('doc/*'))],
-
+- data_files = [(os.path.join('share', 'doc', PACKAGE_NAME), ['README', 'LICENSE']+glob.glob('doc/*')),
+- (os.path.join('share', 'doc', PACKAGE_NAME, 'testcases', 'dot11'),glob.glob('impacket/testcases/dot11/*')),
+- (os.path.join('share', 'doc', PACKAGE_NAME, 'testcases', 'ImpactPacket'),glob.glob('impacket/testcases/ImpactPacket/*')),
+- (os.path.join('share', 'doc', PACKAGE_NAME, 'testcases', 'SMB-RPC'),glob.glob('impacket/testcases/SMB-RPC/*'))],
)
diff --git a/net/py-impacket/pkg-descr b/net/py-impacket/pkg-descr
index 63a015f384df..89e77b8949db 100644
--- a/net/py-impacket/pkg-descr
+++ b/net/py-impacket/pkg-descr
@@ -1,14 +1,11 @@
-Impacket is a collection of Python classes focused
-on providing access to network packets.
-Impacket allows Python developers to craft and decode
-network packets in simple and consistent manner.
-It includes support for low-level protocols such as
-IP, UDP and TCP, as well as higher-level protocols
-such as NMB and SMB. Impacket is highly effective
-when used in conjunction with a packet capture utility
-or package such as Pcapy. Packets can be constructed
-from scratch, as well as parsed from raw data. Furthermore,
-the object oriented API makes it simple to work with deep
-protocol hierarchies.
+Impacket is a collection of Python classes focused on providing access
+to network packets. Impacket allows Python developers to craft and
+decode network packets in simple and consistent manner. It includes
+support for low-level protocols such as IP, UDP and TCP, as well as
+higher-level protocols such as NMB and SMB. Impacket is highly effective
+when used in conjunction with a packet capture utility or package such
+as Pcapy. Packets can be constructed from scratch, as well as parsed
+from raw data. Furthermore, the object oriented API makes it simple to
+work with deep protocol hierarchies.
-WWW: http://oss.coresecurity.com/projects/impacket.html
+WWW: http://corelabs.coresecurity.com/index.php?module=Wiki&action=view&type=tool&name=Impacket