aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
commit5271da855f0c5946ff1f3aa58fbe806871df2f87 (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /net
parent8730c99d5ea1ba861dbab3e0dbc07e16826b1a7a (diff)
downloadports-5271da855f0c5946ff1f3aa58fbe806871df2f87.tar.gz
ports-5271da855f0c5946ff1f3aa58fbe806871df2f87.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/minidlna/Makefile2
-rw-r--r--net/qt4-network/Makefile1
-rw-r--r--net/sendsms/Makefile8
-rw-r--r--net/serviio/Makefile2
-rw-r--r--net/smm++/Makefile8
-rw-r--r--net/udt/Makefile2
6 files changed, 8 insertions, 15 deletions
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index eeb0dd605a5c..dad4620af816 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
MAKE_JOBS_SAFE= yes
MAKEFILE= ${FILESDIR}/BSDmakefile
MAKE_ENV+= FILESDIR="${FILESDIR}" INSTALL_DATA="${INSTALL_DATA}"
-EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude getifaddr.c
+EXTRACT_AFTER_ARGS=--exclude getifaddr.c
PKGMESSAGE= ${WRKSRC}/pkg-message
SUB_FILES+= pkg-message
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index dbaad07a4ad3..a24ab3092c70 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -33,7 +33,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/3rdparty/clucene src/3rdparty/freetype \
src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/net/sendsms/Makefile b/net/sendsms/Makefile
index 1eabf4a7319a..7dd5d7ca164b 100644
--- a/net/sendsms/Makefile
+++ b/net/sendsms/Makefile
@@ -1,8 +1,4 @@
-# New ports collection makefile for: www/sendsms
-# Date created: 2005-12-17
-# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
-#
-# $Tecnik: ports/www/sendsms/Makefile,v 1.3 2006/05/12 12:15:34 itetcu Exp $
+# Created by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
# $FreeBSD$
PORTNAME= sendsms
@@ -16,6 +12,8 @@ EXTRACT_SUFX= .gz
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Simple perl command-line utility to send SMS via from on provider site
+EXTRACT_CMD= ${GZCAT}
+EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= > ${WRKSRC}/${PORTNAME}
PLIST_FILES= bin/sendsms
diff --git a/net/serviio/Makefile b/net/serviio/Makefile
index 47c5f51713cb..de0f7716eb95 100644
--- a/net/serviio/Makefile
+++ b/net/serviio/Makefile
@@ -21,7 +21,7 @@ SUB_FILES+= pkg-message serviiod serviio-console
USE_RC_SUBR= serviio
SUB_LIST+= USER=${USERS}
RESTRICTED= License does not allow selling
-EXTRACT_AFTER_ARGS=|${TAR} -xf - --exclude junit.jar \
+EXTRACT_AFTER_ARGS=--exclude junit.jar \
--exclude org.restlet.ext.net.jar
USERS= dlna
diff --git a/net/smm++/Makefile b/net/smm++/Makefile
index 4a573cdbbd2a..bf6f05069fbe 100644
--- a/net/smm++/Makefile
+++ b/net/smm++/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tcltutor
-# Date created: 16 November 2000
-# Whom: Edwin Groothuis (edwin@mavetju.org)
-#
+# Created by: Edwin Groothuis (edwin@mavetju.org)
# $FreeBSD$
-#
PORTNAME= smm++
PORTVERSION= 6.1.1
@@ -23,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libitk.so:${PORTSDIR}/x11-toolkits/itk \
WRKSRC= ${WRKDIR}/smm/Install.unix
USE_GMAKE= yes
USE_TK= 84+
-EXTRACT_AFTER_ARGS+=|${TAR} -xpf - --exclude CVS
+EXTRACT_AFTER_ARGS=--exclude CVS
post-patch:
${REINPLACE_CMD} -e 's,itkarray=.*,itkarray=${WISH},' ${WRKSRC}/itk.sh
diff --git a/net/udt/Makefile b/net/udt/Makefile
index 15deadab711d..18336b713d3e 100644
--- a/net/udt/Makefile
+++ b/net/udt/Makefile
@@ -14,7 +14,7 @@ PATCH_WRKSRC= ${WRKDIR}/udt${PORTVERSION:R}
WRKSRC= ${PATCH_WRKSRC}/src
MAKEFILE= ${FILESDIR}/BSDmakefile
MAKE_JOBS_SAFE= yes
-EXTRACT_AFTER_ARGS= |${TAR} -xpf - --exclude '*md5*' \
+EXTRACT_AFTER_ARGS= --exclude '*md5*' \
--exclude udt${PORTVERSION:R}/win
USE_LDCONFIG= yes
UDT_APPS= appclient appserver recvfile sendfile test