aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-19 11:15:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-19 11:15:59 +0000
commita737a379dc169c0dad5faa4afcc88417a8dc347b (patch)
tree348d5657db28b1e92107b6e62b2f3e268ec199be /net
parent53cb351521c84cb3ad785bec170514836d9b2908 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Event-tcp/Makefile25
-rw-r--r--net/p5-Event-tcp/distinfo3
-rw-r--r--net/p5-Event-tcp/pkg-descr4
-rw-r--r--net/p5-Event-tcp/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d5da888ba4eb..24a22146dd59 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -465,6 +465,7 @@
SUBDIR += p5-Cisco-IPPhone
SUBDIR += p5-Daemon-Generic
SUBDIR += p5-EasyTCP
+ SUBDIR += p5-Event-tcp
SUBDIR += p5-File-Rsync
SUBDIR += p5-File-RsyncP
SUBDIR += p5-Filesys-SmbClient
diff --git a/net/p5-Event-tcp/Makefile b/net/p5-Event-tcp/Makefile
new file mode 100644
index 000000000000..e2b159240346
--- /dev/null
+++ b/net/p5-Event-tcp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Event-tcp
+# Date created: 2009-11-15
+# Whom: steinex
+#
+# $FreeBSD$
+#
+
+PORTNAME= Event-tcp
+PORTVERSION= 0.14
+CATEGORIES= net devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steinex@nognu.de
+COMMENT= Glue code to build client-server style TCP-based services
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
+ ${SITE_PERL}/${PERL_ARCH}/Ioctl.pm:${PORTSDIR}/devel/p5-Ioctl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Event::tcpsession.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Event-tcp/distinfo b/net/p5-Event-tcp/distinfo
new file mode 100644
index 000000000000..8e74a261e20b
--- /dev/null
+++ b/net/p5-Event-tcp/distinfo
@@ -0,0 +1,3 @@
+MD5 (Event-tcp-0.14.tar.gz) = a46a86e2f5448672a091f4ad706e5b73
+SHA256 (Event-tcp-0.14.tar.gz) = 32b9813972928f8517c24979a476bf75d79e93d004c0d84c825569e498cd9ffd
+SIZE (Event-tcp-0.14.tar.gz) = 7083
diff --git a/net/p5-Event-tcp/pkg-descr b/net/p5-Event-tcp/pkg-descr
new file mode 100644
index 000000000000..0be774a7db5f
--- /dev/null
+++ b/net/p5-Event-tcp/pkg-descr
@@ -0,0 +1,4 @@
+Event::tcp is a bunch of glue code to make it very easy to build
+client-server style TCP-based services.
+
+WWW: http://search.cpan.org/dist/Event-tcp/
diff --git a/net/p5-Event-tcp/pkg-plist b/net/p5-Event-tcp/pkg-plist
new file mode 100644
index 000000000000..50d401cc4b7d
--- /dev/null
+++ b/net/p5-Event-tcp/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Event/tcplisten.pm
+%%SITE_PERL%%/Event/tcpsession.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/tcp/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/tcp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event
+@dirrmtry %%SITE_PERL%%/Event