aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-03-27 00:30:34 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-03-27 00:30:34 +0000
commitb306894ebcb0ef1d315413015df5eaaa6e334efd (patch)
tree508d382623ff195e92c2e8db8be6c79a225968e1 /net
parent69ffa6b7d98af9fe10d386a5bfd5ae3d9a0bd500 (diff)
downloadports-b306894ebcb0ef1d315413015df5eaaa6e334efd.tar.gz
ports-b306894ebcb0ef1d315413015df5eaaa6e334efd.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/mpd5/Makefile6
-rw-r--r--net/mpd5/files/patch-conf__Makefile12
-rw-r--r--net/mpd5/files/patch-doc__Makefile26
-rw-r--r--net/mpd5/files/patch-src__Makefile11
4 files changed, 51 insertions, 4 deletions
diff --git a/net/mpd5/Makefile b/net/mpd5/Makefile
index 5301dce3dade..63466742d28f 100644
--- a/net/mpd5/Makefile
+++ b/net/mpd5/Makefile
@@ -5,8 +5,8 @@ PORTNAME= mpd
DISTVERSION= 5.7
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/Mpd5/Mpd-${PORTVERSION}
-DIST_SUBDIR= mpd5
PKGNAMESUFFIX= 5
+DIST_SUBDIR= mpd5
MAINTAINER= mav@FreeBSD.org
COMMENT= Multi-link PPP daemon based on netgraph(4)
@@ -19,7 +19,6 @@ CONFIGURE_WRKSRC= "${WRKSRC}/src"
USE_OPENSSL= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNG_IPACCT}
@@ -31,7 +30,6 @@ RUN_DEPENDS+= /boot/modules/ng_ipacct.ko:${PORTSDIR}/net-mgmt/ng_ipacct
.endif
.endif
-MAN8= mpd5.8
MANCOMPRESSED= maybe
USE_RC_SUBR= mpd5
HTMLNUM!= jot 70 1
@@ -40,6 +38,6 @@ DOCSDIR= ${PREFIX}/share/doc/mpd5
PORTDOCS= ${HTMLNUM:S/^/mpd/:S/$/.html/} mpd.html mpd.ps README \
mpd_toc.html
PLIST_DIRS= etc/mpd5
-PLIST_FILES= ${CONFSUF:S/^/etc\/mpd5\/mpd./:S/$/.sample/} sbin/mpd5
+PLIST_FILES= ${CONFSUF:S/^/etc\/mpd5\/mpd./:S/$/.sample/} sbin/mpd5 man/man8/mpd5.8.gz
.include <bsd.port.mk>
diff --git a/net/mpd5/files/patch-conf__Makefile b/net/mpd5/files/patch-conf__Makefile
new file mode 100644
index 000000000000..788555f228b8
--- /dev/null
+++ b/net/mpd5/files/patch-conf__Makefile
@@ -0,0 +1,12 @@
+--- conf/Makefile.orig 2014-03-26 03:33:58.000000000 -0300
++++ conf/Makefile 2014-03-26 03:34:12.000000000 -0300
+@@ -3,6 +3,9 @@
+ PREFIX?= /usr/local
+ BINDIR?= /etc/mpd5
+
++BINOWN!= /usr/bin/id -n -u
++BINGRP!= /usr/bin/id -n -g
++
+ MPD_SAMPLES+= mpd.conf.sample
+ MPD_SAMPLES+= mpd.secret.sample
+ MPD_SAMPLES+= mpd.script.sample
diff --git a/net/mpd5/files/patch-doc__Makefile b/net/mpd5/files/patch-doc__Makefile
new file mode 100644
index 000000000000..31b31e0ab5b5
--- /dev/null
+++ b/net/mpd5/files/patch-doc__Makefile
@@ -0,0 +1,26 @@
+--- doc/Makefile.orig 2013-06-11 06:00:00.000000000 -0300
++++ doc/Makefile 2014-03-26 03:39:06.000000000 -0300
+@@ -3,6 +3,11 @@
+ PREFIX?= /usr/local
+ DOCDIR?= ${PREFIX}/share/doc/mpd5
+
++DOCOWN!= /usr/bin/id -n -u
++DOCGRP!= /usr/bin/id -n -g
++MANOWN= ${DOCOWN}
++MANGRP= ${DOCGRP}
++
+ MPD_DOC_FILES+= ../README
+ MPD_DOC_FILES+= mpd*.html
+ MPD_DOC_FILES+= mpd.ps
+@@ -22,9 +27,9 @@
+
+ .if !defined(NOPORTDOCS)
+ afterinstall:
+- [ -d ${DOCDIR} ] || mkdir ${DOCDIR}
++ [ -d ${DESTDIR}${DOCDIR} ] || mkdir ${DESTDIR}${DOCDIR}
+ ${INSTALL} -c -o ${DOCOWN} -g ${DOCGRP} -m ${DOCMODE} \
+- ${MPD_DOC_FILES} ${DOCDIR}
++ ${MPD_DOC_FILES} ${DESTDIR}${DOCDIR}
+ .endif
+
+ .include <bsd.prog.mk>
diff --git a/net/mpd5/files/patch-src__Makefile b/net/mpd5/files/patch-src__Makefile
new file mode 100644
index 000000000000..b97c651db403
--- /dev/null
+++ b/net/mpd5/files/patch-src__Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig 2014-03-26 03:33:24.000000000 -0300
++++ src/Makefile 2014-03-26 03:33:44.000000000 -0300
+@@ -14,6 +14,8 @@
+ NOMAN=
+ NO_MAN=
+
++BINOWN!= /usr/bin/id -n -u
++BINGRP!= /usr/bin/id -n -g
+
+ # Default configuration directory
+