aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 15:42:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 15:56:22 +0000
commitde4eb9dfb3c444156092c7a73782655770ded65c (patch)
tree062209d76bb5401f5f13495cbeef97f89bd46cb5 /net
parent90e1945faa0712e03ccd422288da4537d9192b38 (diff)
net/rubygem-activestorage61: Update to 6.1.4.1
Diffstat (limited to 'net')
-rw-r--r--net/rubygem-activestorage61/Makefile2
-rw-r--r--net/rubygem-activestorage61/distinfo6
-rw-r--r--net/rubygem-activestorage61/files/patch-activestorage.gemspec13
-rw-r--r--net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb13
-rw-r--r--net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb13
5 files changed, 4 insertions, 43 deletions
diff --git a/net/rubygem-activestorage61/Makefile b/net/rubygem-activestorage61/Makefile
index dc6060c418fd..f9ad93c313f8 100644
--- a/net/rubygem-activestorage61/Makefile
+++ b/net/rubygem-activestorage61/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= activestorage
-PORTVERSION= 6.1.3.2
+PORTVERSION= 6.1.4.1
CATEGORIES= net rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= 61
diff --git a/net/rubygem-activestorage61/distinfo b/net/rubygem-activestorage61/distinfo
index 20f468b77cc9..ebe6e36b338e 100644
--- a/net/rubygem-activestorage61/distinfo
+++ b/net/rubygem-activestorage61/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620298756
-SHA256 (rubygem/activestorage-6.1.3.2.gem) = 0f4319e41fb01cc6c12f0bf7cd97a8dc79771fc1f6d308da3a246294c79c7769
-SIZE (rubygem/activestorage-6.1.3.2.gem) = 54784
+TIMESTAMP = 1632664516
+SHA256 (rubygem/activestorage-6.1.4.1.gem) = 716fdda141aa3a9c027f59d0effb08cbf5291fad1df82d50e9e4e1edd2ff769e
+SIZE (rubygem/activestorage-6.1.4.1.gem) = 55296
diff --git a/net/rubygem-activestorage61/files/patch-activestorage.gemspec b/net/rubygem-activestorage61/files/patch-activestorage.gemspec
deleted file mode 100644
index 8eba09555892..000000000000
--- a/net/rubygem-activestorage61/files/patch-activestorage.gemspec
+++ /dev/null
@@ -1,13 +0,0 @@
-Obtained from: https://github.com/rails/rails/commit/b80a2bdeb955c81649e483f2f020a3d5f407c2f9
-
---- activestorage.gemspec.orig 2021-05-06 14:05:12 UTC
-+++ activestorage.gemspec
-@@ -28,7 +28,7 @@ Gem::Specification.new do |s|
- s.add_runtime_dependency(%q<activejob>.freeze, ["= 6.1.3.2"])
- s.add_runtime_dependency(%q<activerecord>.freeze, ["= 6.1.3.2"])
- s.add_runtime_dependency(%q<marcel>.freeze, ["~> 1.0.0"])
-- s.add_runtime_dependency(%q<mini_mime>.freeze, ["~> 1.0.2"])
-+ s.add_runtime_dependency(%q<mini_mime>.freeze, [">= 1.1.0"])
- else
- s.add_dependency(%q<activesupport>.freeze, ["= 6.1.3.2"])
- s.add_dependency(%q<actionpack>.freeze, ["= 6.1.3.2"])
diff --git a/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb b/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb
deleted file mode 100644
index 5e5ac0de6d53..000000000000
--- a/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb
+++ /dev/null
@@ -1,13 +0,0 @@
-Obtained from: https://github.com/rails/rails/commit/b80a2bdeb955c81649e483f2f020a3d5f407c2f9
-
---- app/models/active_storage/variant.rb.orig 2021-04-24 11:45:24 UTC
-+++ app/models/active_storage/variant.rb
-@@ -89,7 +89,7 @@ class ActiveStorage::Variant
- end
-
- def filename
-- ActiveStorage::Filename.new "#{blob.filename.base}.#{variation.format}"
-+ ActiveStorage::Filename.new "#{blob.filename.base}.#{variation.format.downcase}"
- end
-
- alias_method :content_type_for_serving, :content_type
diff --git a/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb b/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb
deleted file mode 100644
index bc1dc981240d..000000000000
--- a/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb
+++ /dev/null
@@ -1,13 +0,0 @@
-Obtained from: https://github.com/rails/rails/commit/b80a2bdeb955c81649e483f2f020a3d5f407c2f9
-
---- app/models/active_storage/variant_with_record.rb.orig 2021-04-24 11:45:24 UTC
-+++ app/models/active_storage/variant_with_record.rb
-@@ -33,7 +33,7 @@ class ActiveStorage::VariantWithRecord
- def transform_blob
- blob.open do |input|
- variation.transform(input) do |output|
-- yield io: output, filename: "#{blob.filename.base}.#{variation.format}",
-+ yield io: output, filename: "#{blob.filename.base}.#{variation.format.downcase}",
- content_type: variation.content_type, service_name: blob.service.name
- end
- end