aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-02-19 11:10:43 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-02-19 11:10:43 +0000
commitf7455240e3b2acb3cd4804dac9a3afe2582a0a96 (patch)
tree94eaef37ab07d82e499ae4cafabe202ea2ed0525 /net
parent6db4531ff6ac4b156bdc1499488964f1c2551e7f (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/googlecl/Makefile3
-rw-r--r--net/netatalk3/Makefile4
-rw-r--r--net/neubot/Makefile3
-rw-r--r--net/nsscache/Makefile3
-rw-r--r--net/py-avahi/Makefile4
-rw-r--r--net/py-gntp/Makefile4
-rw-r--r--net/py-gspread/Makefile3
-rw-r--r--net/py-gspreadsheet/Makefile3
-rw-r--r--net/py-python-ntlm/Makefile3
-rw-r--r--net/py-raet/Makefile3
-rw-r--r--net/py-s3cmd/Makefile3
-rw-r--r--net/py-soappy/Makefile3
-rw-r--r--net/py-suds/Makefile4
-rw-r--r--net/py-wolframalpha/Makefile3
-rw-r--r--net/py-zsi/Makefile4
-rw-r--r--net/samba44/Makefile4
-rw-r--r--net/samba45/Makefile4
-rw-r--r--net/spideroak/Makefile4
-rw-r--r--net/xorp/Makefile2
19 files changed, 37 insertions, 27 deletions
diff --git a/net/googlecl/Makefile b/net/googlecl/Makefile
index e3a396be242c..6de572d5fedc 100644
--- a/net/googlecl/Makefile
+++ b/net/googlecl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= googlecl
PORTVERSION= 0.9.15.1
+PORTREVISION= 1
CATEGORIES= net www python
MAINTAINER= sbz@FreeBSD.org
@@ -15,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdata>0:devel/py-gdata@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oauth2client>0:security/py-oauth2client@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}httplib2>0:www/py-httplib2@${FLAVOR}
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= vinitkumar
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index ecd1553b9649..f01c1b00908b 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netatalk
PORTVERSION= 3.1.11
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF
@@ -62,7 +62,7 @@ LDAP_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_OFF= --without-ldap
SENDFILE_CONFIGURE_ENABLE=sendfile
-DBUS_USES= python:2
+DBUS_USES= python:2.7
DBUS_USE= GNOME=glib20
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libdbus-1.so:devel/dbus
diff --git a/net/neubot/Makefile b/net/neubot/Makefile
index 62628bf9790b..415b3cafe21b 100644
--- a/net/neubot/Makefile
+++ b/net/neubot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= neubot
PORTVERSION= 0.4.16.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://releases.neubot.org/_packages/
@@ -13,7 +14,7 @@ LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-USES= python:2
+USES= python:2.7
NO_BUILD= yes
USERS= _neubot
diff --git a/net/nsscache/Makefile b/net/nsscache/Makefile
index f57ec43fbce2..635c73d4a4d0 100644
--- a/net/nsscache/Makefile
+++ b/net/nsscache/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nsscache
PORTVERSION= 0.32
+PORTREVISION= 1
DISTVERSIONPREFIX= version/
CATEGORIES= net python
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pycurl.so:ftp/py-pycurl@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ldap>0:net/py-ldap@${FLAVOR}
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= google
diff --git a/net/py-avahi/Makefile b/net/py-avahi/Makefile
index 18d9d62e9cf3..d98232b30752 100644
--- a/net/py-avahi/Makefile
+++ b/net/py-avahi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
# $MCom: ports/net/py-avahi/Makefile,v 1.4 2007/07/31 18:24:13 ahze Exp $
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net gnome python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= # empty
@@ -25,7 +25,7 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= python
USE_GNOME= pygtk2
-USES= python:2
+USES= python:2.7
USE_PYTHON= flavors
MANPAGES= avahi-bookmarks.1 avahi-discover.1
diff --git a/net/py-gntp/Makefile b/net/py-gntp/Makefile
index eb553e4059f2..4995c0c94e39 100644
--- a/net/py-gntp/Makefile
+++ b/net/py-gntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gntp
PORTVERSION= 0.8
DISTVERSIONPREFIX= v
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +17,7 @@ GH_ACCOUNT= kfdm
OPTIONS_DEFINE= DOCS
USE_GITHUB= yes
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
diff --git a/net/py-gspread/Makefile b/net/py-gspread/Makefile
index 1dd8a114c204..ab0781f6f88b 100644
--- a/net/py-gspread/Makefile
+++ b/net/py-gspread/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gspread
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +15,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>2.2.1:www/py-requests@${FLAVOR}
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/net/py-gspreadsheet/Makefile b/net/py-gspreadsheet/Makefile
index b1f55a61bd0c..90e4ff4c5b5d 100644
--- a/net/py-gspreadsheet/Makefile
+++ b/net/py-gspreadsheet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gspreadsheet
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdata>0:devel/py-gdata@${FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${FLAVOR}
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
PORTDOCS= README.rst
diff --git a/net/py-python-ntlm/Makefile b/net/py-python-ntlm/Makefile
index b19f51a5b7c4..abf577468e49 100644
--- a/net/py-python-ntlm/Makefile
+++ b/net/py-python-ntlm/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python-ntlm
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,7 +11,7 @@ MAINTAINER= dbaio@FreeBSD.org
COMMENT= Python library that provides NTLM support
NO_ARCH= yes
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/net/py-raet/Makefile b/net/py-raet/Makefile
index a239ea7af10a..dd399f9548c4 100644
--- a/net/py-raet/Makefile
+++ b/net/py-raet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= raet
PORTVERSION= 0.6.5
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Reliable Asynchronous Event Transport protocol library
LICENSE= APACHE20
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/net/py-s3cmd/Makefile b/net/py-s3cmd/Makefile
index 3bd95ad5f031..dadc8869ac21 100644
--- a/net/py-s3cmd/Makefile
+++ b/net/py-s3cmd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= s3cmd
DISTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= SF/s3tools/${PORTNAME}/${DISTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${FLAVOR}
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/net/py-soappy/Makefile b/net/py-soappy/Makefile
index c9bb3b285c5f..77f0019432ec 100644
--- a/net/py-soappy/Makefile
+++ b/net/py-soappy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= soappy
PORTVERSION= 0.12.22
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>0:devel/py-defusedxml@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wstools>0:textproc/py-wstools@${FLAVOR}
-USES= python:2 zip
+USES= python:2.7 zip
USE_PYTHON= autoplist distutils
CONFLICTS= py*-soappy-devel-0.12.*
diff --git a/net/py-suds/Makefile b/net/py-suds/Makefile
index b67f3b3f012b..850d3f0e3fd6 100644
--- a/net/py-suds/Makefile
+++ b/net/py-suds/Makefile
@@ -3,7 +3,7 @@
PORTNAME= suds
PORTVERSION= 0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +15,7 @@ LICENSE= LGPL3
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}suds-jurko-*
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/net/py-wolframalpha/Makefile b/net/py-wolframalpha/Makefile
index 0f57db921b22..0cb65a4ea3f8 100644
--- a/net/py-wolframalpha/Makefile
+++ b/net/py-wolframalpha/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wolframalpha
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +15,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:devel/py-hgtools@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${FLAVOR}
-USES= python:2 zip
+USES= python:2.7 zip
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/net/py-zsi/Makefile b/net/py-zsi/Makefile
index 62fa0a1c8ea7..b7452a539bdc 100644
--- a/net/py-zsi/Makefile
+++ b/net/py-zsi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zsi
DISTVERSION= 2.1-a1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net python
MASTER_SITES= SF/pywebsvcs/ZSI/ZSI-${DISTVERSION:S,-,_,}
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Pure Python implementation of SOAP 1.1
-USES= python:2 shebangfix
+USES= python:2.7 shebangfix
USE_PYTHON= autoplist distutils
NO_ARCH= yes
SHEBANG_FILES= doc/examples/*/*/*/*/*.py \
diff --git a/net/samba44/Makefile b/net/samba44/Makefile
index 70438c60e8d6..3b8fc8617dd1 100644
--- a/net/samba44/Makefile
+++ b/net/samba44/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}44
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
@@ -61,7 +61,7 @@ CONFIGURE_ARGS+= --mandir="${MANPREFIX}/man" \
# Flags
CONFIGURE_ENV+= PTHREAD_LDFLAGS="-lpthread"
-USES= cpe compiler waf pkgconfig perl5 python:2 \
+USES= cpe compiler waf pkgconfig perl5 python:2.7 \
readline iconv shebangfix
USE_PERL5= build
USE_LDCONFIG= ${SAMBA4_LIBDIR}
diff --git a/net/samba45/Makefile b/net/samba45/Makefile
index 5dbd244ed5be..7473bac31820 100644
--- a/net/samba45/Makefile
+++ b/net/samba45/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}45
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
@@ -61,7 +61,7 @@ CONFIGURE_ARGS+= --mandir="${MANPREFIX}/man" \
# Flags
CONFIGURE_ENV+= PTHREAD_LDFLAGS="-lpthread"
-USES= cpe compiler waf pkgconfig perl5 python:2 \
+USES= cpe compiler waf pkgconfig perl5 python:2.7 \
readline iconv shebangfix
USE_PERL5= build
USE_LDCONFIG= ${SAMBA4_LIBDIR}
diff --git a/net/spideroak/Makefile b/net/spideroak/Makefile
index 1aefbca5d92e..65aa223453ac 100644
--- a/net/spideroak/Makefile
+++ b/net/spideroak/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spideroak
PORTVERSION= 6.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://nivit.altervista.org/FreeBSD/ports/distfiles/${PORTNAME}/ \
https://spideroak.com/getbuild?platform=slackware&arch=i386&dummy=/
@@ -32,7 +32,7 @@ PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,} \
SUB_LIST= LINUXBASE=${LINUXBASE}
SUB_FILES= pkg-message
-USES= desktop-file-utils linux python:2 tar:tgz
+USES= desktop-file-utils linux python:2.7 tar:tgz
USE_LINUX= xorglibs
post-patch:
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
index c68068c7351f..1ed631a9f7eb 100644
--- a/net/xorp/Makefile
+++ b/net/xorp/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libpcap.so.1:net/libpcap # avoid base libpcap
-USES= ncurses scons shebangfix ssl compiler:env python:2,build
+USES= ncurses scons shebangfix ssl compiler:env python:2.7,build
USE_GITHUB= yes
USE_RC_SUBR= xorp
GH_ACCOUNT= greearb