aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-24 18:10:30 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-24 18:10:30 +0000
commite1598249298974c6e8c61c34d927acabee345542 (patch)
tree5883afe298a5f232e854b104fc944ca19c4f7e7f /net
parent422e3bda8bd3eb5d0b4737e335fd434883fbc44f (diff)
downloadports-e1598249298974c6e8c61c34d927acabee345542.tar.gz
ports-e1598249298974c6e8c61c34d927acabee345542.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/avahi-app/Makefile2
-rw-r--r--net/blam/Makefile2
-rw-r--r--net/desktop-data-model/Makefile2
-rw-r--r--net/ekiga/Makefile2
-rw-r--r--net/ekiga3/Makefile2
-rw-r--r--net/glib-networking/Makefile2
-rw-r--r--net/gnetcat/Makefile2
-rw-r--r--net/gnome-netstatus/Makefile2
-rw-r--r--net/gnome-nettool/Makefile2
-rw-r--r--net/gnu-dico/Makefile2
-rw-r--r--net/gnu-radius/Makefile2
-rw-r--r--net/gq/Makefile2
-rw-r--r--net/grsync/Makefile2
-rw-r--r--net/gtk-vnc/Makefile2
-rw-r--r--net/heybuddy/Makefile2
-rw-r--r--net/jwhois/Makefile2
-rw-r--r--net/libgnetwork/Makefile2
-rw-r--r--net/libgweather/Makefile2
-rw-r--r--net/libmms/Makefile2
-rw-r--r--net/link-monitor-applet/Makefile2
-rw-r--r--net/miredo/Makefile2
-rw-r--r--net/morebalance/Makefile2
-rw-r--r--net/nc6/Makefile2
-rw-r--r--net/netdude/Makefile2
-rw-r--r--net/netspeed_applet/Makefile2
-rw-r--r--net/nxserver/Makefile2
-rw-r--r--net/online-desktop/Makefile2
-rw-r--r--net/opennx/Makefile2
-rw-r--r--net/phamm/Makefile2
-rw-r--r--net/py-ldaptor/Makefile2
-rw-r--r--net/remmina-applet/Makefile2
-rw-r--r--net/remmina-plugin-i18n/Makefile2
-rw-r--r--net/remmina/Makefile2
-rw-r--r--net/service-discovery-applet/Makefile2
-rw-r--r--net/smb4k/Makefile2
-rw-r--r--net/tcpreen/Makefile2
-rw-r--r--net/tucan/Makefile2
-rw-r--r--net/twitux/Makefile2
-rw-r--r--net/ushare/Makefile2
-rw-r--r--net/vino/Makefile2
-rw-r--r--net/wol/Makefile2
-rw-r--r--net/x11vnc/Makefile2
42 files changed, 42 insertions, 42 deletions
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
index 311a9a70cc8d..6388ea8012f6 100644
--- a/net/avahi-app/Makefile
+++ b/net/avahi-app/Makefile
@@ -27,7 +27,7 @@ USERS?= ${PORTNAME}
GROUPS?= ${USERS}
USE_GNOME?= gnomehack ltverhack glib20 intltool
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME_SUBR= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
diff --git a/net/blam/Makefile b/net/blam/Makefile
index 08f6bd605bbc..ec31f55b064c 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= GMSGFMT="${LOCALBASE}/bin/msgfmt" DATADIRNAME="share"
USE_GNOME= gnomesharp20
-USE_GETTEXT= yes
+USES= gettext
INSTALLS_ICONS= yes
GCONF_SCHEMAS= blam.schemas
diff --git a/net/desktop-data-model/Makefile b/net/desktop-data-model/Makefile
index a927c3d21134..b129405f8da9 100644
--- a/net/desktop-data-model/Makefile
+++ b/net/desktop-data-model/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
USE_GMAKE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME= gnomehack gtk20 glib20 gnomedesktop gnomevfs2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-maemo=no
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index a386a1a4a112..84ba453deff8 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= ekiga-3.*
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_SDL= sdl
INSTALLS_OMF= yes
USE_GNOME= libgnomeui gnomeprefix gnomehack gnomedocutils \
diff --git a/net/ekiga3/Makefile b/net/ekiga3/Makefile
index b9eb55c4e492..53f17d64a012 100644
--- a/net/ekiga3/Makefile
+++ b/net/ekiga3/Makefile
@@ -23,7 +23,7 @@ USE_GCC= any
USE_PERL5= yes
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
USE_XORG= xv
USE_GNOME= gtk20 gnomehack
diff --git a/net/glib-networking/Makefile b/net/glib-networking/Makefile
index 9b14850a958a..efdaed5f42bc 100644
--- a/net/glib-networking/Makefile
+++ b/net/glib-networking/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_ro
USE_XZ= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack glib20 intltool
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
diff --git a/net/gnetcat/Makefile b/net/gnetcat/Makefile
index 77d88874fae5..9b690d281c1a 100644
--- a/net/gnetcat/Makefile
+++ b/net/gnetcat/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GPL'ed re-write of the well known networking tool netcat
USE_ICONV= yes
-USE_GETTEXT= yes
+USES= gettext
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index eb9a796c9f5d..229730211fa8 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnome gnomepanel \
gnomedocutils
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index bb5b8ca86ed1..b68fafd716a5 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2 gnomedocutils
GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/net/gnu-dico/Makefile b/net/gnu-dico/Makefile
index 9c64dc9a7131..04c193f84a40 100644
--- a/net/gnu-dico/Makefile
+++ b/net/gnu-dico/Makefile
@@ -83,7 +83,7 @@ PLIST_SUB+= LDAP="@comment "
.endif
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
index 5de1a76d96f8..b43eb81f7266 100644
--- a/net/gnu-radius/Makefile
+++ b/net/gnu-radius/Makefile
@@ -101,7 +101,7 @@ PLIST_SUB+= EMACS="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 360f575d88b2..78560ab8c927 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -21,7 +21,7 @@ CACHE_DESC= Support the OpenLDAP experimental client cache
USE_GNOME= libglade2 gnomedocutils
USE_OPENSSL= yes
USE_OPENLDAP= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE}
diff --git a/net/grsync/Makefile b/net/grsync/Makefile
index 7e37a371e8eb..85eb5169527f 100644
--- a/net/grsync/Makefile
+++ b/net/grsync/Makefile
@@ -30,7 +30,7 @@ MAN1= grsync.1 grsync-batch.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/net/gtk-vnc/Makefile b/net/gtk-vnc/Makefile
index 9a957d4952b0..2c1da2993ddc 100644
--- a/net/gtk-vnc/Makefile
+++ b/net/gtk-vnc/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= gtk-vnc-0.4.[0-9]*
USE_GNOME= pygtk2 gnomehack
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_LDCONFIG= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/net/heybuddy/Makefile b/net/heybuddy/Makefile
index 467e7fd4a732..d5f7557315c1 100644
--- a/net/heybuddy/Makefile
+++ b/net/heybuddy/Makefile
@@ -28,7 +28,7 @@ DESKTOP_ENTRIES= "Heybuddy" \
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index f9f6512ea6d2..c356e53a849e 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT=An improved WHOIS client capable of selecting server to query
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
CPPFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
diff --git a/net/libgnetwork/Makefile b/net/libgnetwork/Makefile
index e4199d19ae05..7865ac3946cf 100644
--- a/net/libgnetwork/Makefile
+++ b/net/libgnetwork/Makefile
@@ -17,7 +17,7 @@ COMMENT= A GLib-based networking wrapper
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME= gnomeprefix gnomehack intlhack gconf2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/libgweather/Makefile b/net/libgweather/Makefile
index 867bc56c9f8b..f2cb88204d2a 100644
--- a/net/libgweather/Makefile
+++ b/net/libgweather/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/mi
LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
-USE_GETTEXT= yes
+USES= gettext
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 ltverhack
diff --git a/net/libmms/Makefile b/net/libmms/Makefile
index df92c4abc182..b7781e916cc6 100644
--- a/net/libmms/Makefile
+++ b/net/libmms/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= kwm@FreeBSD.org
COMMENT= Library for parsing mms:// and mmsh:// type network streams
USE_GNOME= gnomehack pkgconfig glib20
-USE_GETTEXT= yes
+USES= gettext
USE_ICONV= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/link-monitor-applet/Makefile b/net/link-monitor-applet/Makefile
index 997afbe8ca08..dd346cc49d51 100644
--- a/net/link-monitor-applet/Makefile
+++ b/net/link-monitor-applet/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
USE_BZIP2= yes
USE_GNOME= gnomepanel gnomeprefix libgnomeui librsvg2
-USE_GETTEXT= yes
+USES= gettext
INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
index 7accf4eb8938..7c0868a973e8 100644
--- a/net/miredo/Makefile
+++ b/net/miredo/Makefile
@@ -31,7 +31,7 @@ USE_RC_SUBR= miredo_server miredo
LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
USE_ICONV= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB= NLS=""
diff --git a/net/morebalance/Makefile b/net/morebalance/Makefile
index 4f74b9073972..07c99be7aa62 100644
--- a/net/morebalance/Makefile
+++ b/net/morebalance/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre \
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-USE_GETTEXT= YES
+USES= gettext
LDFLAGS+= -L${LOCALBASE}/lib -lpcre -lggz -lgnutls \
-L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/net/nc6/Makefile b/net/nc6/Makefile
index 12a079a118c5..50ac0a063c46 100644
--- a/net/nc6/Makefile
+++ b/net/nc6/Makefile
@@ -22,7 +22,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index 5aae269e9b67..c3d11136ac67 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= netdude.0:${PORTSDIR}/net/libnetdude
USE_AUTOTOOLS= libltdl libtool
USE_ICONV= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${DOCSDIR}
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lltdl"
diff --git a/net/netspeed_applet/Makefile b/net/netspeed_applet/Makefile
index 73a0ae39a57b..d9a38db61410 100644
--- a/net/netspeed_applet/Makefile
+++ b/net/netspeed_applet/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop
INSTALLS_OMF= yes
USE_GMAKE= yes
USE_GNOME= gnomehier intlhack gnomeprefix gnomehack gnomepanel
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/nxserver/Makefile b/net/nxserver/Makefile
index a62883dd23e4..1f50df2ca5a9 100644
--- a/net/nxserver/Makefile
+++ b/net/nxserver/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
WRKSRC= ${WRKDIR}
GNU_CONFIGURE= yes
ALL_TARGET= World
diff --git a/net/online-desktop/Makefile b/net/online-desktop/Makefile
index 790effefc838..10332fff1bdc 100644
--- a/net/online-desktop/Makefile
+++ b/net/online-desktop/Makefile
@@ -33,7 +33,7 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/desktop-data-engine:${PORTSDIR}/net/desktop-da
USE_BZIP2= yes
USE_GNOME= glib20 gconf2 pygnomedesktop
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
USE_PYTHON= 2.5+
GCONF_SCHEMAS= online-desktop.schemas
diff --git a/net/opennx/Makefile b/net/opennx/Makefile
index 35cd74649d11..1f4ff3e4d112 100644
--- a/net/opennx/Makefile
+++ b/net/opennx/Makefile
@@ -42,7 +42,7 @@ SSH_KEYGEN?= ssh-keygen
CONFIGURE_ARGS+=--disable-nls --localedir=/dev/null
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/net/phamm/Makefile b/net/phamm/Makefile
index 2fa3cb990feb..39e544162914 100644
--- a/net/phamm/Makefile
+++ b/net/phamm/Makefile
@@ -16,7 +16,7 @@ COMMENT= Front-end written in PHP to manage virtual service
NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session
-USE_GETTEXT= yes
+USES= gettext
PHAMMDIR?= www/${PORTNAME}
SCHEMADIR= ${WRKSRC}/schema
diff --git a/net/py-ldaptor/Makefile b/net/py-ldaptor/Makefile
index 549a4a4db693..2a07b89798bf 100644
--- a/net/py-ldaptor/Makefile
+++ b/net/py-ldaptor/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing \
GITVERSION= aad8ded658b36337a08aeb7402b6b67eb8771bea
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= yes
USE_TWISTED= yes
USE_PYDISTUTILS= yes
diff --git a/net/remmina-applet/Makefile b/net/remmina-applet/Makefile
index 443f46dadf57..14c665b0c43c 100644
--- a/net/remmina-applet/Makefile
+++ b/net/remmina-applet/Makefile
@@ -29,7 +29,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/net/remmina-plugin-i18n/Makefile b/net/remmina-plugin-i18n/Makefile
index d638ef31e1ff..868be5c15bcd 100644
--- a/net/remmina-plugin-i18n/Makefile
+++ b/net/remmina-plugin-i18n/Makefile
@@ -11,6 +11,6 @@ COMMENT= Localized messages for Remmina plugins
MASTERDIR= ${.CURDIR}/../remmina-plugins
-USE_GETTEXT= yes
+USES= gettext
.include "${MASTERDIR}/Makefile"
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 161531f7ece6..b7f3e44d5c7e 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -37,7 +37,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/net/service-discovery-applet/Makefile b/net/service-discovery-applet/Makefile
index 399246a5d4de..6e800c31703a 100644
--- a/net/service-discovery-applet/Makefile
+++ b/net/service-discovery-applet/Makefile
@@ -18,7 +18,7 @@ COMMENT= A GNOME applet that shows available network services using mDNS
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/avahi/__init__.py:${PORTSDIR}/net/py-avahi
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/avahi/__init__.py:${PORTSDIR}/net/py-avahi
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= yes
USE_GNOME= gnomehack gnomeprefix intlhack pygnomedesktop
USE_GMAKE= yes
diff --git a/net/smb4k/Makefile b/net/smb4k/Makefile
index 5ca48c81e4d3..bc430dfaf3cd 100644
--- a/net/smb4k/Makefile
+++ b/net/smb4k/Makefile
@@ -23,7 +23,7 @@ SAMBA_PORT?= net/samba36
USE_KDEBASE_VER= 3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USE_GETTEXT= yes
+USES= gettext
USE_BZIP2= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS += --with-qt-dir=${QT_PREFIX} \
diff --git a/net/tcpreen/Makefile b/net/tcpreen/Makefile
index 41f44283fe31..605be9513d8d 100644
--- a/net/tcpreen/Makefile
+++ b/net/tcpreen/Makefile
@@ -17,7 +17,7 @@ MAN1= tcpreen.1
DOC_FILES= AUTHORS NEWS README THANKS TODO
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/net/tucan/Makefile b/net/tucan/Makefile
index 4cb62e9bb360..e6e9da4e706d 100644
--- a/net/tucan/Makefile
+++ b/net/tucan/Makefile
@@ -24,7 +24,7 @@ USE_PYTHON= 2.5+
MANCOMPRESSED= yes
MAN1= tucan.1
-USE_GETTEXT= yes
+USES= gettext
post-patch:
${REINPLACE_CMD} -Ee 's|#! /usr/bin/env python|#! ${PYTHON_CMD}|' ${WRKSRC}/tucan.py
diff --git a/net/twitux/Makefile b/net/twitux/Makefile
index 2648e2a7c287..c161a783d37d 100644
--- a/net/twitux/Makefile
+++ b/net/twitux/Makefile
@@ -25,7 +25,7 @@ INSTALLS_OMF= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
CONFIGURE_ENV+= GMSGFMT="${LOCALBASE}/bin/msgfmt"
GCONF_SCHEMAS= twitux.schemas
INSTALLS_ICONS= yes
diff --git a/net/ushare/Makefile b/net/ushare/Makefile
index 455d9ce16eb9..2145fbefa78c 100644
--- a/net/ushare/Makefile
+++ b/net/ushare/Makefile
@@ -16,7 +16,7 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
-USE_GETTEXT= yes
+USES= gettext
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CFLAGS+= -I${LOCALBASE}/include -I${WRKSRC}
diff --git a/net/vino/Makefile b/net/vino/Makefile
index 9de0c891209e..17392f001946 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
USE_BZIP2= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME= gnomeprefix intlhack gnomehack gnomepanel
USE_XORG= xtst
USE_GMAKE= yes
diff --git a/net/wol/Makefile b/net/wol/Makefile
index 0607fb96a635..318d281c1c43 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -21,7 +21,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-nls
PLIST_SUB= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
USE_ICONV= yes
PLIST_SUB= NLS=""
.endif
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 72ca1b822d88..caddb89316f2 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -36,7 +36,7 @@ NO_OPTIONS_SORT=yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
.endif
.if ${PORT_OPTIONS:MAVAHI}