aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-20 16:04:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-20 16:04:25 +0000
commit1779c8dc073e0395f4eecc6e42321e98b5e30749 (patch)
tree068fd40f9813456e3287e081af72708158112025 /net
parent1e52282e828beb7e3d1c09b1d6ea486e5777bdef (diff)
downloadports-1779c8dc073e0395f4eecc6e42321e98b5e30749.tar.gz
ports-1779c8dc073e0395f4eecc6e42321e98b5e30749.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/mars_nwe/Makefile8
-rw-r--r--net/msend/Makefile8
-rw-r--r--net/poptop/Makefile8
-rw-r--r--net/rmsg/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/net/mars_nwe/Makefile b/net/mars_nwe/Makefile
index a6fd2b3cfb9c..741e8be7085d 100644
--- a/net/mars_nwe/Makefile
+++ b/net/mars_nwe/Makefile
@@ -22,6 +22,12 @@ WRKSRC= ${WRKDIR}/mars_nwe
PLIST= ${WRKDIR}/PLIST.DYN
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
do-install:
@(cd ${WRKSRC} && ./mk.li install)
@${INSTALL_DATA} ${WRKSRC}/examples/nw.ini ${PREFIX}/etc/nwserv.conf.example
@@ -45,4 +51,4 @@ post-install:
.endif
@${ECHO_MSG} "Look in ${DOCSDIR} for documentation."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/msend/Makefile b/net/msend/Makefile
index 08a9533c5ecd..f195d6eaef91 100644
--- a/net/msend/Makefile
+++ b/net/msend/Makefile
@@ -20,4 +20,10 @@ CFLAGS+= -DUSE_READLINE
MAN1= msend.1
MAN8= mesgd.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index 929e3cdc5e8e..92271dc27afa 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -39,4 +39,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf \
${PREFIX}/etc/pptpd.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/rmsg/Makefile b/net/rmsg/Makefile
index fa60cc60b5e8..7d2746e1469c 100644
--- a/net/rmsg/Makefile
+++ b/net/rmsg/Makefile
@@ -17,4 +17,10 @@ WRKSRC= ${WRKDIR}/rmsg
MAN1= rmsg.1
MAN8= rmsgd.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>