aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-13 09:13:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-13 09:13:15 +0000
commit219561fb300e87df34f5c6706a61f61dd3611796 (patch)
treed79b6bcd3a1f50a9304d826b9ae061867f37399b /net
parent2fd6221c0bd0b3c6bbb09d1c258b2266be78da9b (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-IO-Socket-Multicast6/Makefile27
-rw-r--r--net/p5-IO-Socket-Multicast6/distinfo3
-rw-r--r--net/p5-IO-Socket-Multicast6/pkg-descr10
-rw-r--r--net/p5-IO-Socket-Multicast6/pkg-plist4
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0518837c2290..ee6b6c618e6a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -419,6 +419,7 @@
SUBDIR += p5-IO-INET6
SUBDIR += p5-IO-Interface
SUBDIR += p5-IO-Socket-Multicast
+ SUBDIR += p5-IO-Socket-Multicast6
SUBDIR += p5-IP-Country
SUBDIR += p5-JavaScript-RPC
SUBDIR += p5-Net
diff --git a/net/p5-IO-Socket-Multicast6/Makefile b/net/p5-IO-Socket-Multicast6/Makefile
new file mode 100644
index 000000000000..34e003f827ae
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast6/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-IO-Socket-Multicast6
+# Date created: 2007-03-10
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Socket-Multicast6
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Send and receive IPv4 and IPv6 multicast messages
+
+RUN_DEPENDS= p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6 \
+ p5-IO-Interface>=1.01:${PORTSDIR}/net/p5-IO-Interface \
+ p5-Socket-Multicast6>=0.01:${PORTSDIR}/net/p5-Socket-Multicast6 \
+ ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-INET6
+
+PERL_MODBUILD= yes
+
+MAN3= IO::Socket::Multicast6.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-IO-Socket-Multicast6/distinfo b/net/p5-IO-Socket-Multicast6/distinfo
new file mode 100644
index 000000000000..10244d3a549e
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast6/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-Socket-Multicast6-0.02.tar.gz) = ccc2f461f4936cd4336722872af654dd
+SHA256 (IO-Socket-Multicast6-0.02.tar.gz) = 9d2359516570f2133ab71bc709deba0528fabe0f75a7e4ea10a1377b098feaea
+SIZE (IO-Socket-Multicast6-0.02.tar.gz) = 12156
diff --git a/net/p5-IO-Socket-Multicast6/pkg-descr b/net/p5-IO-Socket-Multicast6/pkg-descr
new file mode 100644
index 000000000000..ccb627aee090
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast6/pkg-descr
@@ -0,0 +1,10 @@
+The IO::Socket::Multicast6 module subclasses IO::Socket::INET6 to enable you to
+manipulate multicast groups. With this module you will be able to receive
+incoming multicast transmissions and generate your own outgoing multicast
+packets.
+
+This module uses the same API as IO::Socket::Multicast, but with added support
+for IPv6 (IPv4 is still supported). Unlike IO::Socket::Multicast, this is a
+pure-perl module.
+
+WWW: http://search.cpan.org/dist/IO-Socket-Multicast6/
diff --git a/net/p5-IO-Socket-Multicast6/pkg-plist b/net/p5-IO-Socket-Multicast6/pkg-plist
new file mode 100644
index 000000000000..0700504b1f43
--- /dev/null
+++ b/net/p5-IO-Socket-Multicast6/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/IO/Socket/Multicast6.pm
+@dirrmtry %%SITE_PERL%%/IO/Socket
+@dirrmtry %%SITE_PERL%%/IO