aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2011-11-19 14:31:23 +0000
committerRenato Botelho <garga@FreeBSD.org>2011-11-19 14:31:23 +0000
commit22a440235e7e811a624bf49dc4cf776c52387956 (patch)
treeb03b6028c0d7dede25e171395f21c36cdff180ec /net
parentf3ab96460a9a06f759556885740194c52b7947ce (diff)
downloadports-22a440235e7e811a624bf49dc4cf776c52387956.tar.gz
ports-22a440235e7e811a624bf49dc4cf776c52387956.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/rinetd/Makefile2
-rw-r--r--net/rinetd/files/patch-rinetd.c8
2 files changed, 9 insertions, 1 deletions
diff --git a/net/rinetd/Makefile b/net/rinetd/Makefile
index 91d7b94db700..ba63e73ff669 100644
--- a/net/rinetd/Makefile
+++ b/net/rinetd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rinetd
PORTVERSION= 0.62
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.boutell.com/rinetd/http/ \
${MASTER_SITE_GENTOO}
diff --git a/net/rinetd/files/patch-rinetd.c b/net/rinetd/files/patch-rinetd.c
index c7797d5978ce..fe942d0093de 100644
--- a/net/rinetd/files/patch-rinetd.c
+++ b/net/rinetd/files/patch-rinetd.c
@@ -8,3 +8,11 @@
initArrays();
readConfiguration();
RegisterPID();
+@@ -646,6 +646,7 @@
+ }
+ }
+ }
++ fclose(in);
+ /* Open the log file */
+ if (logFile) {
+ fclose(logFile);