aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-09-09 22:41:43 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-09-09 22:41:43 +0000
commitb61cf1a74ae38385d3b4616f6352636dd7f20d57 (patch)
treec7441689be1b7d6baaf09b66d35ace396e47a0c3 /net
parentc35cc6b3920e6e7d1487afb0f0db83e07a818f9b (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/hupnp/Makefile7
-rw-r--r--net/hupnp/files/patch-herqq.pro7
-rw-r--r--net/hupnp/files/patch-hmulticast_socket.cpp8
-rw-r--r--net/hupnp/pkg-descr2
4 files changed, 8 insertions, 16 deletions
diff --git a/net/hupnp/Makefile b/net/hupnp/Makefile
index c53ad0f1d846..b2716fe9d1ed 100644
--- a/net/hupnp/Makefile
+++ b/net/hupnp/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: hupnp
-# Date created: 2010-12-29
-# Whom: Dima Panov <fluffy@FreeBSD.org>
-#
+# Created by: Dima Panov <fluffy@FreeBSD.org>
# $FreeBSD$
PORTNAME= hupnp
@@ -18,7 +15,7 @@ USE_ZIP= yes
USE_GMAKE= yes
USE_QT4= corelib network xml dbus gui \
qmake_build moc_build rcc_build uic_build
-QMAKE_ARGS= PREFIX=${PREFIX} herqq.pro
+QMAKE_ARGS= PREFIX=${PREFIX} "CONFIG+=DISABLE_AVTESTAPP DISABLE_TESTAPP" herqq.pro
do-configure:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
diff --git a/net/hupnp/files/patch-herqq.pro b/net/hupnp/files/patch-herqq.pro
deleted file mode 100644
index 7f87fd81a6e5..000000000000
--- a/net/hupnp/files/patch-herqq.pro
+++ /dev/null
@@ -1,7 +0,0 @@
---- ./herqq.pro.orig 2011-03-28 00:42:32.000000000 +1100
-+++ ./herqq.pro 2011-08-08 12:10:55.831627096 +1100
-@@ -18,4 +18,3 @@
- }
-
- !CONFIG(DISABLE_CORE) : SUBDIRS += hupnp
--!CONFIG(DISABLE_TESTAPP) : SUBDIRS += apps/simple_test-app
diff --git a/net/hupnp/files/patch-hmulticast_socket.cpp b/net/hupnp/files/patch-hmulticast_socket.cpp
index 49152aa5d75a..de79da5e8870 100644
--- a/net/hupnp/files/patch-hmulticast_socket.cpp
+++ b/net/hupnp/files/patch-hmulticast_socket.cpp
@@ -1,8 +1,10 @@
---- ./hupnp/src/socket/hmulticast_socket.cpp.orig 2011-03-28 00:42:32.000000000 +1100
-+++ ./hupnp/src/socket/hmulticast_socket.cpp 2011-08-08 11:59:59.868629425 +1100
-@@ -27,6 +27,8 @@
+--- ./hupnp/src/socket/hmulticast_socket.cpp.orig 2011-03-28 00:42:32.000000000 +0300
++++ ./hupnp/src/socket/hmulticast_socket.cpp 2013-09-10 00:35:26.000000000 +0300
+@@ -26,7 +26,10 @@
+ #include <winsock2.h>
#include <ws2tcpip.h>
#else
++#include <sys/types.h>
#include <arpa/inet.h>
+#include <netinet/in.h>
+#include <sys/socket.h>
diff --git a/net/hupnp/pkg-descr b/net/hupnp/pkg-descr
index 55eb6382776c..0b4ef667bbe2 100644
--- a/net/hupnp/pkg-descr
+++ b/net/hupnp/pkg-descr
@@ -1,4 +1,4 @@
Herqq UPnP (HUPnP) is a software library for building UPnP devices and control
points conforming to the UPnP Device Architecture version 1.1.
-WWW: http://www.herqq.org/
+WWW: http://hupnp.linada.fi/