aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
commitd500c1cc50f23b0489994e29a3a20f32a3cb441d (patch)
tree7c1e12df7a7d8fba86936f85270c40cc1e388312 /net
parent23e6a2b3da60fd03fb9e392af59450056c09f9a5 (diff)
downloadports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.tar.gz
ports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/slirp/Makefile8
-rw-r--r--net/sting/Makefile8
-rw-r--r--net/tcpview/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/net/slirp/Makefile b/net/slirp/Makefile
index 9e36f77163e3..874a74712594 100644
--- a/net/slirp/Makefile
+++ b/net/slirp/Makefile
@@ -17,6 +17,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
COMMENT= A (C)SLIP/PPP emulator for users with shell accounts
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
# serious LP64 issues
ONLY_FOR_ARCHS= i386
@@ -31,4 +37,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/slirp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/slirp.man ${PREFIX}/man/man1/slirp.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/sting/Makefile b/net/sting/Makefile
index b1258a0b3569..c806e7fccc55 100644
--- a/net/sting/Makefile
+++ b/net/sting/Makefile
@@ -14,6 +14,12 @@ DISTNAME= sting
MAINTAINER= kbyanc@posi.net
COMMENT= A tool that measures end-to-end TCP connection characteristics
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
do-install:
@@ -22,4 +28,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.sting
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index edceb69a1fd1..632af7d9e037 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -14,6 +14,12 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= A Motif-based TCP/IP protocol analyzer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_BISON= yes
USE_MOTIF= yes
USE_REINPLACE= yes
@@ -28,4 +34,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/DOC/Tcpview ${X11BASE}/lib/X11/app-defaults/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>