aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-11-10 16:57:25 +0000
committerJohn Marino <marino@FreeBSD.org>2013-11-10 16:57:25 +0000
commite9d8c3207ea5461719d6d9abb2518763f8813a76 (patch)
treea9a8f8a4bc2be735c6a0d71f8c7e0d4eb19888ab /net
parentb028024cc78daa5e7240009e4157a741899974aa (diff)
downloadports-e9d8c3207ea5461719d6d9abb2518763f8813a76.tar.gz
ports-e9d8c3207ea5461719d6d9abb2518763f8813a76.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/polyorb/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/net/polyorb/Makefile b/net/polyorb/Makefile
index 08e5eb3fa263..b0f265bb3414 100644
--- a/net/polyorb/Makefile
+++ b/net/polyorb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= polyorb
PORTVERSION= 2.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.dragonlace.net/src/
@@ -16,11 +17,12 @@ BUILD_DEPENDS= xmlada>=3.2:${PORTSDIR}/textproc/xmlada
USES+= ada gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
+NO_MTREE= yes
+
USE_PYTHON_BUILD= yes
+NO_LICENSES_INSTALL= yes
-DESTINY= ${WRKDIR}/destino
-MAKE_ENV= DESTDIR=${DESTINY} \
- PROCESSORS=${MAKE_JOBS_NUMBER}
+MAKE_ENV= PROCESSORS=${MAKE_JOBS_NUMBER}
CONFIGURE_ENV= PYTHON=${PYTHON_CMD} \
ac_cv_prog_CXXCPP="cpp -E" \
ac_cv_prog_SVN=false
@@ -38,22 +40,19 @@ CONFIGURE_ARGS= --with-appli-perso="corba dsa moma" \
# However, GPL 2012 is particularly unstable, so a custom tarball from
# SVN revision 201373 has been created, which is the last of PCS version 5.
-NO_STAGE= yes
do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} default
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} default
post-install:
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d -empty -print | ${XARGS} ${RMDIR}
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
- @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${WRKDIR}/PLIST.all
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty -print | ${XARGS} ${RMDIR}
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' -e '/share\/gps/d' \
- -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+ -e 's/^/@dirrm /g' >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.mk>