aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-06-15 19:39:56 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-06-15 19:39:56 +0000
commit3ae7902d7aa7e80e5179dc0056a739982e04b1b3 (patch)
tree59c680626b40350c3e623be0f942824455c6e2cd /net
parent1cc2e0d40d66946907fe8c355c00d3eb6e37bab8 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pysphere/Makefile28
-rw-r--r--net/py-pysphere/distinfo2
-rw-r--r--net/py-pysphere/pkg-descr21
4 files changed, 52 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5aa39f0d0d71..d9e2a6c8619f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -931,6 +931,7 @@
SUBDIR += py-port-for
SUBDIR += py-pypcap
SUBDIR += py-pysendfile
+ SUBDIR += py-pysphere
SUBDIR += py-qt4-network
SUBDIR += py-radix
SUBDIR += py-s3cmd
diff --git a/net/py-pysphere/Makefile b/net/py-pysphere/Makefile
new file mode 100644
index 000000000000..858d6a47db5b
--- /dev/null
+++ b/net/py-pysphere/Makefile
@@ -0,0 +1,28 @@
+# Created by: olli hauer <ohauer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pysphere
+PORTVERSION= 0.1.7
+CATEGORIES= net python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ohauer@FreeBSD.org
+COMMENT= Python API for interaction with the vSphere Web Services SDK
+
+LICENSE= BSD
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+post-patch:
+ @${SED} -i '' -e 's/pysphere-0.1.5/pysphere-0.1.7/' \
+ ${WRKSRC}/setup.py \
+ ${WRKSRC}/PKG-INFO \
+ ${WRKSRC}/pysphere.egg-info/PKG-INFO
+
+.include <bsd.port.mk>
diff --git a/net/py-pysphere/distinfo b/net/py-pysphere/distinfo
new file mode 100644
index 000000000000..372246c5ec57
--- /dev/null
+++ b/net/py-pysphere/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pysphere-0.1.7.zip) = cef3cb3a6836f1cf092caf4613123d084f36b0e96fa48a27708c0e868df8a1ea
+SIZE (pysphere-0.1.7.zip) = 516848
diff --git a/net/py-pysphere/pkg-descr b/net/py-pysphere/pkg-descr
new file mode 100644
index 000000000000..799cbed4e441
--- /dev/null
+++ b/net/py-pysphere/pkg-descr
@@ -0,0 +1,21 @@
+Python API for interaction with the vSphere Web Services SDK.
+
+Among other operations, it provides easy interfaces to:
+
+- Connect to VMWare's ESX, ESXi, Virtual Center, Virtual Server hosts
+- Query hosts, datacenters, resource pools, virtual machines
+- VM: Power on, power off, reset, revert to snapshot, get properties, update
+ vmware tools, clone, migrate.
+- vSphere 5.0 Guest Operations: create/delete/move files and directories.
+ Upload/download files from the guest system. List/start/stop processes in
+ the guest system.
+- Create and delete snapshots
+- Hosts statistics and performance monitoring
+
+An of course, you can use it to access all the vSphere API through python.
+
+It's built upon a slightly modified version of ZSI (that comes bundled-in)
+which makes it really fast in contrast to other python SOAP libraries that
+don't provide code generation.
+
+WWW: https://code.google.com/p/pysphere/