aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-15 16:02:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-15 16:02:32 +0000
commit500f132b543487cd0780ec8896d123f3282ba49e (patch)
tree6f3e1b00b174a26096ccce3b08c6bfc105f4e114 /net
parente4c542c72559ad221db9bd4506fda8bdbb4907a3 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Net_Nmap/Makefile34
-rw-r--r--net/pear-Net_Nmap/distinfo3
-rw-r--r--net/pear-Net_Nmap/pkg-descr9
4 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fb950037e262..c5be21c7715c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -665,6 +665,7 @@
SUBDIR += pear-Net_LDAP2
SUBDIR += pear-Net_MAC
SUBDIR += pear-Net_NNTP
+ SUBDIR += pear-Net_Nmap
SUBDIR += pear-Net_POP3
SUBDIR += pear-Net_Ping
SUBDIR += pear-Net_SMS
diff --git a/net/pear-Net_Nmap/Makefile b/net/pear-Net_Nmap/Makefile
new file mode 100644
index 000000000000..3aae32da2192
--- /dev/null
+++ b/net/pear-Net_Nmap/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-Net_Nmap
+# Date created: 13 Oct 2008
+# Whom: Wen Heping<wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Nmap
+PORTVERSION= 1.0.0
+CATEGORIES= net pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Simple Wrapper Class for the Nmap Utility
+
+BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net
+FILES= Nmap.php \
+ Nmap/Exception.php Nmap/Host.php \
+ Nmap/Parser.php Nmap/Service.php
+
+EXAMPLES= example1.php example2.php example2.xml
+
+TESTS= NetNmapParseTest.php \
+ NetNmapParseTest.xml \
+ NetNmapScanTest.php \
+ test_config.php
+
+DOCS= LICENSE README
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Nmap/distinfo b/net/pear-Net_Nmap/distinfo
new file mode 100644
index 000000000000..72076601f495
--- /dev/null
+++ b/net/pear-Net_Nmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Net_Nmap-1.0.0.tgz) = 4773850a9d92924fb38e6eb51e83df65
+SHA256 (PEAR/Net_Nmap-1.0.0.tgz) = 77220d4ebca7e2e414b8bb72f4ec4ebe4fc043e7fb7fae2d2ad135412e943a6b
+SIZE (PEAR/Net_Nmap-1.0.0.tgz) = 19450
diff --git a/net/pear-Net_Nmap/pkg-descr b/net/pear-Net_Nmap/pkg-descr
new file mode 100644
index 000000000000..af230b6281f7
--- /dev/null
+++ b/net/pear-Net_Nmap/pkg-descr
@@ -0,0 +1,9 @@
+Net_Nmap is a simple interface for Nmap, the
+free and open source utility for network
+exploration or security auditing.
+
+Net_Nmap can be used to auto discovery hosts
+and services in your network or simply to
+parse Nmap XML output.
+
+WWW: http://pear.php.net/package/Net_Nmap/