aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-02 20:59:47 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-02 20:59:47 +0000
commit6b7bd47b4e1788c8aab74d3760670bb3bf6e2283 (patch)
tree62f968ac7e246959f91e9d17afdb0483da298b7b /net
parent70cb68b667af4d2bdf206c5ac53bce3020f259a0 (diff)
downloadports-6b7bd47b4e1788c8aab74d3760670bb3bf6e2283.tar.gz
ports-6b7bd47b4e1788c8aab74d3760670bb3bf6e2283.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/babeld/Makefile4
-rw-r--r--net/babeld/distinfo4
-rw-r--r--net/babeld/files/patch-Makefile30
-rw-r--r--net/babeld/files/patch-util.c10
4 files changed, 11 insertions, 37 deletions
diff --git a/net/babeld/Makefile b/net/babeld/Makefile
index 3f77820cb2ad..e7cb44e5dbf8 100644
--- a/net/babeld/Makefile
+++ b/net/babeld/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= babeld
-PORTVERSION= 1.2.0
+PORTVERSION= 1.3.3
CATEGORIES= net
-MASTER_SITES= http://www.pps.jussieu.fr/~jch/software/files/
+MASTER_SITES= http://www.pps.univ-paris-diderot.fr/~jch/software/files/
MAINTAINER= gaod@hychen.org
COMMENT= A distance-vector routing protocol
diff --git a/net/babeld/distinfo b/net/babeld/distinfo
index 868c1df73f03..648193ef4ffa 100644
--- a/net/babeld/distinfo
+++ b/net/babeld/distinfo
@@ -1,2 +1,2 @@
-SHA256 (babeld-1.2.0.tar.gz) = e864298dda0a0a3d1daf91d1cf45ddd0896557accbbe5eb8aec3c2d3cf7a6aef
-SIZE (babeld-1.2.0.tar.gz) = 62720
+SHA256 (babeld-1.3.3.tar.gz) = 1376b901f18b193defa2b4e4337e13ead21c0a60c309e37ba086d82fe2f5638f
+SIZE (babeld-1.3.3.tar.gz) = 65126
diff --git a/net/babeld/files/patch-Makefile b/net/babeld/files/patch-Makefile
index fb7cdd699e8e..3489451d109c 100644
--- a/net/babeld/files/patch-Makefile
+++ b/net/babeld/files/patch-Makefile
@@ -1,30 +1,14 @@
---- Makefile.orig 2010-02-09 01:42:25.000000000 +0800
-+++ Makefile 2010-04-21 17:35:52.000000000 +0800
-@@ -1,12 +1,8 @@
--PREFIX = /usr/local
--
+--- Makefile.orig 2012-07-30 15:04:33.000000000 +0800
++++ Makefile 2012-07-30 15:05:21.000000000 +0800
+@@ -1,6 +1,6 @@
+ PREFIX = /usr/local
+
-CDEBUGFLAGS = -Os -g -Wall
-+CDEBUGFLAGS = -O2 -Wall
++CDEBUGFLAGS = -O2 -g -Wall
DEFINES = $(PLATFORM_DEFINES)
--CFLAGS = $(CDEBUGFLAGS) $(DEFINES) $(EXTRA_DEFINES)
--
--LDLIBS = -lrt
-+CFLAGS = $(CDEBUGFLAGS) $(DEFINES) $(EXTRA_DEFINES) -D__APPLE__
-
- SRCS = babeld.c net.c kernel.c util.c network.c source.c neighbour.c \
- route.c xroute.c message.c resend.c config.c local.c
-@@ -15,7 +11,7 @@
- route.o xroute.o message.o resend.o config.o local.o
-
- babeld: $(OBJS)
-- $(CC) $(CFLAGS) $(LDFLAGS) -o babeld $(OBJS) $(LDLIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o babeld $(OBJS)
-
- .SUFFIXES: .man .html
-
-@@ -33,13 +29,10 @@
+@@ -33,13 +33,10 @@
all: babeld babeld.man
install.minimal: babeld
diff --git a/net/babeld/files/patch-util.c b/net/babeld/files/patch-util.c
deleted file mode 100644
index c5293bcc4d43..000000000000
--- a/net/babeld/files/patch-util.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- util.c.orig 2010-04-20 05:48:52.000000000 +0800
-+++ util.c 2010-04-20 05:49:28.000000000 +0800
-@@ -31,6 +31,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
-+#include <netinet/in.h>
-
- #include "babeld.h"
- #include "util.h"