aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /net
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile5
-rw-r--r--net/hs-connection/Makefile17
-rw-r--r--net/hs-connection/distinfo2
-rw-r--r--net/hs-connection/pkg-descr6
-rw-r--r--net/hs-gsasl/Makefile16
-rw-r--r--net/hs-gsasl/distinfo2
-rw-r--r--net/hs-gsasl/pkg-descr3
-rw-r--r--net/hs-hostname/Makefile4
-rw-r--r--net/hs-iproute/Makefile15
-rw-r--r--net/hs-iproute/distinfo2
-rw-r--r--net/hs-iproute/pkg-descr5
-rw-r--r--net/hs-maccatcher/Makefile4
-rw-r--r--net/hs-network-conduit/Makefile17
-rw-r--r--net/hs-network-conduit/distinfo2
-rw-r--r--net/hs-network-conduit/pkg-descr3
-rw-r--r--net/hs-network-info/Makefile5
-rw-r--r--net/hs-network-info/distinfo4
-rw-r--r--net/hs-network-info/pkg-descr9
-rw-r--r--net/hs-network-multicast/Makefile3
-rw-r--r--net/hs-network-multicast/distinfo4
-rw-r--r--net/hs-network-protocol-xmpp/Makefile16
-rw-r--r--net/hs-network-protocol-xmpp/distinfo2
-rw-r--r--net/hs-network-protocol-xmpp/pkg-descr3
-rw-r--r--net/hs-network/Makefile5
-rw-r--r--net/hs-network/distinfo4
-rw-r--r--net/hs-pcap/Makefile4
-rw-r--r--net/hs-publicsuffixlist/Makefile4
-rw-r--r--net/hs-sendfile/Makefile4
-rw-r--r--net/hs-simple-sendfile/Makefile7
-rw-r--r--net/hs-simple-sendfile/distinfo4
-rw-r--r--net/hs-socks/Makefile5
-rw-r--r--net/hs-socks/distinfo4
32 files changed, 128 insertions, 62 deletions
diff --git a/net/Makefile b/net/Makefile
index b9a7aeef389b..b490e6fc6937 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -203,12 +203,15 @@
SUBDIR += howl
SUBDIR += hping
SUBDIR += hping-devel
+ SUBDIR += hs-connection
+ SUBDIR += hs-gsasl
SUBDIR += hs-hostname
+ SUBDIR += hs-iproute
SUBDIR += hs-maccatcher
SUBDIR += hs-network
- SUBDIR += hs-network-conduit
SUBDIR += hs-network-info
SUBDIR += hs-network-multicast
+ SUBDIR += hs-network-protocol-xmpp
SUBDIR += hs-pcap
SUBDIR += hs-publicsuffixlist
SUBDIR += hs-sendfile
diff --git a/net/hs-connection/Makefile b/net/hs-connection/Makefile
new file mode 100644
index 000000000000..54f5adf2975a
--- /dev/null
+++ b/net/hs-connection/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= connection
+PORTVERSION= 0.2.3
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Simple and easy network connections API
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= cprng-aes data-default-class network>=2.3 socks>=0.4 \
+ tls>=1.2 x509>=1.4 x509-store>=1.4 x509-system>=1.4 \
+ x509-validation>=1.5
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-connection/distinfo b/net/hs-connection/distinfo
new file mode 100644
index 000000000000..b8a65f4ee764
--- /dev/null
+++ b/net/hs-connection/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/connection-0.2.3.tar.gz) = 4b6f62d66bebc38052e98f2b6798acdb79c9171b170d2e059aaa697d53b0b80a
+SIZE (cabal/connection-0.2.3.tar.gz) = 7621
diff --git a/net/hs-connection/pkg-descr b/net/hs-connection/pkg-descr
new file mode 100644
index 000000000000..aad4e8aab151
--- /dev/null
+++ b/net/hs-connection/pkg-descr
@@ -0,0 +1,6 @@
+Simple network library for all your connection need. Features: Really
+simple to use, SSL/TLS, SOCKS. This library provides a very simple api
+to create sockets to a destination with the choice of SSL/TLS, and
+SOCKS.
+
+WWW: http://github.com/vincenthz/hs-connection
diff --git a/net/hs-gsasl/Makefile b/net/hs-gsasl/Makefile
new file mode 100644
index 000000000000..727db8de2472
--- /dev/null
+++ b/net/hs-gsasl/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= gsasl
+PORTVERSION= 0.3.5
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Bindings for GNU libgsasl
+
+LICENSE= GPLv3
+
+USES= pkgconfig
+LIB_DEPENDS= libgsasl.so:${PORTSDIR}/security/gsasl
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-gsasl/distinfo b/net/hs-gsasl/distinfo
new file mode 100644
index 000000000000..a131f7646ff7
--- /dev/null
+++ b/net/hs-gsasl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/gsasl-0.3.5.tar.gz) = a3aecd149b580e2afc0f3473e806e2245a0b649df6c8359540fa65af8dce279d
+SIZE (cabal/gsasl-0.3.5.tar.gz) = 20117
diff --git a/net/hs-gsasl/pkg-descr b/net/hs-gsasl/pkg-descr
new file mode 100644
index 000000000000..245ab400f884
--- /dev/null
+++ b/net/hs-gsasl/pkg-descr
@@ -0,0 +1,3 @@
+Bindings for GNU libgsasl.
+
+WWW: https://john-millikin.com/software/haskell-gsasl/
diff --git a/net/hs-hostname/Makefile b/net/hs-hostname/Makefile
index fa135bdc519a..cbd54e1ad6d1 100644
--- a/net/hs-hostname/Makefile
+++ b/net/hs-hostname/Makefile
@@ -2,13 +2,13 @@
PORTNAME= hostname
PORTVERSION= 1.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Cross-platform means of determining the hostname
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/net/hs-iproute/Makefile b/net/hs-iproute/Makefile
new file mode 100644
index 000000000000..00cf3e358179
--- /dev/null
+++ b/net/hs-iproute/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= iproute
+PORTVERSION= 1.3.1
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= IP Routing Table
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= appar byteorder network
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-iproute/distinfo b/net/hs-iproute/distinfo
new file mode 100644
index 000000000000..0d63cbcabc6a
--- /dev/null
+++ b/net/hs-iproute/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/iproute-1.3.1.tar.gz) = b73104d337f14e63e1ca84dd37405df28e7a7f7e714e83efd63cca80d1d66ad0
+SIZE (cabal/iproute-1.3.1.tar.gz) = 9897
diff --git a/net/hs-iproute/pkg-descr b/net/hs-iproute/pkg-descr
new file mode 100644
index 000000000000..533e3608fef3
--- /dev/null
+++ b/net/hs-iproute/pkg-descr
@@ -0,0 +1,5 @@
+IP Routing Table is a tree of IP ranges to search one of them on the
+longest match base. It is a kind of TRIE with one way branching removed.
+Both IPv4 and IPv6 are supported.
+
+WWW: http://www.mew.org/~kazu/proj/iproute/
diff --git a/net/hs-maccatcher/Makefile b/net/hs-maccatcher/Makefile
index b9210467d4d6..8fac1dff8ef2 100644
--- a/net/hs-maccatcher/Makefile
+++ b/net/hs-maccatcher/Makefile
@@ -2,13 +2,13 @@
PORTNAME= maccatcher
PORTVERSION= 2.1.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Obtain the host MAC address on *NIX and Windows
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= parsec
diff --git a/net/hs-network-conduit/Makefile b/net/hs-network-conduit/Makefile
deleted file mode 100644
index e08c17f393f5..000000000000
--- a/net/hs-network-conduit/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= network-conduit
-PORTVERSION= 1.0.0
-PORTREVISION= 5
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Stream socket data using conduits
-
-LICENSE= BSD
-
-USE_CABAL= conduit>=1.0 lifted-base>=0.1 monad-control>=0.3 \
- network>=2.3 transformers>=0.2.2
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-network-conduit/distinfo b/net/hs-network-conduit/distinfo
deleted file mode 100644
index 94d0fadad127..000000000000
--- a/net/hs-network-conduit/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (cabal/network-conduit-1.0.0.tar.gz) = 63de6be7775d99a56485be57af965aea957c228ea9cae8389b20d03bb9796f9a
-SIZE (cabal/network-conduit-1.0.0.tar.gz) = 5853
diff --git a/net/hs-network-conduit/pkg-descr b/net/hs-network-conduit/pkg-descr
deleted file mode 100644
index 601a30445ae9..000000000000
--- a/net/hs-network-conduit/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Stream socket data using conduits.
-
-WWW: http://github.com/snoyberg/conduit
diff --git a/net/hs-network-info/Makefile b/net/hs-network-info/Makefile
index 0cc71cfc3613..b5378d70902e 100644
--- a/net/hs-network-info/Makefile
+++ b/net/hs-network-info/Makefile
@@ -1,14 +1,13 @@
# $FreeBSD$
PORTNAME= network-info
-PORTVERSION= 0.2.0.3
-PORTREVISION= 6
+PORTVERSION= 0.2.0.5
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Access the local computer's basic network configuration
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/net/hs-network-info/distinfo b/net/hs-network-info/distinfo
index b80aeea6f6ed..f0291a2020a4 100644
--- a/net/hs-network-info/distinfo
+++ b/net/hs-network-info/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-info-0.2.0.3.tar.gz) = 42e79146828b3e7dfeca884a4be4fe79f7a84bc4471d8cf1ecf7ea3c55a1dc12
-SIZE (cabal/network-info-0.2.0.3.tar.gz) = 5644
+SHA256 (cabal/network-info-0.2.0.5.tar.gz) = 8ee37b7e3219d18395a3c9020a9be8cfa7c5390f2c4b0e54b5feea35e5b4fd3d
+SIZE (cabal/network-info-0.2.0.5.tar.gz) = 5988
diff --git a/net/hs-network-info/pkg-descr b/net/hs-network-info/pkg-descr
index 17d9f8557cd5..f1952a45c1a3 100644
--- a/net/hs-network-info/pkg-descr
+++ b/net/hs-network-info/pkg-descr
@@ -1,7 +1,8 @@
This library provides simple read-only access to the local computer's
-networking configuration. It is currently capable of getting a list of
-all the network interfaces and their respective IPv4, IPv6 and MAC addresses.
-network-info has been tested and is known to work on Ubuntu 10.10, Mac OS
-X 10.6.4 and Windows XP.
+networking configuration. It is currently capable of getting a list of
+all the network interfaces and their respective IPv4, IPv6 and MAC
+addresses. network-info has been tested and is known to work on Ubuntu
+10.10, FreeBSD 9.0, Mac OS X 10.6.4 and Windows XP/7. It probably works
+on other flavours of Linux, OS X, FreeBSD and Windows as well.
WWW: http://github.com/jystic/network-info
diff --git a/net/hs-network-multicast/Makefile b/net/hs-network-multicast/Makefile
index 221b4bc248c8..7ebf266cdc22 100644
--- a/net/hs-network-multicast/Makefile
+++ b/net/hs-network-multicast/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= network-multicast
-PORTVERSION= 0.0.7
-PORTREVISION= 6
+PORTVERSION= 0.0.11
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-multicast/distinfo b/net/hs-network-multicast/distinfo
index dfa48152f1bd..1c8fabe78227 100644
--- a/net/hs-network-multicast/distinfo
+++ b/net/hs-network-multicast/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-multicast-0.0.7.tar.gz) = 8360edb6d575493331a92f03950e0039cad9ab09bf40bceaf821b2f3187914a3
-SIZE (cabal/network-multicast-0.0.7.tar.gz) = 2886
+SHA256 (cabal/network-multicast-0.0.11.tar.gz) = 65842175e53bb72164b7b1a448a3cc4bdf42df8d64089853ea54ccccd266fa39
+SIZE (cabal/network-multicast-0.0.11.tar.gz) = 2970
diff --git a/net/hs-network-protocol-xmpp/Makefile b/net/hs-network-protocol-xmpp/Makefile
new file mode 100644
index 000000000000..059e0bc81a7b
--- /dev/null
+++ b/net/hs-network-protocol-xmpp/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= network-protocol-xmpp
+PORTVERSION= 0.4.6
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Client library for the XMPP protocol
+
+LICENSE= GPLv3
+
+USE_CABAL= gnuidn>=0.2 gnutls>=0.1.4 gsasl>=0.3 libxml-sax>=0.7 \
+ monads-tf>=0.1 network>=2.2 text>=0.10 xml-types>=0.3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-network-protocol-xmpp/distinfo b/net/hs-network-protocol-xmpp/distinfo
new file mode 100644
index 000000000000..60fb116b3f2e
--- /dev/null
+++ b/net/hs-network-protocol-xmpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/network-protocol-xmpp-0.4.6.tar.gz) = d6ec010deff24503e8f8fdb67cfd10ba84f19907c95bf1fca24dec10be74aa76
+SIZE (cabal/network-protocol-xmpp-0.4.6.tar.gz) = 24100
diff --git a/net/hs-network-protocol-xmpp/pkg-descr b/net/hs-network-protocol-xmpp/pkg-descr
new file mode 100644
index 000000000000..cb14430f34cd
--- /dev/null
+++ b/net/hs-network-protocol-xmpp/pkg-descr
@@ -0,0 +1,3 @@
+Client library for the XMPP protocol.
+
+WWW: https://john-millikin.com/software/haskell-xmpp/
diff --git a/net/hs-network/Makefile b/net/hs-network/Makefile
index 432b828bfdb4..048a4a8d5709 100644
--- a/net/hs-network/Makefile
+++ b/net/hs-network/Makefile
@@ -1,14 +1,13 @@
# $FreeBSD$
PORTNAME= network
-PORTVERSION= 2.4.1.2
-PORTREVISION= 4
+PORTVERSION= 2.4.2.3
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Low-level networking interface
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= parsec>=3.0
diff --git a/net/hs-network/distinfo b/net/hs-network/distinfo
index 7649f3a2ef8a..f5340112bb53 100644
--- a/net/hs-network/distinfo
+++ b/net/hs-network/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-2.4.1.2.tar.gz) = b04dc56542428bc92f11263f500b3ad82e6a0787805601472d59af7e769bfe38
-SIZE (cabal/network-2.4.1.2.tar.gz) = 140424
+SHA256 (cabal/network-2.4.2.3.tar.gz) = 801b9c652dae626bf4a96175162b1290e7fe7ff20d802d62434d5ae1d363c16d
+SIZE (cabal/network-2.4.2.3.tar.gz) = 141749
diff --git a/net/hs-pcap/Makefile b/net/hs-pcap/Makefile
index adf13f75ebaa..1078f3ae34d3 100644
--- a/net/hs-pcap/Makefile
+++ b/net/hs-pcap/Makefile
@@ -3,13 +3,13 @@
PORTNAME= pcap
PORTVERSION= 0.4.5.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= System-independent interface for user-level packet capture
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= network
diff --git a/net/hs-publicsuffixlist/Makefile b/net/hs-publicsuffixlist/Makefile
index 98841a08d38a..4ca7eaf9221a 100644
--- a/net/hs-publicsuffixlist/Makefile
+++ b/net/hs-publicsuffixlist/Makefile
@@ -2,13 +2,13 @@
PORTNAME= publicsuffixlist
PORTVERSION= 0.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Is a given string a domain suffix?
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= cereal data-default text>=0.11 utf8-string
diff --git a/net/hs-sendfile/Makefile b/net/hs-sendfile/Makefile
index 7b46d1943c1e..986b140e4ae5 100644
--- a/net/hs-sendfile/Makefile
+++ b/net/hs-sendfile/Makefile
@@ -2,13 +2,13 @@
PORTNAME= sendfile
PORTVERSION= 0.7.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Portable sendfile library
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= network>=2
diff --git a/net/hs-simple-sendfile/Makefile b/net/hs-simple-sendfile/Makefile
index 4ba52b069d7c..87234ff77734 100644
--- a/net/hs-simple-sendfile/Makefile
+++ b/net/hs-simple-sendfile/Makefile
@@ -1,16 +1,15 @@
# $FreeBSD$
PORTNAME= simple-sendfile
-PORTVERSION= 0.2.11
-PORTREVISION= 5
+PORTVERSION= 0.2.15
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Cross-platform library for the sendfile() system call
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-USE_CABAL= network
+USE_CABAL= network resourcet
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/net/hs-simple-sendfile/distinfo b/net/hs-simple-sendfile/distinfo
index 74441c13ab9d..cc996f48dca6 100644
--- a/net/hs-simple-sendfile/distinfo
+++ b/net/hs-simple-sendfile/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/simple-sendfile-0.2.11.tar.gz) = d26162f7025660e9a6cb38b866522a76444a289307381a94b1d3c9b43b4d35e1
-SIZE (cabal/simple-sendfile-0.2.11.tar.gz) = 7166
+SHA256 (cabal/simple-sendfile-0.2.15.tar.gz) = 49fa29f71239f59ee9a141f9c9ca0d3e2f3428b416a822cb6abc6ff6050442b9
+SIZE (cabal/simple-sendfile-0.2.15.tar.gz) = 7321
diff --git a/net/hs-socks/Makefile b/net/hs-socks/Makefile
index bec490bd838c..92a74d95d9bd 100644
--- a/net/hs-socks/Makefile
+++ b/net/hs-socks/Makefile
@@ -1,14 +1,13 @@
# $FreeBSD$
PORTNAME= socks
-PORTVERSION= 0.5.1
-PORTREVISION= 4
+PORTVERSION= 0.5.4
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Socks proxy (version 5) implementation
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= cereal>=0.3.1 network>=2.3
diff --git a/net/hs-socks/distinfo b/net/hs-socks/distinfo
index 04a0707d1664..f084eb06116b 100644
--- a/net/hs-socks/distinfo
+++ b/net/hs-socks/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/socks-0.5.1.tar.gz) = 5e012550f7aa732a2b9a68bd69606a8c92ebcb04f45461715312aa49df5cfc23
-SIZE (cabal/socks-0.5.1.tar.gz) = 7917
+SHA256 (cabal/socks-0.5.4.tar.gz) = e9b5e1ea78592632bb086e5f4d6da523be01921a4a8998ca78552bdc396db4da
+SIZE (cabal/socks-0.5.4.tar.gz) = 8021