aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-04-30 16:26:32 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-04-30 16:26:32 +0000
commit3ebd84eadafc6adfbfffaf3d38a180c8aa131b3f (patch)
treed8db2ac45c224d55ca1c7386852b0b1434f35dcd /net
parent0cda9daa2b1bb6ba7ad36765916d7e243c3d63e5 (diff)
downloadports-3ebd84eadafc6adfbfffaf3d38a180c8aa131b3f.tar.gz
ports-3ebd84eadafc6adfbfffaf3d38a180c8aa131b3f.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/linphone-base/Makefile29
-rw-r--r--net/ndisc6/Makefile16
-rw-r--r--net/tsclient/Makefile10
-rw-r--r--net/wireshark/Makefile5
4 files changed, 27 insertions, 33 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index 6fcf25e513fb..d7f0ed69282b 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: linphone
-# Date created: 30 December 2002
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= linphone
PORTVERSION= 3.2.1
@@ -21,7 +17,8 @@ LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
CONFLICTS= ortp-[0-9]*
-USE_GNOME= glib20 gnomehack intlhack pkgconfig
+USE_GNOME= glib20 intlhack
+USES= pathfix pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure oRTP/configure mediastreamer2/configure
@@ -34,18 +31,14 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
.if defined(LINPHONE_GUI)
@@ -63,6 +56,12 @@ MAN1= linphonec.1 linphonecsh.1 sipomatic.1
SUBDIRS= po oRTP mediastreamer2 coreapi console
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|sounds/linphone|linphone/sounds|g' \
${WRKSRC}/configure
diff --git a/net/ndisc6/Makefile b/net/ndisc6/Makefile
index 6545dd57c2ef..49891f6b977e 100644
--- a/net/ndisc6/Makefile
+++ b/net/ndisc6/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ndisc6
-# Date created: 12 July 2006
-# Whom: rdenis@simphalempin.com
-#
+# Created by: rdenis@simphalempin.com
# $FreeBSD$
-#
PORTNAME= ndisc6
PORTVERSION= 1.0.2
@@ -21,14 +17,14 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-suid-install
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} >= 803000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rdnssd-rdnssd.h
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
.else
CONFIGURE_ARGS+=--disable-nls
.endif
@@ -45,11 +41,11 @@ USE_RC_SUBR= rdnssd
PORTDOCS= AUTHORS NEWS README
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index 0b23575a8c4b..6bb51d51586d 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -8,14 +8,14 @@ CATEGORIES= net gnome
MASTER_SITES= SF
MAINTAINER= ports@thepentagon.org
-COMMENT= A GNOME 2 frontend for rdesktop and vncviewer
+COMMENT= GNOME 2 frontend for rdesktop and vncviewer
RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
USE_AUTOTOOLS= libtool
USE_GNOME= gtk20
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
@@ -24,7 +24,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= tsclient.1
PORTDOCS= COPYING NEWS README
-OPTIONS_DEFINE= GNOME TIGHTVNC XNEST DOCS
+OPTIONS_DEFINE= GNOME TIGHTVNC XNEST DOCS
OPTIONS_DEFAULT= GNOME
TIGHTVNC_DESC= vncviewer support
XNEST_DESC= X via Xnest support
@@ -32,8 +32,8 @@ XNEST_DESC= X via Xnest support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNOME}
-USES= pathfix
-USE_GNOME+= gnomeprefix gnomepanel libgnomeui
+USES+= pathfix
+USE_GNOME+= gnomeprefix gnomepanel libgnomeui
.else
CONFIGURE_ARGS+= --disable-gnome
.endif
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 2509678419cb..0f30345cef5f 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -15,14 +15,13 @@ MASTER_SITES= http://www.wireshark.org/download/src/ \
DISTNAME= ${DATADIR_NAME}-${PORTVERSION}
MAINTAINER= marcus@FreeBSD.org
-COMMENT?= A powerful network analyzer/capture tool
+COMMENT?= Powerful network analyzer/capture tool
DATADIR_NAME= wireshark
USE_PERL5_BUILD=yes
USE_PYTHON_BUILD=yes
-USE_GETTEXT= yes
-USES= iconv
+USES= iconv gettext
USE_BZIP2= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes