aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2019-04-22 12:23:10 +0000
committerRenato Botelho <garga@FreeBSD.org>2019-04-22 12:23:10 +0000
commitc252f2eee792abfc5bd5140fda326e381df5173c (patch)
tree7aa76b8347180556a0ccfe6e014ae9e5d759ece8 /net
parent192b82ab14ddc1981bff6b91842518016c80a89f (diff)
downloadports-c252f2eee792abfc5bd5140fda326e381df5173c.tar.gz
ports-c252f2eee792abfc5bd5140fda326e381df5173c.zip
MFH: r499350
net/xmlrpc-c: Remove trace messages accidentally added on last super-stable version PR: 237194 Submitted by: raivo.hool@gmail.com Obtained from: https://sourceforge.net/p/xmlrpc-c/code/2981/ Sponsored by: Rubicon Communications, LLC (Netgate) Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2019Q2/; revision=499630
Diffstat (limited to 'net')
-rw-r--r--net/xmlrpc-c/Makefile1
-rw-r--r--net/xmlrpc-c/files/patch-src_cpp_value.cpp34
-rw-r--r--net/xmlrpc-c/files/patch-src_xmlrpc__string.c31
3 files changed, 66 insertions, 0 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index c349311a5a46..0a139c7088d6 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlrpc-c
PORTVERSION= 1.51.03
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/Xmlrpc-c%20Super%20Stable/${PORTVERSION}
diff --git a/net/xmlrpc-c/files/patch-src_cpp_value.cpp b/net/xmlrpc-c/files/patch-src_cpp_value.cpp
new file mode 100644
index 000000000000..aba637c10101
--- /dev/null
+++ b/net/xmlrpc-c/files/patch-src_cpp_value.cpp
@@ -0,0 +1,34 @@
+--- src/cpp/value.cpp.orig 2019-03-29 03:33:33 UTC
++++ src/cpp/value.cpp
+@@ -1,4 +1,3 @@
+-#include <iostream>
+ /*****************************************************************************
+ value.cpp
+ ******************************************************************************
+@@ -622,13 +621,9 @@ class cNewStringWrapper { (public)
+
+ switch (nlCode) {
+ case value_string::nlCode_all:
+- cerr << "Going to call xmlrpc_string_new_lp" << endl;
+- cerr << "length = " << cppvalue.length() << ", value = "
+- << cppvalue.c_str() << endl;
+ this->valueP = xmlrpc_string_new_lp(&env.env_c,
+ cppvalue.length(),
+ cppvalue.c_str());
+- cerr << "Back from xmlrpc_string_new_lp" << endl;
+ break;
+ case value_string::nlCode_lf:
+ this->valueP = xmlrpc_string_new_lp_cr(&env.env_c,
+@@ -661,12 +656,9 @@ value_string::value_string(std::string const&
+
+ value_string::value_string(std::string const& cppvalue) {
+
+- cerr << "value_string constructor entered" << endl;
+ cNewStringWrapper wrapper(cppvalue, nlCode_all);
+- cerr << "wrapper constructed" << endl;
+
+ this->instantiate(wrapper.valueP);
+- cerr << "value_string constructor exiting" << endl;
+ }
+
+
diff --git a/net/xmlrpc-c/files/patch-src_xmlrpc__string.c b/net/xmlrpc-c/files/patch-src_xmlrpc__string.c
new file mode 100644
index 000000000000..8287543239ee
--- /dev/null
+++ b/net/xmlrpc-c/files/patch-src_xmlrpc__string.c
@@ -0,0 +1,31 @@
+--- src/xmlrpc_string.c.orig 2019-03-29 03:33:33 UTC
++++ src/xmlrpc_string.c
+@@ -1,4 +1,3 @@
+-#include <stdio.h>
+ /*=============================================================================
+ xmlrpc_string
+ ===============================================================================
+@@ -746,15 +745,12 @@ stringNew(xmlrpc_env * const envP,
+ enum crTreatment const crTreatment,
+ xmlrpc_value ** const valPP) {
+
+- fprintf(stderr, "stringNew entered\n");
+ xmlrpc_value * valP;
+
+ xmlrpc_validate_utf8(envP, value, length);
+
+ if (!envP->fault_occurred) {
+- fprintf(stderr, "Going to xmlrpc_createXmlrpcValue\n");
+ xmlrpc_createXmlrpcValue(envP, &valP);
+- fprintf(stderr, "Back from createXmlrpcValue\n");
+
+ if (!envP->fault_occurred) {
+ valP->_type = XMLRPC_TYPE_STRING;
+@@ -774,7 +770,6 @@ stringNew(xmlrpc_env * const envP,
+ *valPP = valP;
+ }
+ }
+- fprintf(stderr, "stringNew exiting\n");
+ }
+
+