aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-07-02 00:42:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-07-02 00:42:58 +0000
commit12dd57234c38a6ab59d30210d9e47feae62b449a (patch)
tree3ffca2deaf65146ce915e958a19cb9d5eeb9d045 /net
parente43277becb0b2c0c7397a535096d04e2627fc23f (diff)
downloadports-12dd57234c38a6ab59d30210d9e47feae62b449a.tar.gz
ports-12dd57234c38a6ab59d30210d9e47feae62b449a.zip
net/waypipe: add new port
Notes
Notes: svn path=/head/; revision=505658
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/waypipe/Makefile47
-rw-r--r--net/waypipe/distinfo3
-rw-r--r--net/waypipe/pkg-descr5
4 files changed, 56 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3b8942e780d3..c8dbc0b7101b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1490,6 +1490,7 @@
SUBDIR += wackamole
SUBDIR += wackford-squeers
SUBDIR += wakeonlan
+ SUBDIR += waypipe
SUBDIR += whois
SUBDIR += widentd
SUBDIR += wireguard
diff --git a/net/waypipe/Makefile b/net/waypipe/Makefile
new file mode 100644
index 000000000000..5c92bad325f7
--- /dev/null
+++ b/net/waypipe/Makefile
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+PORTNAME= waypipe
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0-27
+CATEGORIES= net
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Network transparency with Wayland
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= wayland-protocols>=1.12:graphics/wayland-protocols \
+ wayland>=1.15:graphics/wayland
+LIB_DEPENDS= libffi.so:devel/libffi
+
+USES= meson pkgconfig
+USE_GITLAB= yes
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= mstoeckl
+GL_COMMIT= 360676be384d627a0a74ec1780fbbfc6379fec37
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= DMABUF FFMPEG LZ4 MANPAGES ZSTD
+OPTIONS_DEFAULT=DMABUF FFMPEG LZ4 MANPAGES ZSTD
+
+DMABUF_DESC= File descriptors used to exchange data for e.g., OpenGL applications
+DMABUF_USES= gl
+DMABUF_USE= GL=gbm
+DMABUF_LIB_DEPENDS= libdrm.so:graphics/libdrm
+DMABUF_MESON_ENABLED= with_dmabuf
+
+FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+FFMPEG_MESON_ENABLED= with_video
+
+LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
+LZ4_MESON_ENABLED= with_lz4
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
+ZSTD_MESON_ENABLED= with_zstd
+
+.include <bsd.port.mk>
diff --git a/net/waypipe/distinfo b/net/waypipe/distinfo
new file mode 100644
index 000000000000..81e728c77547
--- /dev/null
+++ b/net/waypipe/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1562026847
+SHA256 (mstoeckl-waypipe-360676be384d627a0a74ec1780fbbfc6379fec37_GL0.tar.gz) = 56312800637ee14c9923c585bb33be458185619dfb1088f4ff890ab869d89f12
+SIZE (mstoeckl-waypipe-360676be384d627a0a74ec1780fbbfc6379fec37_GL0.tar.gz) = 94472
diff --git a/net/waypipe/pkg-descr b/net/waypipe/pkg-descr
new file mode 100644
index 000000000000..047ca77fb065
--- /dev/null
+++ b/net/waypipe/pkg-descr
@@ -0,0 +1,5 @@
+waypipe is a proxy for Wayland clients. It forwards Wayland messages and
+serializes changes to shared memory buffers over a single socket. This makes
+application forwarding similar to ssh -X feasible.
+
+WWW: https://gitlab.freedesktop.org/mstoeckl/waypipe