aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-02 03:27:54 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-02 03:27:54 +0000
commit57298ea74813e4038ae96cd2196affe69181f9fc (patch)
treeedb4544b269129068fc8927705aaaa1c11d76f9a /net
parent30fe50276dc1a3d4ba4a4ee7d6755e78579df3ce (diff)
downloadports-57298ea74813e4038ae96cd2196affe69181f9fc.tar.gz
ports-57298ea74813e4038ae96cd2196affe69181f9fc.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/openldap/Makefile13
-rw-r--r--net/openldap/files/patch-db29
-rw-r--r--net/openldap/pkg-plist4
-rw-r--r--net/openldap12/Makefile13
-rw-r--r--net/openldap12/files/patch-db29
-rw-r--r--net/openldap12/pkg-plist4
-rw-r--r--net/openldap2/Makefile13
-rw-r--r--net/openldap2/pkg-plist4
-rw-r--r--net/openldap20-server/Makefile13
-rw-r--r--net/openldap20-server/pkg-plist4
-rw-r--r--net/openldap20/Makefile13
-rw-r--r--net/openldap20/pkg-plist4
-rw-r--r--net/openldap21-server/Makefile13
-rw-r--r--net/openldap21-server/pkg-plist4
-rw-r--r--net/openldap21/Makefile13
-rw-r--r--net/openldap21/pkg-plist4
-rw-r--r--net/openldap22-server/Makefile13
-rw-r--r--net/openldap22-server/pkg-plist4
-rw-r--r--net/openldap22/Makefile13
-rw-r--r--net/openldap22/pkg-plist4
-rw-r--r--net/openldap23-server/Makefile13
-rw-r--r--net/openldap23-server/pkg-plist4
-rw-r--r--net/openldap24-server/Makefile13
-rw-r--r--net/openldap24-server/pkg-plist4
24 files changed, 234 insertions, 11 deletions
diff --git a/net/openldap/Makefile b/net/openldap/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap/Makefile
+++ b/net/openldap/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap/files/patch-db b/net/openldap/files/patch-db
new file mode 100644
index 000000000000..489f067ffa89
--- /dev/null
+++ b/net/openldap/files/patch-db
@@ -0,0 +1,29 @@
+--- configure.orig Mon Jan 17 11:53:36 2000
++++ configure Thu Mar 2 18:40:40 2000
+@@ -6011,14 +6011,14 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ol_LIBS="$LIBS"
+- echo $ac_n "checking for db_open in -ldb""... $ac_c" 1>&6
+-echo "configure:6016: checking for db_open in -ldb" >&5
++ echo $ac_n "checking for db_open in -ldb2""... $ac_c" 1>&6
++echo "configure:6016: checking for db_open in -ldb2" >&5
+ ac_lib_var=`echo db'_'db_open | sed 'y%./+-:%__p__%'`
+ if eval "test \"\${ac_cv_lib_$ac_lib_var+set}\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ldb $LIBS"
++LIBS="-ldb2 $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 6024 "configure"
+ #include "confdefs.h"
+@@ -6046,7 +6046,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ol_cv_lib_db2=-ldb
++ ol_cv_lib_db2=-ldb2
+ else
+ echo "$ac_t""no" 1>&6
+ ol_cv_lib_db2=no
diff --git a/net/openldap/pkg-plist b/net/openldap/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap/pkg-plist
+++ b/net/openldap/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap12/Makefile b/net/openldap12/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap12/Makefile
+++ b/net/openldap12/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap12/files/patch-db b/net/openldap12/files/patch-db
new file mode 100644
index 000000000000..489f067ffa89
--- /dev/null
+++ b/net/openldap12/files/patch-db
@@ -0,0 +1,29 @@
+--- configure.orig Mon Jan 17 11:53:36 2000
++++ configure Thu Mar 2 18:40:40 2000
+@@ -6011,14 +6011,14 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ol_LIBS="$LIBS"
+- echo $ac_n "checking for db_open in -ldb""... $ac_c" 1>&6
+-echo "configure:6016: checking for db_open in -ldb" >&5
++ echo $ac_n "checking for db_open in -ldb2""... $ac_c" 1>&6
++echo "configure:6016: checking for db_open in -ldb2" >&5
+ ac_lib_var=`echo db'_'db_open | sed 'y%./+-:%__p__%'`
+ if eval "test \"\${ac_cv_lib_$ac_lib_var+set}\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ldb $LIBS"
++LIBS="-ldb2 $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 6024 "configure"
+ #include "confdefs.h"
+@@ -6046,7 +6046,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ol_cv_lib_db2=-ldb
++ ol_cv_lib_db2=-ldb2
+ else
+ echo "$ac_t""no" 1>&6
+ ol_cv_lib_db2=no
diff --git a/net/openldap12/pkg-plist b/net/openldap12/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap12/pkg-plist
+++ b/net/openldap12/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap2/Makefile b/net/openldap2/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap2/Makefile
+++ b/net/openldap2/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap2/pkg-plist b/net/openldap2/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap2/pkg-plist
+++ b/net/openldap2/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap20-server/Makefile b/net/openldap20-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap20-server/Makefile
+++ b/net/openldap20-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap20-server/pkg-plist b/net/openldap20-server/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap20-server/pkg-plist
+++ b/net/openldap20-server/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap20/pkg-plist b/net/openldap20/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap20/pkg-plist
+++ b/net/openldap20/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap21-server/pkg-plist b/net/openldap21-server/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap21-server/pkg-plist
+++ b/net/openldap21-server/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap21/Makefile b/net/openldap21/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap21/Makefile
+++ b/net/openldap21/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap21/pkg-plist b/net/openldap21/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap21/pkg-plist
+++ b/net/openldap21/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap22-server/pkg-plist b/net/openldap22-server/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap22-server/pkg-plist
+++ b/net/openldap22-server/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap22/Makefile b/net/openldap22/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap22/Makefile
+++ b/net/openldap22/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap22/pkg-plist b/net/openldap22/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap22/pkg-plist
+++ b/net/openldap22/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap23-server/pkg-plist b/net/openldap23-server/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap23-server/pkg-plist
+++ b/net/openldap23-server/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw