aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-11-27 23:02:28 +0000
committerCy Schubert <cy@FreeBSD.org>2011-11-27 23:02:28 +0000
commit63547acb0319a980c2c23d331318ea3b4f465e34 (patch)
tree003ea22f45c1efa5fc6bf1c725b32d48d696e3fd /net
parent71289444c9ffc8d3c3e123b72165621e55316a5e (diff)
downloadports-63547acb0319a980c2c23d331318ea3b4f465e34.tar.gz
ports-63547acb0319a980c2c23d331318ea3b4f465e34.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/ntp-devel/Makefile28
-rw-r--r--net/ntp-devel/Makefile.inc104
-rw-r--r--net/ntp-devel/distinfo4
-rw-r--r--net/ntp-devel/pkg-plist1
4 files changed, 127 insertions, 10 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index 27661d128df6..2de98904278a 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ntp
-PORTVERSION= 4.2.7p234
+PORTVERSION= 4.2.7p236
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ntp-dev/ \
http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-dev/ \
@@ -23,9 +23,11 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake libtool
USE_GNOME= gnomehack
-.if defined(ENABLE_RAWDCF)
-CONFIGURE_ARGS+= --enable-RAWDCF
-.endif
+MAN8= ntp-keygen.8 ntpd.8 ntpdc.8 ntpq.8 sntp.8 ntp-wait.8
+
+.include "Makefile.inc"
+
+.include <bsd.port.options.mk>
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --without-crypto
@@ -41,7 +43,21 @@ PLIST_SUB+= SSL=""
CONFIGURE_ARGS+= --enable-ipv6
.endif
-MAN8= ntp-keygen.8 ntpd.8 ntpdc.8 ntpq.8 sntp.8 ntp-wait.8
+.if defined(WITH_NTPSNMPD)
+PLIST_FILES+= sbin/ntpsnmpd
+BUILD_DEPENDS+= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
+RUN_DEPENDS+= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
+.else
+CONFIGURE_ARGS+= --without-ntpsnmpd
+.endif
+
+.for D in ${NTP_DRIVERS}
+.if defined(WITH_${D})
+CONFIGURE_ARGS+= --enable-${D}
+.endif
+.endfor
+
+.include <bsd.port.pre.mk>
pre-everything::
@${ECHO}
@@ -50,8 +66,6 @@ pre-everything::
@${ECHO} building and installing this port.
@${ECHO}
-.include <bsd.port.pre.mk>
-
.if exists(${LOCALBASE}/bin/net-snmp-config)
# NTP autodects net-snmp and if found builds and installs a binary that
# uses it. If detected, modify dependencies and package list.
diff --git a/net/ntp-devel/Makefile.inc b/net/ntp-devel/Makefile.inc
new file mode 100644
index 000000000000..7b9d7f414674
--- /dev/null
+++ b/net/ntp-devel/Makefile.inc
@@ -0,0 +1,104 @@
+# $FreeBSD: /tmp/pcvs/ports/net/ntp-devel/Makefile.inc,v 1.1 2011-11-27 23:02:28 cy Exp $
+
+OPTIONS= NTPSNMPD "Build and install ntpsnmpd" OFF \
+ SSL "Enable SSL" ON \
+ IPV6 "Enable IPv6" OFF \
+ BANCOMM "Enable Datum/Bancomm bc635/VME interface" OFF \
+ GPSVME "Enable TrueTime GPS receiver/VME interface" OFF \
+ ACTS "Enable ACTS modem service" OFF \
+ ARBITER "Enable Arbiter 1088A/B GPS receiver" OFF \
+ ARCRON_MSF "Enable Arcron MSF receiver" OFF \
+ AS2201 "Enable Austron 2200A/2201A GPS receiver" OFF \
+ ATOM "Enable ATOM PPS interface" OFF \
+ CHRONOLOG "Enable Chrono-log K-series WWVB receiver" OFF \
+ CHU "Enable CHU modem/decoder" OFF \
+ AUDIO_CHU "Enable CHU audio/decoder" OFF \
+ DATUM "Enable Datum Programmable Time System" OFF \
+ DUMBCLOCK "Enable Dumb generic hh:mm:ss local clock" OFF \
+ FG "Enable Forum Graphic GPS" OFF \
+ HEATH "Enable Heath GC-1000 WWV/WWVH receiver" OFF \
+ HOPFSERIAL "Enable hopf serial clock device" OFF \
+ HOPFPCI "Enable hopf 6039 PCI board" OFF \
+ HPGPS "Enable HP 58503A GPS receiver" OFF \
+ IRIG "Enable IRIG audio decoder" OFF \
+ JJY "Enable JJY receiver" OFF \
+ JUPITER "Enable Rockwell Jupiter GPS receiver" OFF \
+ LEITCH "Enable Leitch CSD 5300 Master Clock" OFF \
+ LOCAL_CLOCK "Enable local clock reference" OFF \
+ MX4200 "Enable Magnavox MX4200 GPS receiver" OFF \
+ NEOCLOCK4X "Enable NeoClock4X DCF77 / TDF receiver" OFF \
+ NMEA "Enable NMEA GPS receiver" OFF \
+ ONCORE "Enable Motorola VP/UT Oncore GPS receiver" OFF \
+ PALISADE "Enable Palisade clock" OFF \
+ PCF "Enable Conrad parallel port radio clock" OFF \
+ PST "Enable PST/Traconex 1020 WWV/WWVH receiver" OFF \
+ RIPENCC "Enable RIPENCC specific Trimble driver" OFF \
+ SHM "Enable SHM clock attached thru shared memory" OFF \
+ SPECTRACOM "Enable Spectracom 8170/Netclock/2 WWVB" OFF \
+ TRUETIME "Enable Kinemetrics/TrueTime receivers" OFF \
+ ULINK "Enable Ultralink WWVB receiver" OFF \
+ WWV "Enable WWV Audio receiver" OFF \
+ ZYFER "Enable Zyfer GPStarplus receiver" OFF \
+ COMPUTIME "Enable Diem Computime Radio Clock" OFF \
+ DCF7000 "Enable ELV/DCF7000 clock" OFF \
+ HOPF6021 "Enable HOPF 6021 clock" OFF \
+ MEINBERG "Enable Meinberg clocks" OFF \
+ RAWDCF "Enable DCF77 raw time code" OFF \
+ RCC8000 "Enable RCC 8000 clock" OFF \
+ SCHMID "Enable Schmid DCF77 clock" OFF \
+ TRIMTAIP "Enable Trimble GPS receiver/TAIP protocol" OFF \
+ TRIMTSIP "Enable Trimble GPS receiver/TSIP protocol" OFF \
+ WHARTON "Enable WHARTON 400A Series clock" OFF \
+ VARITEXT "Enable VARITEXT clock" OFF
+
+# Not supported by FreeBSD: TPRO "Enable KSI/Odetics TPRO/S GPS receiver/IRIG" OFF \
+# XXX Broken under FreeBSD: TT560 "Enable TrueTime 560 IRIG-B decoder" OFF \
+
+NTP_DRIVERS= \
+ BANCOMM \
+ GPSVME \
+ ACTS \
+ ARBITER \
+ ARCRON_MSF \
+ AS2201 \
+ ATOM \
+ CHRONOLOG \
+ CHU \
+ AUDIO_CHU \
+ DATUM \
+ DUMBCLOCK \
+ FG \
+ HEATH \
+ HOPFSERIAL \
+ HOPFPCI \
+ HPGPS \
+ IRIG \
+ JJY \
+ JUPITER \
+ LEITCH \
+ LOCAL_CLOCK \
+ MX4200 \
+ NEOCLOCK4X \
+ NMEA \
+ ONCORE \
+ PALISADE \
+ PCF \
+ PST \
+ RIPENCC \
+ SHM \
+ SPECTRACOM \
+ TRUETIME \
+ ULINK \
+ WWV \
+ ZYFER \
+ COMPUTIME \
+ DCF7000 \
+ HOPF6021 \
+ MEINBERG \
+ RAWDCF \
+ RCC8000 \
+ SCHMID \
+ TRIMTAIP \
+ TRIMTSIP \
+ WHARTON \
+ VARITEXT
diff --git a/net/ntp-devel/distinfo b/net/ntp-devel/distinfo
index 0030139e2e4e..d2f638729240 100644
--- a/net/ntp-devel/distinfo
+++ b/net/ntp-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ntp-dev-4.2.7p234.tar.gz) = 315c40fddc645d7a85e5abb5170a973d6021e3ad92b283e3ec8929390470e421
-SIZE (ntp-dev-4.2.7p234.tar.gz) = 5732935
+SHA256 (ntp-dev-4.2.7p236.tar.gz) = 18ed317bf5b34c8d929c2318c668a5cb4658bad984b4d305c0572489ffe04ce4
+SIZE (ntp-dev-4.2.7p236.tar.gz) = 5724310
diff --git a/net/ntp-devel/pkg-plist b/net/ntp-devel/pkg-plist
index 89c11f12d8b7..0ee83315bd32 100644
--- a/net/ntp-devel/pkg-plist
+++ b/net/ntp-devel/pkg-plist
@@ -4,7 +4,6 @@ sbin/ntpd
sbin/ntpdate
sbin/ntpdc
sbin/ntpq
-%%NETSNMP%%sbin/ntpsnmpd
sbin/ntptime
sbin/ntptrace
sbin/sntp